Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-09-03, 08:20 PM   #1
crazyme9
Registered User
 
Join Date: Sep 2003
Posts: 3
Send a message via AIM to crazyme9
Default Common Error But I Am Stumped

i have RH9 and have been messing with Twin veiw but it still dont work after 5 aganising days i get the error No modes remaining for display device
my xf86config is as follows:
Section "Module"
Load "dbe"
Load "record"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
Load "v4l"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
ModulePath "/usr/X11R6/lib/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "AutoRepeat" "250 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "microsoft"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "Resolution" "300"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor[0]"
ModelName "Unprobed Monitor"
VendorName "Monitor Vendor"
HorizSync 31.5-37.9
VertRefresh 50-70
EndSection

Section "Monitor"
Identifier "Monitor[1]"
ModelName "Unprobed Monitor"
VendorName "Monitor Vendor"
HorizSync 31-80
VertRefresh 56-65
EndSection

Section "Device"
BoardName "Gforce FX 5200"
Identifier "Device[0]"
VendorName "nvidia"
Driver "nvidia"
BusID "PCI:2:09:0"
Option "Dac8Bit" "3"
Option "TwinView" "on"
Option "Stereo" "3"
Option "Rotate" "off"
Option "NoTwinViewXineramaInfo" "1"
Option "NvAGP" "3"
Option "ConnectedMonitor" ""
Option "TwinViewOrientation" "RightOf"
Option "SecondMonitorHorizSync" "31-80"
Option "SecondMonitorVertRefresh" "48-65"
Option "MetaModes" "1024x768,1024x768"
Screen 0
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
Subsection "Display"
Depth 24
EndSubsection
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
Screen 0 "Screen[0]" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
Option "Xinerama" "off"
Option "Clone" "off"
EndSection
crazyme9 is offline   Reply With Quote
Old 09-13-03, 11:09 PM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

I've never used a syntax like:
Monitor[0]

instead I've always seen:
Monitor0

Are you certain the XFree86 config accepts this naming convention?
LordMorgul is offline   Reply With Quote
Old 09-14-03, 03:05 AM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

Either is a valid identifier; the problem with the configuration looks like the lack of modes in the Display subsection of the Screen section:

Code:
Section "Screen"
  Identifier "Screen[0]"
  Device "Device[0]"
  Monitor "Monitor[0]"
  DefaultDepth 24
  Subsection "Display"
    Depth 24
  EndSubsection
EndSection
You will need to define the target modes you're interested in, for example:

Code:
  ...
  Subsection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
  EndSubsection
  ...
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
VERY common mistake by people here: nV doesn't have a 12 month cycle Uttar Rumor Mill 27 09-10-02 04:46 PM

All times are GMT -5. The time now is 06:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.