Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-25-02, 08:58 AM   #1
Petz
Registered User
 
Join Date: Aug 2002
Location: Campbelltown, NSW Australia
Posts: 14
Default Desperate for help with Display problems!!!!!

Im new to linux and seem to be having a problem that no one else seems to have mentioned or I have missed from a previous post.

The problem has been exhibited across 3 different kernel versions and 2 different video cards. All of which where fresh installs.

System:
OS: Red Hat 7.3
Kernel: 2.4.18-3(Stock), 2.4.18-5, 2.4.18-10(current)
XFree86: 4.2.0
Video card: Geforce2mx(had the same problem) and a ti4200(current).

I am using the NVIDIA graphics drivers supplied on this site and got the X server to work by following the instructions in the readme for the source rpm's(Installed for the first kernel and then upgraded for the new kernel to work)

-------------------------------------------

The problem can be seen in the following picture that im going to post.

1.jpg shows a picture of mozilla with its default page. Notice the redhat graphics have not loaded properly and when the mouse is moved around fuzzy squares have started appearing.

2.jpg this is the one I want to fix the most as it makes configuring the OS and certain feautures extremely hard to use. Certain system menus/dialoges eg. Users account configuator. Are apperaing with the text extreamly small, so all i can see is squiggly black lines. Not all menus appear like this, it is only a select few which do it every time.

3.jpg is a screen cap of netscape at its default page. Now this browser seems to be working for the most part(better then mozilla atm) as im writing this article in it. However for some reason some sites are apearing with insanly large font sizes.

Any help would be greatly appreciated......
Petz is offline   Reply With Quote
Old 08-25-02, 08:58 AM   #2
Petz
Registered User
 
Join Date: Aug 2002
Location: Campbelltown, NSW Australia
Posts: 14
Default

File 1
Attached Thumbnails
Click image for larger version

Name:	1.jpg
Views:	268
Size:	70.0 KB
ID:	172  
Petz is offline   Reply With Quote
Old 08-25-02, 08:59 AM   #3
Petz
Registered User
 
Join Date: Aug 2002
Location: Campbelltown, NSW Australia
Posts: 14
Default

File 2
Attached Thumbnails
Click image for larger version

Name:	2.jpg
Views:	261
Size:	87.7 KB
ID:	173  
Petz is offline   Reply With Quote
Old 08-25-02, 09:26 AM   #4
Petz
Registered User
 
Join Date: Aug 2002
Location: Campbelltown, NSW Australia
Posts: 14
Default

3rd file is to big and i have no idea whether linux has a program in here somewhere to increase the amount of jpeg compression so ill leave it at two files.

I am hoping its just a config setting as the same thing happened with a fresh install when i had my old geforce2mx(I didnt have to load on the nvidia drivers for this just using the drivers in the distro) which suggests to me its probly isnt driver related.
Petz is offline   Reply With Quote
Old 08-25-02, 10:43 AM   #5
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

Do you have the problem too when using the "nv" driver. (That is the driver that was included with RH 7.3)

The problem really looks like a driver bug to me.

Perhaps this helps. Add a line:
Option "NoRenderAccel" to the screen or device section of your XF86Config-4 file.
Thunderbird is offline   Reply With Quote
Old 08-25-02, 01:35 PM   #6
soomon
Registered User
 
Join Date: Aug 2002
Posts: 14
Default

Hi,
I also have a Gf4 Ti4200.
How did you install the driver?
I only get error messages.
Did you use rpm's or tar's?
Which versions did you use?
soomon is offline   Reply With Quote
Old 08-25-02, 07:00 PM   #7
Petz
Registered User
 
Join Date: Aug 2002
Location: Campbelltown, NSW Australia
Posts: 14
Default

Soomon

"I am using the NVIDIA graphics drivers supplied on this site and got the X server to work by following the instructions in the readme for the source rpm's(Installed for the first kernel and then upgraded for the new kernel to work)"

I used the source rpm's and followed the readme available to install them. The version on this site is all the same i think(1.0-2960). Im probly not the person you want to ask for help but what error did you get at which stage of the install. And which way are you installing it.
Petz is offline   Reply With Quote
Old 08-25-02, 08:00 PM   #8
Petz
Registered User
 
Join Date: Aug 2002
Location: Campbelltown, NSW Australia
Posts: 14
Default

Quote:
Originally posted by Thunderbird

Do you have the problem too when using the "nv" driver. (That is the driver that was included with RH 7.3)
Yes as i stated earlier the problem existed even with the stock drivers(nv) when I was using my old geforce2mx card. First boot after a fresh install.


Quote:
The problem really looks like a driver bug to me.

Perhaps this helps. Add a line:
Option "NoRenderAccel" to the screen or device section of your XF86Config-4 file.


that didnt seem to help but thank you for the suggestion. Any other ideas? Has anyone else got this problem from a new install of redhat 7.3?
Petz is offline   Reply With Quote

Old 08-26-02, 04:58 AM   #9
soomon
Registered User
 
Join Date: Aug 2002
Posts: 14
Default

Hi,
I used the files from the NVIDIA server:
http://www.nvidia.com/view.asp?PAGE=linux
one GLX file:
GLX RPM NVIDIA_GLX-1.0-2960.i386.rpm
this kernel:
NVIDIA_kernel-1.0-2960.mdk82up.i586.rpm
and the kernel source rpm:
NVIDIA_kernel-1.0-2960.src.rpm

I always used a fresh installation so i used
rpm -ivh NVIDIA_kernel-1.0-2960.src.rpm - no problem
rpm -ivh NVIDIA_kernel-1.0-2960.mdk82up.i586.rpm - error:
modprobe: can't initialize the NVdriver kernel module
install completed successfully!
ironic, isn't it?
The GLX package produces no problem.
But the X-server:

NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0) (--) NVIDIA(0): Linear framebuffer at 0xC0000000 (--)
NVIDIA(0): MMIO registers at 0xCE000000
(EE)
NVIDIA(0): Failed to initialize the NVdriver kernel module! (EE)
NVIDIA(0): *** Aborting *** (II)
UnloadModule: "nvidia" (II) UnloadModule: "vgahw" (II)
Unloading /usr/X11R6/lib/modules/libvgahw.a (EE) Screen(s) found, but none have a usable configuration.
Fatal server error: no screens found
When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log". Please report problems to xfree86@xfree86.
soomon is offline   Reply With Quote
Old 08-26-02, 05:01 AM   #10
soomon
Registered User
 
Join Date: Aug 2002
Posts: 14
Default

Ops i forgot to tell you that I have the same problem with the tar's.
soomon is offline   Reply With Quote
Old 09-18-02, 07:11 AM   #11
Petz
Registered User
 
Join Date: Aug 2002
Location: Campbelltown, NSW Australia
Posts: 14
Default Update

Well with the new driver release I had the same problems. However not satisfied that no one else was getting these problems I dug a bit deeper to find the problem and finally success. I think it was my monitor is being fussy or lieing to the video card about what it can do(anyone want to explain?).

Shortend story follows what I did
1. Login to gnome redhat. Hold down ALT + CTRL and press F1. This takes you to a text login. So login as root. Then run "Xconfigurator". This will make you a XF86Config-4 file for the vesa(default) driver. In my case everything had to be done custom. Example my montior is a hitachi CM615 not listed so select custom and I enter the horizontal and vertical frequencies from the hardware manuel. Next is video card setup which you can either probe(didnt work) or do manually. In my case i have a ti4200 w/64mb. So select 64mb VRAM and for the Clockchip(no idea what I should have choosen) select the setting that says no clockchip(or recommended next to it). Next I think you select what resoulution that you want redhat to be able to work in use space-bar to select the ones you want I choose 1280x1024, 1024x768, and 800x600 in all three color settings 8bit, 16 and 24bit. Do a test and your done and back at the text console. If you reboot here then you shouldnt have the problems like in the jpegs I posted except your using the vesa driver not the optimised nvidia one, so read on before restarting.

2. Hold ALT + CTRL and press F7 (may take a few goes it was senstive on my system). Now go to the folder /etc/X11/ and edit the XF86Config-4 file that was just created as per the nvidia instuctions remove Load "dri", Load "GLcore" and Load "glx" should already be there.

3. Restart the PC. Now if like me you get the results in the jpeg earlier. look at the log file /var/log/XFree86.0.log
at the top of the text it explains what the symbols mean. In my case I had a stack of warnings. All of which where along the lines of this resolution needs adjusting blah blah blah EIDE blah blah. Now because Ive spent some time trying different config files and seeing what other had I added this line to the config file which fixed all my problems.

In the section for your graphics card add at the bottom
Option Option "IgnoreEDID" "true"

Oh and if like me youd prefer 24bit color over 16 then go down to the section with all the resolution and change the default color depth from 16 to 24

Save and restart your PC.

ENJOY

Also could someone take a look and explain to me in detail what each of these line in the config file does. Ill attach my file so you can see what I would like explained. Because when I was playing around with it some lines i could comment out/remove and they didnt make any obvious differences. So do I really need these?

Lastly yes I am a linux newbie so most of this is probly obvious to most of you but us newbies not in the know I beleive this could help some of us. Oh yeah and if you are like me when I first loaded redhat on it didnt detect 1 of my 2 network card and your sound card dosnt work. Go into your BIOS and disable/turn off the setting for Plug and Play(PnP) OS it works a treat

Couple of questions to.
1. Cause ive been mucking around in the root users account is there someway to reset it to the default as when I logged in the first times(redhat defaults).

2. What do I need to add the the config file to get it to default to one of the resoluton say 1024x768 at 85hz?
Attached Files
File Type: txt xf86config-4.txt (2.1 KB, 155 views)
Petz is offline   Reply With Quote
Old 09-18-02, 04:43 PM   #12
Petz
Registered User
 
Join Date: Aug 2002
Location: Campbelltown, NSW Australia
Posts: 14
Wink

Please help.........
Petz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Russian Masterpieces Put on Display Using NVIDIA GPU Technology News Archived News Items 0 06-25-12 04:10 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Problems with Mandrake and NVidia drivers..... xMonoxide187x NVIDIA Linux 2 08-22-02 01:55 PM
Suse 8.0 Dual display on Quadro 4 700XGL TheCowStir NVIDIA Linux 3 08-10-02 12:16 PM

All times are GMT -5. The time now is 04:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.