Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-15-03, 12:37 AM   #1
mstempf
Registered User
 
Join Date: Sep 2003
Location: Missouri
Posts: 2
Default Installed nvidia drivers but not seeing anything about it under /proc

All,

I just installed Redhat 9 on my machine that has a Nvidia GeForce 4 card. The install of the Nvidia driver went fine - no error messages. When I started X - I did not see the nvidia splash screen so I downloaded Yanc to see if it saw the drivers - it stated that it couldn't find the drivers or that the drivers were too old.

I reinstalled the nvidia drivers again (and it told me that it had to remove the previous installation), but again - nothing.

Plus it probes and finds the monitor that is on the digital port, but displays that information on the monitor that is on the analog port? Not sure why.

Any ideas?

Thanks,

Michael

Here is my XF86Config entries:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "VX900"
DisplaySize 380 300
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
VideoRam 131072
Option "TwinView" "TRUE"
option "SecondMonitorHorizSync" "30-80"
option "SecondMonitorVertRefresh" "50-85"
Option "MetaModes"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
mstempf is offline   Reply With Quote
Old 09-15-03, 03:21 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

You're instructing XFree86 to load the XFree86 nv driver module instead of NVIDIA's nvidia driver module; the /proc entries will only be visible when the NVIDIA kernel module is loaded (which happens in response to the NVIDIA XFree86 driver initializing on typical configurations).
zander is offline   Reply With Quote
Old 09-15-03, 06:54 AM   #3
mstempf
Registered User
 
Join Date: Sep 2003
Location: Missouri
Posts: 2
Default

Ok - so what am I suppose to do to fix this?

Michael
mstempf is offline   Reply With Quote
Old 09-15-03, 09:38 AM   #4
geowiz
Registered User
 
Join Date: Jul 2003
Location: Houston, Tx USA
Posts: 110
Default Instructions

From the readme file /usr/share/doc/NVIDIA_GLX-1.0/README do the following:

In XF86Config
replace Driver "nv" with Driver "nvidia".

Remove or comment out
Load "dri"

At the end of XF86Config file comment out:
Section "DRI"
Group 0
Mode 0666
EndSection


Restart X. If X doesn't start correctly, look at the log file in /var/log/XFree86.0.log to diagnose the problem.

Have fun .
geowiz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 12:52 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 03:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.