Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-16-12, 05:20 AM   #1
eliwap
Registered User
 
Join Date: May 2004
Posts: 88
Default Need to Reinstall 32 bit support

Hi

please find included nvidia-bug-report.log.gz

Currently running:

Nvidia GPU - GTS 450
Fedora 16 x86_64
nvidia driver: 295.49-1 (from rpmfusion - including 32bit library support)

There is a game I'm running under wine and of course, it requires 32bit support. What happens, is that almost everytime that I need to quit the game and then restart it, the game fails to start unless I uninstall and then reinstall the 32bit libraries.

When I run the game from the command line, I get the following error message.

winehq err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr


Please help me to resolve this. This is driving me a little nuts
Attached Files
File Type: gz nvidia-bug-report.log.gz (93.8 KB, 55 views)
eliwap is offline   Reply With Quote
Old 05-16-12, 09:22 AM   #2
kwizart
Registered User
 
Join Date: Feb 2005
Location: Paris, France
Posts: 129
Default Re: Need to Reinstall 32 bit support

Problem like this might be related to one or another 32bit libraries using rpath or dlopening the wrong libGL library from /usr/lib instead of trusting the system linker that will use /usr/lib/nvidia.

Is there any improvements with only running ldconfig as root instead of yum reinstall xorg-x11-drv-nvidia-libs.I686 ?

In the worst case:
rpm -e mesa-libGL.i686 --nodeps but then it will be missing from RPM dependencies perspective
kwizart is offline   Reply With Quote
Old 05-17-12, 03:46 AM   #3
eliwap
Registered User
 
Join Date: May 2004
Posts: 88
Default Re: Need to Reinstall 32 bit support

Thanks for your response kwizart and for pointing me to the appropriate locations in the file system.

There is no improvement when running ldconfig as root. I tried that quite some time ago.

I'm sure that you are already aware, when running rpm -e mesa-libGL.i686, I get:

libGL.so.1 is needed by (installed) mesa-libGLU-7.11.2-3.fc16.i686
libGL.so.1 is needed by (installed) wine-core-1.5.4-1.fc16.i686

As a consquence I am reluctant to run this --nodeps as wine may not work at all let alone the difficulties of maintaining the reliability of updates on the computer.

Based on the info you provided, I was thinking of manually recreating the links in /usr/lib/ to point the appropriate file in /usr/lib/nvidia. What do you think?

And if this works, how do we get this fixed?

Thanks again for your help

Eli

Last edited by eliwap; 05-17-12 at 06:16 AM. Reason: typo
eliwap is offline   Reply With Quote
Old 05-17-12, 03:55 PM   #4
eliwap
Registered User
 
Join Date: May 2004
Posts: 88
Default Re: Need to Reinstall 32 bit support

OK... I tried it, and it didn't work.

Any suggestions?
eliwap is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any word for official Linux support of GTX 690? georgelinux NVIDIA Linux 4 05-15-12 03:30 AM
Does 845-D support 533 Mhz FSP Penium 4s? DXnfiniteFX CPUs, Motherboards And Memory 3 10-02-02 06:50 AM
Official Detonator 40.xx Feedback Thread pelly NVIDIA Windows Graphics Drivers 299 09-22-02 07:54 AM
Athlon XP Support in Mobo? DoinkyBottoms CPUs, Motherboards And Memory 11 09-13-02 10:03 PM
Driver support for GeForce4 420 Go and Windows 98? h_happy NVIDIA Windows Graphics Drivers 12 08-26-02 12:19 AM

All times are GMT -5. The time now is 05:41 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.