Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-22-03, 03:02 PM   #1
elimgarak1359
Registered User
 
Join Date: Jul 2003
Location: Germany
Posts: 2
Angry Multiple X Screens with nVidia GeForce 4 Ti and Suse Linux 8.2 - big problem



hi folks! i am a new linux user and have big problems configuring my two displays with my nvidia card and suse linux 8.2. the trouble is, whatever I do, i can't use the two screens as separate ones, the only thing I get is I can't start the KDE session anymore or if both screen run there is only a single X screen as explained in the nVidia Readme file in APPENDIX I (CONFIGURING TWINVIEW). Then I configured XF86Config as explained in APPENDIX I (CONFIGURING TWINVIEW) and APPENDIC R (CONFIGURING MULTIPLE X SCREENS ON ONE CARD). I even tried the Option ConnectedMonitor "CRT, DFP", but it didn't help. I'll attach my XF86Config file, maybe someone arround had simmilary problems or discovers something I've overseen and can help me with some suggestions what I should change in the config file.
Attached Files
File Type: zip xf86config.zip (1.5 KB, 194 views)
elimgarak1359 is offline   Reply With Quote
Old 08-23-03, 02:36 AM   #2
Soundi
Registered User
 
Join Date: Aug 2003
Location: Finland
Posts: 2
Default

You should comment these lines:

Option "TwinView"
Option "SecondMonitorHorizSync" "30-61"
Option "SecondMonitorVertRefresh" "54-75"

Because, if you want to use Screens separate, you cannot configure it to use TwinView...
Soundi is offline   Reply With Quote
Old 09-16-03, 05:42 PM   #3
elimgarak1359
Registered User
 
Join Date: Jul 2003
Location: Germany
Posts: 2
Default

Thanks for the sugestion!

I did comment those lines and now it looks like this:

-on the first monitor everything is in german language
-on the second monitor all the shortcuts and the control pannel are also there, but everything is in english.
-if I open a window, e.g. the browser, it opens on the first monitor and it is not possible to move it to the second monitor
-the only thing that I can move on both monitors is the mouse pointer



What did I do wrong? Does anyone please have any sugestion? Please, I need your help. Or is this just the way it should work when using multiple X screens?

Below the content of my X86Config file, maybe it helps.


# /.../
# SaX generated XFree86 config file
# Created on: 2003-07-29.
#
# Version: 4.7
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.7)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "v4l"
Load "extmod"
Load "type1"
Load "freetype"
Load "dbe"
Load "speedo"
Load "glx"
EndSection

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "MapName" "Standard Keyboard [ pc105 ]"
Option "Protocol" "Standard"
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "ButtonNumber" "5"
Option "Device" "/dev/mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
HorizSync 30-61
Identifier "Monitor[0]"
ModelName "101540"
VendorName "BELINEA"
VertRefresh 54-75
UseModes "Modes[0]"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
HorizSync 30-61
Identifier "Monitor[1]"
ModelName "101540"
VendorName "BELINEA"
VertRefresh 54-75
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 101.50 1280 1296 1552 1736 1024 1024 1033 1070
Modeline "1024x768" 66.29 1024 1040 1216 1336 768 768 777 802
Modeline "1024x768" 76.49 1024 1040 1216 1336 768 768 777 802
Modeline "800x600" 40.56 800 816 928 1072 600 600 609 626
Modeline "800x600" 46.80 800 816 928 1072 600 600 609 626
Modeline "640x480" 25.96 640 656 720 864 480 480 489 501
Modeline "640x480" 29.95 640 656 720 864 480 480 489 501
Modeline "800x600" 64.06 800 840 968 1040 600 612 621 648 +HSync +VSync
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[1]"
Identifier "Screen[1]"
Monitor "Monitor[1]"
EndSection

Section "Device"
BoardName "GeForce4 Ti 4400"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
# Option "TwinView"
# Option "SecondMonitorHorizSync" "30-61"
# Option "SecondMonitorVertRefresh" "54-75"
Option "MetaModes" "1024x768, 1024x768; 800x600, 800x600; 640x480, 640x480"
VendorName "NVidia"
EndSection

Section "Device"
BoardName "GeForce4 Ti 4400"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[1]"
Screen 1
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
Screen 1 "Screen[1]" rightOf "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSectiongerman language german language

Last edited by elimgarak1359; 09-24-03 at 02:34 PM.
elimgarak1359 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:14 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.