Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-13-02, 05:18 PM   #1
ImmortalPob
Registered User
 
Join Date: Sep 2002
Posts: 5
Default Help me...

First off the critical info...

- Running Red Hat 7.3 (2.4.18-3 kernel)
- GeForrce 4 Ti 4200
- Athlon XP processor (single)
- tried ver 1.0-3123 of the driver
- got the athlon kernel driver
- rpm version

If i forgot something let me know... here is the problem...

after doing the install (both RPM) and reebooting, x would not start. So i ran Xconfigurator, but X wouldd not load even on 640X480X8bit. then i ran statx to note the version of XF89Config it was using (XF86config-4). I then removed the two lines from the config file (GLcore and ummm the other one....). tried startx again (not Xconfigurator cause it would have just screwed up those two lines again...) and X still failed to load. The final command executed was:

[GLX]: calling GLXExtensionInit

just after this line it crashed with:

Fatal server error: caught signal 11

Any ideas...
ImmortalPob is offline   Reply With Quote
Old 09-13-02, 06:17 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Please post a copy of your /var/log/XFree86.0.log and /etc/X11/XF86Config-4 files...

thanks!

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 09-13-02, 09:42 PM   #3
ImmortalPob
Registered User
 
Join Date: Sep 2002
Posts: 5
Default

Good grief you want the whole things... i gant now cause i am booted into windows ... i will tommorow...
ImmortalPob is offline   Reply With Quote
Old 09-15-02, 05:21 PM   #4
ImmortalPob
Registered User
 
Join Date: Sep 2002
Posts: 5
Default

first the config file:

# XFree86 4.2.0 configuration generated by Xconfigurator 4.10.7

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

# Red Hat Linux 6.0 and later use the xfs font server for improved
# interactive performance

Section "Files"
FontPath "unix/:7100"
EndSection

# Module loading section

Section "Module"
Load "dbe" # Double-buffering
Load "glx" # OpenGL X protocol interface
Load "extmod" # Misc. required extensions
Load "v4l" # Video4Linux
# Load "record" # X event recorder
# You only need the following two modules if you do not use xfs.
# Load "freetype" # TrueType font handler
# Load "type1" # Adobe Type 1 font handler
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "off"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Dell 1726T-HS/D1025HT"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 31.0-85.0
VertRefresh 50.0-100.0
Option "dpms"
EndSection

Section "Device"
Identifier "NVIDIA GeForce 4 (generic)"
Driver "vesa"
BoardName "Unknown"
EndSection

Section "Device"
Identifier "Linux Frame Buffer"
Driver "fbdev"
BoardName "Unknown"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Dell 1726T-HS/D1025HT"
DefaultDepth 8
Subsection "Display"
Depth 8
Modes "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection


I cant add the log now.. it makes the post too big...
ImmortalPob is offline   Reply With Quote
Old 09-15-02, 06:29 PM   #5
borgzilla
Linux Assimilator
 
Join Date: Aug 2002
Location: Scottsdale, AZ
Posts: 72
Default

Quote:
Originally posted by ImmortalPob
first the config file:

# XFree86 4.2.0 configuration generated by Xconfigurator 4.10.7

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

# Red Hat Linux 6.0 and later use the xfs font server for improved
# interactive performance

Section "Files"
FontPath "unix/:7100"
EndSection

# Module loading section

Section "Module"
Load "dbe" # Double-buffering
Load "glx" # OpenGL X protocol interface
Load "extmod" # Misc. required extensions
Load "v4l" # Video4Linux
# Load "record" # X event recorder
# You only need the following two modules if you do not use xfs.
# Load "freetype" # TrueType font handler
# Load "type1" # Adobe Type 1 font handler
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "off"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Dell 1726T-HS/D1025HT"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 31.0-85.0
VertRefresh 50.0-100.0
Option "dpms"
EndSection

Section "Device"
Identifier "NVIDIA GeForce 4 (generic)"
Driver "nvidia"
BoardName "Unknown"
EndSection

Section "Device"
Identifier "Linux Frame Buffer"
Driver "fbdev"
BoardName "Unknown"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Dell 1726T-HS/D1025HT"
DefaultDepth 24
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

I cant add the log now.. it makes the post too big...
Ok here's your modified configuration
compare and change accordingly

Don't forget init 6
borgzilla is offline   Reply With Quote
Old 09-15-02, 09:01 PM   #6
ImmortalPob
Registered User
 
Join Date: Sep 2002
Posts: 5
Default

actually fixed my own prolem, only change needed is the line driver"vesa" changed to driver "nvidia"
ImmortalPob is offline   Reply With Quote
Old 09-15-02, 09:02 PM   #7
ImmortalPob
Registered User
 
Join Date: Sep 2002
Posts: 5
Default

err crap it was driver vesa after running Xconfigurator again...
ImmortalPob is offline   Reply With Quote
Old 09-15-02, 10:08 PM   #8
utiel
Registered User
 
Join Date: Aug 2002
Location: mallorca
Posts: 65
Default XConfigurator doesn't know nvidia

If you run XConfigurator, you will notice that your XF86Config file is created as before.

You need to change "nv" to "nvidia" , adding Load "glx", delete Load "dri" , Load "GLcore" and customize your options.

In RedHat, XConfigurator doesn't do this.
It use "nv" driver, or "vesa" driver. Never "nvidia".

I don't know any program or script that make this job for us.

backup your XF86Config file before running XConfigurator, and then, modify it manually.
utiel is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:37 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.