Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-29-12, 06:25 PM   #1
Luno
Registered User
 
Join Date: May 2012
Posts: 1
Default Option "Coolbits" has no effect

Hi,

I'm trying to get fan control working with an old GeForce 6600 GT by adding

Code:
Option "Coolbits" "4"
to my xorg.conf. This should unlock the fan control in nvidia-settings (and it does, working like a charm on another PC with a GTS450).

However, it doesn't seem to work with the 6600 GT. The fan is definitely controllable, setting the speed of the fan in Windows is working fine (using the gainward xpert tool). nvidia-settings is also reporting the fan speed as "Variable", indicating that speed control is possible.

The fan is permanently at 100%, which is pretty noisy and gets really annoying after some time, not to mention that it's completely unnecessary because I'm not planning to anything in the 3rd dimension with that old rig. I'd hate to have to change to Windows completely just because of that stubborn fan

What I've tried so far:

- Setting Coolbits to every value from 1 - 7. (You never know...)
- Trying different drivers (currently back at 295.40)
- nvclock (outdated and broken)

OS is Linux Mint 13 x64, xorg.conf is looking like this:

Code:
Section "Device"
	Identifier	"Default Device"
	Option	"NoLogo"	"True"
	Option "Coolbits" "4"
EndSection
What am I missing? Any hints appreciated.
Luno is offline   Reply With Quote
Old 06-21-12, 12:18 AM   #2
mynis01
Registered User
 
Join Date: Jun 2012
Posts: 1
Default Re: Option "Coolbits" has no effect

Unfortunately, it appears that coolbits and nvclock do not work with cards from the 400/500/600 series, and who knows which others. If your card is supported, it is also possible that you have to instead modify
Code:
/etc/X11/xorg.conf.d/20-nvidia.conf
mynis01 is offline   Reply With Quote
Old 06-21-12, 03:49 AM   #3
djanssen
Registered User
 
Join Date: Jul 2006
Location: Germany
Posts: 8
Default Re: Option "Coolbits" has no effect

It seems to work with (6600GT, 302.17):

xorg.conf:
option "Coolbits" "5"

and
nvidia-settings -a [gpu:0]/GPUFanControlState=1 -a [fan:0]/GPUCurrentFanSpeed=97

DJanssen
djanssen is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM
TwinView in RedHat 8 nerfherder64 NVIDIA Linux 5 10-07-02 08:19 PM
Xtacy t14600, Redhat 7.3.. X but no logo. Rob C. NVIDIA Linux 8 08-12-02 10:28 AM
Dual Display with main CRT, and secondary TV-out BlackDogg NVIDIA Linux 3 08-10-02 10:52 AM
RedHAT didn't like nVidia GeForce 4 MX 440 alfa2k1 NVIDIA Linux 13 08-09-02 06:06 PM

All times are GMT -5. The time now is 07:27 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.