Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-18-12, 09:57 AM   #1
Lamieur
The god of fertility
 
Lamieur's Avatar
 
Join Date: Apr 2006
Posts: 24
Default [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine

Hello,

Title might sound more dramatic than it really is. After upgrading to 302.17, I was greeted with login screen on low resolution and refresh rate.

In Xorg.0.log there's information like:
[ 1350.735] (WW) NVIDIA(0): Error while parsing panning domain in mode description
[ 1350.735] (WW) NVIDIA(0): "1152x864@120"

Not only I'm using modes like this for ages, ALL the modeline calculators on the Internet produce modes with "@" followed by refresh rate.

Now every ModeLine containing "@" is rejected.

Work around was to replace every "@" with "_" in xorg.conf and all looks working.

I hope this helps someone :)
Lamieur is offline   Reply With Quote
Old 06-19-12, 10:49 PM   #2
mlord
Linux kernel hacker
 
Join Date: Feb 2009
Location: Ottawa, Canada
Posts: 173
Default Re: [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine

Quote:
Originally Posted by Lamieur View Post
Hello,

Title might sound more dramatic than it really is. After upgrading to 302.17, I was greeted with login screen on low resolution and refresh rate.

In Xorg.0.log there's information like:
[ 1350.735] (WW) NVIDIA(0): Error while parsing panning domain in mode description
[ 1350.735] (WW) NVIDIA(0): "1152x864@120"

Not only I'm using modes like this for ages, ALL the modeline calculators on the Internet produce modes with "@" followed by refresh rate.

Now every ModeLine containing "@" is rejected.

Work around was to replace every "@" with "_" in xorg.conf and all looks working.

I hope this helps someone
Ouch. That's a nasty bug.
mlord is offline   Reply With Quote
Old 06-20-12, 11:43 AM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine

Thanks for reporting this. I filed bug 1003603.
AaronP is offline   Reply With Quote
Old 06-20-12, 07:14 PM   #4
Lost Dog
Registered User
 
Join Date: Aug 2007
Posts: 151
Default Re: [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine

I've had this same issue so I've been using 29X.XX series on my HTPC. I thought it may have been some change in how modelines were handled and didn't bother investigating it!

Let me know if you need any additional logs from another user's system.
Lost Dog is offline   Reply With Quote
Old 06-22-12, 08:16 AM   #5
mlord
Linux kernel hacker
 
Join Date: Feb 2009
Location: Ottawa, Canada
Posts: 173
Default Re: [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine

Mmm.. related to this, perhaps: MythtTv-0.24-fixes (mythfrontend) seems to be unable to use xrandr to change screen refresh rates with the new 302.xx drivers. The exact same xorg.conf file works fine with 295.53 (even with all of the '@' symbols changed to '_' so they don't get ignored by the newer driver).

Looks like a beta release, not ready for production just yet.
mlord is offline   Reply With Quote
Old 06-22-12, 08:24 AM   #6
mlord
Linux kernel hacker
 
Join Date: Feb 2009
Location: Ottawa, Canada
Posts: 173
Default Re: [WARNING] 302.17 doesn't accept modelines 295.53 and older did just fine

Quote:
Originally Posted by mlord View Post
Here's the code from MythTV
Wrong os -- that was for OS/X. Still digging here.
mlord is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:17 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.