Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-23-03, 04:20 PM   #1
C4mper
Registered User
 
Join Date: Sep 2003
Posts: 4
Send a message via ICQ to C4mper
Question Kernel Mismatch 2.4.20-4GB and 2.4.20-4GB-athlon

Hello.

I?ve just tried to reinstall the nvidia graphics driver on my system. I?ve run sh NVIDIA-linux-4496.pg2.run and first it aborted at the point of kernel creation with an error. After entering
export IGNORE_CC_MISMATCH=yes
it came further on and compiled the kernel module but stopped due to the wrong kernel. Log says its a kernel mismatch between 2.4.20-4GB and my 2.4.20-4GB-athlon. But there is no other kernel source I could download.

Where is my mistake? Can I bypass that checkup?

Thanks a lot. At the moment I run XFree86-4 with "nv" driver, so it works, but that can?t be the solution.

C4mper aka Philipp
__________________
NVidia Geforce4 4200Ti
AMD Athlon
Suse Linux 8.2
Kernel 2.4.20-4GB-athlon

Last edited by C4mper; 09-23-03 at 04:28 PM.
C4mper is offline   Reply With Quote
Old 09-23-03, 09:15 PM   #2
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

Hi,

Where did you run that file from as you need to use the one that came from suse update.

Start suse in safe mode, login as root and type cd /usr/share/doc/nvidia

Then type:

./NVIDIA-Linux-x86-1.0-4496.pkg2.run

Then just reboot.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0

Last edited by SuLinUX; 09-23-03 at 09:23 PM.
SuLinUX is offline   Reply With Quote
Old 09-24-03, 04:27 AM   #3
C4mper
Registered User
 
Join Date: Sep 2003
Posts: 4
Send a message via ICQ to C4mper
Default

Originally posted by SuLinUX
> Where did you run that file from as you need to use the one that came from suse update.

My file NVIDIA-Linux-x86-1.0-4496.pkg2.run comes from nvidia download page. My kernel sources come from SuseUpdate, sure!

> Start suse in safe mode, login as root and type cd /usr/share/doc/nvidia
Running in safe mode is clear due to not running X. Root is clear. In that given directory is NVIDIA_GLX1.0, nothing else...
[QOUTE]
Then type:
./NVIDIA-Linux-x86-1.0-4496.pkg2.run [/quote]
I?ve never done anything else, but not from that directory above, which should not make any difference at all.

I would like to post my /var/log/nvidia-installer.log, but that seems to be quite long and finishs with :
...
Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
4496). As part of installing this driver (version: 1.0-4496), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Kernel include path: '/lib/modules/2.4.20-4GB-athlon/build/include'
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f nv.o os-agp.o os-interface.o os-registry.o nv-linux.o nv_compiler.h *
.d NVdriver nvidia.o
-> Building kernel module:
executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/lib/modules/2.4.20-4G
B-athlon/build/include'...
You appear to be compiling the NVIDIA kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.
If you know what you are doing and want to override this check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1
-> Error.
...
So i have set IGNORE_CC_MISMATCH=yes and it runs fine by compiling a new kernel interface for 2.4.20-4GB. But then he mismatches with my running kernel as I wrote in the title.
How should I set the CC environment variable to the name of the compiler? What compiler has SuSE used?

Thanky for help, but I suppose the solution above does not seem to be one.

Philipp


Quote:
Then just reboot. [/b]
Yeah, good old windows times. Just reboot
__________________
NVidia Geforce4 4200Ti
AMD Athlon
Suse Linux 8.2
Kernel 2.4.20-4GB-athlon

Last edited by C4mper; 09-24-03 at 04:35 AM.
C4mper is offline   Reply With Quote
Old 09-24-03, 07:24 AM   #4
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

Did you install a kernel update?

I dont bother with kernel updates as I cannot get the drivers to work in 3D.

Sorry you dont have to reboot just startx.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 09-24-03, 09:39 AM   #5
C4mper
Registered User
 
Join Date: Sep 2003
Posts: 4
Send a message via ICQ to C4mper
Default

Actually I?ve tried to update the kernel manually by compiling a newer one. That did not run that fine, so I reinstalled the original kernel with Suse Update, same with the sources. I thought that everything would be fine afterwards. But I have to reinstall the nvidia driver and that does not work...

Isn?t there any nvidia pro reading this? A moderator? I?ve got no idea what went wrong but it only seems to be the kernel mismatch, but I don?t know why!

When I try to install the driver with

sh NVIDIA-linux-1.0-4496.pk2.run --use-kernel-name="2.4.20-4GB" or something like that, he installs it succesfully, but I still can?t use it in my configuration of XFree86-4.

What informations does anyone need, i?ll give them to you. But I do need help, please.

C4mper
__________________
NVidia Geforce4 4200Ti
AMD Athlon
Suse Linux 8.2
Kernel 2.4.20-4GB-athlon
C4mper is offline   Reply With Quote
Old 09-24-03, 10:54 AM   #6
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

I have the same version as you and had the same problem, when you reinstalled the kernel did you do it from the suse cd?

The one on suse update is 2.4.20-100, to get the nvidia drivers working again I reinstalled the original 2.4.20-38 kernel.

Now I have the drivers working again, seems to me you have the same problem.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 09-24-03, 12:58 PM   #7
C4mper
Registered User
 
Join Date: Sep 2003
Posts: 4
Send a message via ICQ to C4mper
Default

Har Har Har
Everythings fine now. Got the solution over your idea, even if it was not the solution. When you update kernel and kernel-source (as me to 2.4.20SuSE-100) we should read the NVIDIA-HowTo on Suse homepage under
ftp://ftp.suse.com/pub/suse/i386/sup...ler-HOWTO.html

As you read there, you have to 'configure' the kernel source by executing
make cloneconfig && make dep and export IGNORE_CC_MISMATCH=YES.
After that everything runs fine.

But I?ver learned a lot

Maybe it works for you, too!

C4mper
__________________
NVidia Geforce4 4200Ti
AMD Athlon
Suse Linux 8.2
Kernel 2.4.20-4GB-athlon
C4mper is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:38 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.