Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-13-12, 08:00 AM   #1
Stingray
Registered User
 
Join Date: Oct 2007
Location: Austin, TX
Posts: 17
Default Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE

I have two similar systems that I have upgraded from Fedora 15 to Fedora 17 recently. I'm using the RPM Fusion packages for the 295.59 NVIDIA driver, and all current Fedora 17 updates (which means Xorg server 1.12.2).

One of the systems has a GTX 460 SE. That one runs fine.

The other system has a 9300 GE, and after being logged in for a while (let's say 24 hours), things start to slow to a crawl. Xorg uses near-100% CPU when rapidly moving your mouse between windows (using focus-follows-mouse). Trying to use Firefox is awful, everything goes in slow motion. Logging out and back in to restart Xorg solves the problem, temporarily of course.

This is easily reproduceable and has happened every day for the last week or two. I tried the Nouveau driver instead of the NVIDIA driver and the problem went away as expected, but I'd rather use the NVIDIA driver for various reasons.

Is there a known issue with older cards (ie 9 Series) and the latest NVIDIA drivers?

Is there any easy way to use the older drivers (I believe I was using 280.13 on Fedora 15, and had no problems) with Fedora 17, to at least test that? RPM Fusion doesn't seem to have them available for F17. And getting NVIDIA drivers running without RPM Fusion packages seems to be a real nightmare in recent Fedora versions.

I did try using the 173xx drivers from RPM Fusion (for the 9300 GE system), and with those drivers, the slowness occurs right off the bat. You don't even have to wait the 24 hours to see it.
Stingray is offline   Reply With Quote
Old 07-13-12, 12:58 PM   #2
kwizart
Registered User
 
Join Date: Feb 2005
Location: Paris, France
Posts: 129
Default Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE

You need to attach the output of nvidia-bug-report.sh

I don't remeber if 280.13 is compatible with xorg-server 1.12, it's not according to:
http://us.download.nvidia.com/XFree8...uirements.html

You can try to reproduce on F-15 but with the 295.53 packages from rpmfusion-nonfree-updates-testing. (You will need the kernel from fedora updates-testing for pre-built kmod).

Now the other way would be to grab the lastest nvidia packages ( xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs akmod-nvidia) from:
http://download1.rpmfusion.org/nonfr...ide/x86_64/os/
You will need to install kernel-devel and run akmods --force
kwizart is offline   Reply With Quote
Old 07-13-12, 01:08 PM   #3
Stingray
Registered User
 
Join Date: Oct 2007
Location: Austin, TX
Posts: 17
Default Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE

Here's the bug report file.

I'll give the newer (beta?) versions a try later on.
Attached Files
File Type: gz nvidia-bug-report.log.gz (44.6 KB, 33 views)
Stingray is offline   Reply With Quote
Old 07-13-12, 02:12 PM   #4
kwizart
Registered User
 
Join Date: Feb 2005
Location: Paris, France
Posts: 129
Default Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE

The beta driver is now available.

To witch problem the video=vesa:off vga=normal is the solution ? I expect it to have no effect toward grub2 graphical boot that make early vesa initialization.
kwizart is offline   Reply With Quote
Old 07-13-12, 02:17 PM   #5
Stingray
Registered User
 
Join Date: Oct 2007
Location: Austin, TX
Posts: 17
Default Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE

Without the "video=vesa:off vga=normal", I get the complaint at bootup about "NVRM: Your system is not currently configured to drive a VGA console" etc etc. With it, I don't. Not sure that it matters, though. Anyway, I've tested it both ways, and the slowdown happens either way.
Stingray is offline   Reply With Quote
Old 07-14-12, 11:07 AM   #6
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE

Quote:
Originally Posted by Stingray View Post
Without the "video=vesa:off vga=normal", I get the complaint at bootup about "NVRM: Your system is not currently configured to drive a VGA console" etc etc. With it, I don't. Not sure that it matters, though. Anyway, I've tested it both ways, and the slowdown happens either way.

Try the beta


Code:
su
yum --enablerepo rpmfusion-nonfree-rawhide update *\nvidia\*
__________________
leigh123linux
leigh123linux is offline   Reply With Quote
Old 07-14-12, 11:18 AM   #7
Stingray
Registered User
 
Join Date: Oct 2007
Location: Austin, TX
Posts: 17
Default Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE

Yep, already got the 304.22 beta from RPM Fusion running on both computers, should know results on the 9300 GE system within a day or two.
Stingray is offline   Reply With Quote
Old 08-07-12, 03:47 AM   #8
Stingray
Registered User
 
Join Date: Oct 2007
Location: Austin, TX
Posts: 17
Default Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE

Figured out the problem. It isn't the card model. It's VMware Workstation.

I run VMware Workstation with a Windows XP VM on the system with the 9300 GE card (but not the system with the GTX 460 SE card). Running NVIDIA's Linux driver (including the latest beta) + VMware Workstation on Fedora 17, causes video to drag to a crawl within 24-48 hours.

I switched from VMware to VirtualBox and the problem went away.

Note that the problem doesn't happen with Nouveau, though. So I don't know if it's a VMware problem or an NVIDIA problem. Likely VMware though, as its kernel modules haven't been updated in a while and it doesn't officially support Fedora 17.
Stingray is offline   Reply With Quote

Old 08-07-12, 04:04 PM   #9
xorbe
Unbuffered User
 
Join Date: Jun 2005
Posts: 388
Default Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE

Oooh I see something like this too -- vncviewer repaints start getting really slow, before everything goes into a death spiral ("NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context" and black boxes on the screen, and 2 second hangs, etc.) with 295.59 64-bit that is.

Not using vmware, just vncviewer.

Last edited by xorbe; 08-08-12 at 04:54 PM.
xorbe is offline   Reply With Quote
Old 08-07-12, 08:51 PM   #10
Stingray
Registered User
 
Join Date: Oct 2007
Location: Austin, TX
Posts: 17
Default Re: Xorg slows to a crawl on Fedora 17 w/ 295.59 on 9300 GE

Are you using VMware or no?
Stingray is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to modify brightness with driver 295.59 and xorg 1.11.4 lorenrookie NVIDIA Linux 0 06-22-12 08:03 AM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM

All times are GMT -5. The time now is 03:59 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.