Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-13-12, 09:39 PM   #1
joegiampaoli
Registered User
 
Join Date: Jan 2009
Posts: 23
Default Terribly slow FPS in glxguears with 304.37 driver

Just tried driver 304.37 on Debian "Squeeze" 32bit - GeForce 210

Everything worked well except I always like to launch glxgears as a tool to test all is well (like not too low FPS), I never use it as a real tool for precision testing, just for basic checking that acceleration is working ok, but I did notice the FPS were like really low this time:

With previous 295.71 I get like 16700 Frames per each 5 seconds
With newer 304.37 I got like 300 Frames per every 5 seconds.

So I went back to previous version.

Anyway, as I said, glxgears should never be considered an optimal tool for measuring FPS but for sure something must be wrong right?

Thanks!
joegiampaoli is offline   Reply With Quote
Old 08-13-12, 09:46 PM   #2
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: Terribly slow FPS in glxguears with 304.37 driver

This explains why you have less fps with 304.37

http://www.nvnews.net/vbulletin/showthread.php?t=176815
Quote:

With newer 304.37 I got like 300 Frames per every 5 seconds.

300 frames divided by 5 seconds = 60 fps which = the screen refresh rate (this means sync-to-vblank is on).
__________________
leigh123linux
leigh123linux is offline   Reply With Quote
Old 08-14-12, 01:51 AM   #3
artem
Registered User
 
Join Date: Jun 2006
Posts: 703
Default Re: Terribly slow FPS in glxguears with 304.37 driver

google: vsync
artem is offline   Reply With Quote
Old 08-17-12, 05:44 PM   #4
pvelkovski
Registered User
 
Join Date: Sep 2010
Posts: 6
Default Re: Terribly slow FPS in glxguears with 304.37 driver

You will get the same "slow" FPS rate if in 295.71, you start the NVidia X server settings application, and then under the OpenGL setting you thick the Sync to VBlank option. What I'm trying to prove to you is that as far as this is concerned, there is no actual bug in the 304.37.

Last edited by pvelkovski; 08-17-12 at 08:45 PM. Reason: spelling error
pvelkovski is offline   Reply With Quote
Old 08-24-12, 05:57 AM   #5
sjlopezb
Registered User
 
Join Date: Mar 2012
Posts: 34
Default Re: Terribly slow FPS in glxguears with 304.37 driver

Quote:
Originally Posted by leigh123linux View Post
(...)
300 frames divided by 5 seconds = 60 fps which = the screen refresh rate (this means sync-to-vblank is on).
And also disabled.
sjlopezb is offline   Reply With Quote
Old 08-24-12, 06:01 AM   #6
sjlopezb
Registered User
 
Join Date: Mar 2012
Posts: 34
Default Re: Terribly slow FPS in glxguears with 304.37 driver

To all this.

Does it have to do with the TrueBuffer activated?
sjlopezb is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:51 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.