Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-03-12, 03:21 PM   #1
eskuai
Registered User
 
Join Date: Aug 2007
Posts: 35
Default error messages NVRM: Your system is not currently configured to drive a VGA console

Hello,

New kernel fedora 17 kernel Linux darkstar 3.5.3-1.fc17.i686.PAE #1 SMP , and nvidia drviers 304.37

$dmesg

shows...

[ 24.619093] NVRM: GPU at 0000:01:00: GPU-4d6bc212-5e3b-e73a-2c72-deee66be43b1
[ 24.619100] NVRM: Your system is not currently configured to drive a VGA console
[ 24.619104] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[ 24.619107] NVRM: requires the use of a text-mode VGA console. Use of other console
[ 24.619109] NVRM: drivers including, but not limited to, vesafb, may result in
[ 24.619112] NVRM: corruption and stability problems, and is not supported.

nvidia bug attached
Attached Files
File Type: gz nvidia-bug-report.log.gz (75.4 KB, 50 views)
eskuai is offline   Reply With Quote
Old 09-03-12, 10:53 PM   #2
artem
Registered User
 
Join Date: Jun 2006
Posts: 704
Default Re: error messages NVRM: Your system is not currently configured to drive a VGA conso

You have vesafb enabled, either disable it or don't pay attention to these messages.

Code:
[    0.744082] vesafb: mode is 640x480x32, linelength=2560, pages=0
[    0.744083] vesafb: scrolling: redraw
[    0.744085] vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    0.744137] vesafb: framebuffer at 0xef000000, mapped to 0xf7e80000, using 1216k, total 1216k
[    0.744187] Console: switching to colour frame buffer device 80x30
[    0.784429] fb0: VESA VGA frame buffer device
It's not clear why it gets enabled, but probably you'll need to remove "rhgb", or pass "vga=normal nomodeset" to your kernel.
artem is offline   Reply With Quote
Old 09-04-12, 02:21 AM   #3
kwizart
Registered User
 
Join Date: Feb 2005
Location: Paris, France
Posts: 129
Default Re: error messages NVRM: Your system is not currently configured to drive a VGA conso

This error occur since grub2 enable graphical boot.
This can be disabled at the kernel side by using a the kernel boot line :
Code:
video=vesa:off vga=normal
But then I was searching the root cause and I think I've managed to get rid of the problem at the grub2 level using:
GRUB_VIDEO_BACKEND=true as a grub env. This can probably be made available from a file in /etc/grub.d.

This will disable graphical boot from grub2. So I don't know which solution is the best.
kwizart is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:26 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.