Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-01-03, 07:36 AM   #1
NetzPeter
Registered User
 
Join Date: Oct 2003
Posts: 2
Default HighResolution in textmode?

Hi, can anybody give me a hint for this?

I recently downloaded the latest NVIDIA driver and installed it successfully on RedHat 9. Now I want to use the textmode (not X!) in a high resolution mode but there is no information about how to edit /etc/TextConfig (chipset, clocks, clockchip).

Thx in advance,

Peter
NetzPeter is offline   Reply With Quote
Old 10-01-03, 06:35 PM   #2
connyosis
Eggplant
 
connyosis's Avatar
 
Join Date: May 2003
Location: Sweden
Posts: 86
Send a message via ICQ to connyosis
Default

Dunno if this is what you mean, but you can add a line like this vga=ask to your kernel line in grub or lilo. When you then reboot lilo/grub will scan for available video modes. Try out which one you like and then when you're happy replace vga=ask with vga=<mode>.

For me my kernel line in grub.conf looks like this:
kernel (hd0,0)/boot/linux260t6-acpi root=/dev/hda5 hdd=ide-scsi vga=0x0164
__________________
"Never bump a baby carriage out of a crosswalk unless the kid's really asking for it."
connyosis is offline   Reply With Quote
Old 10-02-03, 06:45 AM   #3
NetzPeter
Registered User
 
Join Date: Oct 2003
Posts: 2
Default

Hello connyosis,

thanks, it's not exactly what I wanted but now it looks much better.

Probably I should tell that I want to have a resolution of 1280x1024 not the simple vga mode. I posted my question late in the evening, so I was a little bit too tired to be more precisely ;-) .

Peter
NetzPeter is offline   Reply With Quote
Old 10-02-03, 07:14 AM   #4
connyosis
Eggplant
 
connyosis's Avatar
 
Join Date: May 2003
Location: Sweden
Posts: 86
Send a message via ICQ to connyosis
Default

Oh, you want to use framebuffer. Well, then you need to make sure your kernel has support for framebuffer devices, and the riva chip. (Both riva and geforce cards uses that driver)
Then instead of 0x0164 as in my example you enter another value. I haven't used framebuffer in a long time, I think it's too slow, but use google and you're bound to find a good howto somewhere.
__________________
"Never bump a baby carriage out of a crosswalk unless the kid's really asking for it."
connyosis is offline   Reply With Quote
Old 10-02-03, 01:02 PM   #5
_tf_
scriptfoo warrior
 
_tf_'s Avatar
 
Join Date: Apr 2003
Location: here
Posts: 117
Default

use vesafb and disable rivafb, because nvidia x drivers dont like rivafb.

then use vga="your number" usually 792
in grub/lilo

when you get a blank screen at boot
try this patch
http://bugzilla.kernel.org/show_bug.cgi?id=777
_tf_ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.