Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-05-03, 07:34 PM   #1
Phasmus
Registered User
 
Join Date: Oct 2003
Posts: 3
Default 4496 Upgrade Disabled 3d Programs

Greetings,

I'm a linux semi-newbie (I've used Linux for a while, but never delved into the guts of it much) running Mandrake 9.1 with a GeForce Ti4200 on a 2600 Athalon system.

I just installed the 1.0-4349 drivers and, at long last, all of those 3d-ish games my little brother wants to play (i.e. Tuxracer, Chromium) started running at full speed. Then I ran nvidia update to bring the drivers to version 1.0-4496... and now none of those programs will load. In KDE the menu bar will show up for a few seconds with with the rotating hour glass on top, and then they shut down entirely. I tried downgrading (Just running the original 4349 installer), with the same results. I feel that the answer must be fairly simple, perhaps as little as tweaking a config file somewhere... but I have no idea what to do.

Thanks for any help that can be provided.
Attached Files
File Type: log xfree86.0.log (25.7 KB, 174 views)
Phasmus is offline   Reply With Quote
Old 10-07-03, 10:32 AM   #2
Phasmus
Registered User
 
Join Date: Oct 2003
Posts: 3
Default

Additional Data:
glxgears still runs, and at quite a respectable frame rate (though the animation itself looks quite jerky)... if that is of any relevance to this situation.
Phasmus is offline   Reply With Quote
Old 10-08-03, 11:06 AM   #3
Phasmus
Registered User
 
Join Date: Oct 2003
Posts: 3
Default

Additional Data:

I have carefully performed all of the steps suggested in this portion of the FAQ to no avail:

Q: X starts for me, but OpenGL applications terminate immediately.

A: If X starts, but OpenGL causes problems, you most likely have a
problem with other libraries in the way, or there are stale symlinks.
See Appendix C for details. Sometimes, all it takes is to rerun
'ldconfig'.

You should also check that the correct extensions are present;
'xdpyinfo' should show the "GLX", "NV-GLX" and "NVIDIA-GLX" extensions
present. If these three extensions are not present, then there is
most likely a problem with the glx module getting loaded or it is
unable to implicitly load GLcore. Check your XF86Config file and make
sure that you are loading glx (see "Editing Your XF86Config File"
above). If your XF86Config file is correct, then check the XFree86
log file for warnings/errors pertaining to GLX. Also check that all
of the necessary symlinks are in place (refer to Appendix C).

---

The files and symlinks seem to be intact. As far as I could tell (via ldd) Tuxracer, etc, was accessing the proper files. The only oddity was this: of the files created in /dev (according to Appendix C) the only ones I could find were nvidia0 and nvidiactl. Even though I had just reinstalled the driver, there was no sign of nvidia1, 2 or 3. I do not know if this has anything to do with my problem, or how to try to fix it if it does. (Extract the drivers manually and copy the files to the directory?)
Phasmus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with configuring monitors and keeping them disabled with 302.17 Erosmith NVIDIA Linux 2 06-20-12 12:10 AM
Podcast: SCINET Derives 100 Teraflops from InfiniBand Upgrade News Archived News Items 0 06-17-12 02:00 AM
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 03:55 AM
To upgrade, or not to upgrade... jnd3 Microsoft Windows XP And Vista 18 09-13-02 11:09 AM

All times are GMT -5. The time now is 09:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.