Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-03-11, 04:31 PM   #1
Steffen M.
Registered User
 
Join Date: Jul 2005
Posts: 5
Default Fan speed of GTX 580 stuck at about 30 %

Hi all,

I've got a problem with my GTX 580 (Gainward GeForce GTX 580 Phantom 3GB) under Linux (openSUSE 11.3, x86-64, Kernel: 2.6.35.14, NVIDIA drivers: 280.13). From time to time the fan of my GTX has been being stuck at about 30 % - which is the idle speed - and has not started to rotate faster under high load (e.g. while doing CUDA calculations). It's not always exactly 30 %, at the moment it is stuck at 34 %, for example. This low fan speed results in GPU temperatures of about 96C which I, of course, don't want to run my GPU at.

The problem doesn't occur always, only from time to time. When it occurs, only rebooting the machine helps to solve it for a while. Then, after some days of running without any problems, it starts to occur again.

My questions are: Does anybody else have this problem? What would be the solution for it?

"nvclock" unfortunately doesn't support the GTX 5xx series. "nvidia-settings" can't be used to modify the fan speed, either. While I've set the option "Coolbits" "5" in xorg.conf, it seems that this option is not applied to the GTX 580, as this card is actually not used for X in my setup. I have an old 6600GT which does the graphics (and is used by X). The GTX580 is only used for calculations.

Thank you very much in advance!

Regards,
Steffen
Steffen M. is offline   Reply With Quote
Old 11-03-11, 07:51 PM   #2
kometata
Registered User
 
Join Date: Apr 2011
Posts: 12
Default Re: Fan speed of GTX 580 stuck at about 30 %

Quote:
Originally Posted by Steffen M. View Post
"nvclock" unfortunately doesn't support the GTX 5xx series. "nvidia-settings" can't be used to modify the fan speed, either. While I've set the option "Coolbits" "5" in xorg.conf, it seems that this option is not applied to the GTX 580, as this card is actually not used for X in my setup. I have an old 6600GT which does the graphics (and is used by X). The GTX580 is only used for calculations.

Thank you very much in advance!

Regards,
Steffen
Just follow these instructions:
http://blog.cryptohaze.com/2011/02/n...-headless.html

i.e. temporary connect a second monitor (there is also another way) and then just add in the Section "Screen":
Option "ConnectedMonitor" "CRT"
Option "Coolbits" "5"
and you will be able to control the fans. I use that and it works under Suse and GTX580 3GB.

Regards,
kometata is offline   Reply With Quote
Old 11-04-11, 06:02 AM   #3
Steffen M.
Registered User
 
Join Date: Jul 2005
Posts: 5
Default Re: Fan speed of GTX 580 stuck at about 30 %

Quote:
Originally Posted by kometata View Post
Thanks a lot! This should be a possible work-around for my problem. I'll try it as soon as possible.

Nevertheless I still wonder why the fan speed control gets stuck from time to time. This is not what the whole fan control thing was inteded for. I run the most recent video card BIOS which is offered by Gainward. Yesterday, after submitting my posting I upgraded the drivers from 280.13 to 285.05.09. Perhaps this fixes it. But I don't even know in how far the driver is involved in the fan control...

Regards,
Steffen
Steffen M. is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:15 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.