Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-13-03, 04:09 PM   #1
GMan
Registered User
 
Join Date: Oct 2003
Location: San Antonio, TX
Posts: 11
Unhappy Newbie completely lost in Linux

Well, I have found out that learning Linux is a little harder than I expected. I'm very new at this OS (1 week) and am having multiple problems. I would like to update my nVidia drivers and have managed to folow the readme file but get an error that X is running.

I have no clue how to turn it off or what to do. I am running Mandarke 9.1 and have a GeoForce 4 MX440 vidieo card with 64 megs of ram. My CPU is a PIII at 1 gig. I don't know how to get the information mentioned by the moderator on XF86 (I don't know if its installed).

This seems hopeless, but can anybody lead me in the right direction please? Thank you in advance.

GMan.
GMan is offline   Reply With Quote
Old 10-13-03, 05:41 PM   #2
Head_slinger
DEP Hater :)
 
Head_slinger's Avatar
 
Join Date: Jul 2002
Location: Newcastle, UK
Posts: 277
Send a message via ICQ to Head_slinger
Default

Seeing you are very new to Linux i suggest that you do a little research into what exactly X window server is.

Summary:
Console is Linux, X Window server is running in the console. On windows to update a program you have to close it. That is exactly what the installer wants you todo.


Its been ages since i used Linux. So if you take my advice its your fault .

Go into a console, and type

init 3

This should close X and spit you into a console. You may have to log in again, go in as root.

Now install the drivers by following the readme as you probably were. Im assuming you already edited your X86 config file. Once all that is done, your set .

To get back into X just type

init 5

Head_slinger

any probs ill be on ICQ - 113066795 or MSN - head_slinger@hotmail.com
__________________
AMD Athlon 64 3500+
1gb Corsair XMS3200C2PT
Leadtek 6800GT
Audigy 2
ASUS A8V

Windows XP Prof./SuSe 8.2
Head_slinger is offline   Reply With Quote
Old 10-13-03, 06:05 PM   #3
GMan
Registered User
 
Join Date: Oct 2003
Location: San Antonio, TX
Posts: 11
Default

Well THAT was a neat trick! I'm liking this Linux system more by the minute! Thanks for the help on installing the driver. I can see now that I'm going to have to try and find you on ICQ for the next part vs. boring everybody here with the XFree ??? over my head.

Thanks.

GMan
GMan is offline   Reply With Quote
Old 10-13-03, 07:22 PM   #4
GMan
Registered User
 
Join Date: Oct 2003
Location: San Antonio, TX
Posts: 11
Default

Head_Slinger is the Man! Thanks for your help! The OpenGL drivers are loaded and work well! Thanks for taking time out to help me!


GMan
GMan is offline   Reply With Quote
Old 10-13-03, 11:54 PM   #5
dreamerv3
Geforce 3 ti 500
 
Join Date: Dec 2002
Location: Washington DC
Posts: 27
Default

Dammit, I was gonna say that but in a more comprehensive way!

Well you figured it out anyhow...

X is the gui framwork your respective desktop environment works ontop of, GNOME or KDE or others.

When you you type "init 3" in a terminal you are telling the system to go into a state of operation without the gui. Text based, failsafe so to speak....

sometimes if the user you're using as the everyday account doesn't recognize the init 3 command, you have to type "su" in the terminal window which will cause the system to ask you for the root password.

type it in and now that particular terminal window has root access, including the ability to start applications through the command line with root privlidges. to mess around (not recommended for a newb to mess around with root access as they can screw things up and nothing will stop you from doing so.) type "su" and then the password when prompted, now the prompt should have root somewhere in it, at the command line type "nautilus" you'll notice that the file manager now can create directories on the root trunk of the filesystem where previusly the everyday user couldn't.

Don't delete or modify directories or files in this state unless you know what you're doing.

close nautilus by clicking on the X in the window frame or going >>file>>close
now you're back at the root access terminal window, now type "exit" in the command line, you're back to being the ordinary user who opened the command terminal in the first place. Try that with windows...

This means you can do root things without actually logging out and logging in again.

See you're learning something new everyday...

Now just go read the Nvidia README file and you'll be all set...
dreamerv3 is offline   Reply With Quote
Old 10-14-03, 07:06 AM   #6
GMan
Registered User
 
Join Date: Oct 2003
Location: San Antonio, TX
Posts: 11
Default

Thanks for the help DreamWeaver! I am obviously very new to Linux and have a lot to learn, but I am finding out quickly how capable Linux is.

Now if I could just figure out how to use grub!


GMan
GMan is offline   Reply With Quote
Old 10-14-03, 08:35 AM   #7
GMan
Registered User
 
Join Date: Oct 2003
Location: San Antonio, TX
Posts: 11
Default

I might have gotten a little ahead of myself...

I booted this morning and responded to the post's, but when I checked the OpenGL screensavers, they would not run.

What is that all about? They worked last night and now they don't?

Anybody have an idea what I should check?


GMan
GMan is offline   Reply With Quote
Old 10-14-03, 04:21 PM   #8
VMUNIX
Registered User
 
Join Date: Oct 2003
Posts: 28
Send a message via ICQ to VMUNIX
Default

When you tried to run the OpenGL screen savers, did they freeze your computer? or just didn't work?
VMUNIX is offline   Reply With Quote

Old 10-14-03, 05:48 PM   #9
firest0rm
Registered User
 
Join Date: Oct 2003
Posts: 1
Default

The same thing happened to me. I have installed redhat 9 and my opengl graphics where running slow. So I installed the nivida driver and now opengl doesnt work. whenever i try to run a opengl screensaver it wont run.
firest0rm is offline   Reply With Quote
Old 10-14-03, 10:59 PM   #10
GMan
Registered User
 
Join Date: Oct 2003
Location: San Antonio, TX
Posts: 11
Default

They worked right after I installed them, but not this morning or this evening. When I go to the OpenGL screensaver test or apply radio button, I don't get anything. There is nothing running in the preview window either.

I think I'm going to check the Xfree config file...

GMan
GMan is offline   Reply With Quote
Old 10-14-03, 11:08 PM   #11
dreamerv3
Geforce 3 ti 500
 
Join Date: Dec 2002
Location: Washington DC
Posts: 27
Default

Under the part of XF86Config-4 called:


**********************************************

Section "Module"

**********************************************

Do you have a line that looks like:

**********************************************

Load "glx"

**********************************************


If not then add it under the part of XF86Config-4 called:


**********************************************

Section "Module"

**********************************************

There are other "Load" statements in the module section too, but the

Load "glx"

line loads the nvidia gl driver which runs the gl acceleration on your system.

Let me know!
dreamerv3 is offline   Reply With Quote
Old 10-15-03, 05:38 PM   #12
GMan
Registered User
 
Join Date: Oct 2003
Location: San Antonio, TX
Posts: 11
Default

Will do! I'll try it tonight when I get home from class. Thanks.


GMan
GMan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost Planet 3 Footage Raises Some Eyebrows News Archived News Items 0 05-23-12 03:10 PM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 01:52 PM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 11:13 PM
Linux VS. Windows XP! XP wins! dostler NVIDIA Linux 20 09-15-02 04:47 PM
NVIDIA_kernel with gcc 3.2 based linux kernel akay NVIDIA Linux 18 08-24-02 10:23 AM

All times are GMT -5. The time now is 10:37 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.