Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-13-03, 04:42 AM   #1
chris26
Registered User
 
Join Date: Oct 2003
Posts: 8
Default Semi-Newbie on Mandrake 9.1

Hello everyone.

I would really appreciate it if someone could help me through my nvidia driver problem.

I went ahead and decided to download the drivers from the NVIDIA page even though everything seemed to be working fine. I booted into the console mode, ran the installer as root, and edited my XF86config-4 file. Everything was pretty much as NVIDIA recommended it with the exception of the load "glx" line.

I then did a startx, and everything seemed fine. However on each reboot, I am unable to boot into x windows, each time I get an error. I now have to re-install the driver each time I boot up my computer to get into X windows.

Because I am using X right now, I have an XF86Config that is not tainted, so Im going to attach my log-files and config files on a post right after this one. I would really appreciate some help working through this, thanks!
chris26 is offline   Reply With Quote
Old 10-13-03, 05:09 AM   #2
chris26
Registered User
 
Join Date: Oct 2003
Posts: 8
Default

Hello again,

Ok here are two files concerning the above mentioned problem. One is the log from /var/log/ that outlines the errors from the Nvidia driver, and the other is the actual XF86config-4 config file.
Attached Files
File Type: txt xconfig-4-log.txt (2.7 KB, 157 views)
chris26 is offline   Reply With Quote
Old 10-13-03, 05:11 AM   #3
chris26
Registered User
 
Join Date: Oct 2003
Posts: 8
Default

Cant attach more than one file at a time i see

Here is the second one. WHile Im at it, I also have a new problem. Only root can now startx, I get some kind of new, "Cannot open Xserver, perhaps you dont have permission?" warning.

THanks for the help
Attached Files
File Type: txt nvidia-log.txt (19.7 KB, 179 views)
chris26 is offline   Reply With Quote
Old 10-13-03, 08:56 PM   #4
chris26
Registered User
 
Join Date: Oct 2003
Posts: 8
Default

Hello,

Im sorry that no one was able to help me out, maybe my problem was too difficult. However, it is entirely possible that I might have found a solution to my trouble from reading some of the other posts. Im going to try it out. If it doesnt work Ill be back here complain to you all for not giving me a hand If it does work, Ill probably do the same anyways
chris26 is offline   Reply With Quote
Old 10-14-03, 06:51 AM   #5
chris26
Registered User
 
Join Date: Oct 2003
Posts: 8
Default

Hello,

Anyone out there?

Im afraid I cant get this driver working and Im going to have to reinstall linux if I dont get some decent feedback soon. Im quite dissapointed at the lack of actual support here. I can certainly understand why so many linux users are beginning to feel a cold shoulder from Nvidia. Its a shame, really though. Because eventually some other card company will start putting out real Linux support and NVIDIA will be left in the dust, because I can guarantee you that people will flock to where the most support is.
chris26 is offline   Reply With Quote
Old 10-20-03, 02:12 PM   #6
ElFlaco
Registered User
 
Join Date: Oct 2003
Location: 1024 NW Street, Limbo
Posts: 4
Send a message via ICQ to ElFlaco
Unhappy Join the NVidia's broken linux club!

Hi Chris

I have an issue with Mandrake 9.1 and a GF2 Mx200, but is not even remotely like yours. I can use X perfectly, but no matter what I change in the config I can't get accelerated 3D, which was the reason i put the card in for.

What model / brand is your card? mine is an Inno3D one.
ElFlaco is offline   Reply With Quote
Old 10-20-03, 09:03 PM   #7
chris26
Registered User
 
Join Date: Oct 2003
Posts: 8
Default

Gforce 5600 ultra.

I have been asking for help on mandrake-linux's forum boards. They have really good people there who are not reserved to give advice. After exhausting all options, I have come to the conclusion that it is not possible to use the new nvidia drivers with mandrake 9.1 and with a geforce 5600 ultra.

I installed the kernel sources, I installed the driver in console mode, I edited my XF86config-4 file, etc etc....

It simply does not work if I set the driver to "nvidia", it does work if I set it to "nv."

Im beginning to think that mandrake 9.1 is broke.
chris26 is offline   Reply With Quote
Old 10-21-03, 03:22 AM   #8
ikkit
Registered User
 
Join Date: Oct 2003
Posts: 1
Default

ive got the same problem like you chris with my geforce4 4200 ti and mdk 9.1
if you found a solution.....

ikkit is offline   Reply With Quote

Old 10-21-03, 07:49 AM   #9
ElFlaco
Registered User
 
Join Date: Oct 2003
Location: 1024 NW Street, Limbo
Posts: 4
Send a message via ICQ to ElFlaco
Default Problem Solved! :D

Chris, i just fixed my problem yesterday, and now i have everything working, including GL.

According to the nvidia site, the 4496 supports the FX5900, so it surely supports yours. This tutorial helped me a lot: http://www.linuxquestions.org/questi...ticle&artid=30


Oh, and by the way, one the troubleshooting sections on the README inside "/usr/share/doc/NVIDIA-GLX<some numbers here>/ " says that one possible cause is the nvidia kernel module not loading. If your XFree log says something like "(EE) NVIDIA(0): Failed to initialize the NVdriver kernel module!" you probably have the same problem I had.

Since I didn't know the format of the /etc/modules.conf file (yes, yes, there is a man page for that, i was just lazy) I just inserted a "modprobe nvidia" line at the end of in the /etc/rc.d/rc.modules script.

Also, it seems that after 3 or so tries of start the X system at boot ending in failure, Mandrake automatically edits /etc/inittab and sets the text console boot for good. You just have to change the line that says:

id:3:initdefault

to:

id:5:initdefault

Hope that helps!

Regards
Juancho
ElFlaco is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM
Mandrake 9 and nVidia drivers HunterA3 NVIDIA Linux 9 10-09-02 02:54 AM
Mandrake 9.0 driver installation Andy Mecham NVIDIA Linux 3 10-02-02 04:12 PM
Mandrake 8.2 first time user... mcortz_2000 NVIDIA Linux 3 09-26-02 01:51 PM
Mandrake 9 and Geforce 4 goyo NVIDIA Linux 1 08-18-02 04:18 PM

All times are GMT -5. The time now is 10:54 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.