Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-20-12, 03:20 PM   #1
alex_sh
Registered User
 
Join Date: Dec 2005
Posts: 4
Exclamation Regression with GTK+ menus when using a virtual resolution

Hello,

I have a physical resolution set to 1920x1080 and the virtual to 2560x1440. "nvidiaXineramaInfo" is set to "false" so that the window manager (kwin or window maker) uses the whole virtual screen.

Ever since updating to 304.43 (from 295.59) on openSUSE 12.1 x86-64 (and later to 12.2), I've been experiencing problems with GTK+ applications (both GTK+2 and 3). If I invoke a menu from outside the 1920x1080 area, the menu always shows up inside the top left 1920x1080 area. For example, if I pan (move the mouse to the far right and down) and click somewhere at 2200x1200 point, the menu shows up in a totally different place - it always tries to stay within the physical resolution limits.
Qt4 applications are not affected.

For now I had to set Option "Xinerama" "True", which fixes the issue but disables RANDR as well (which I think used to work before).

You can quickly set such resolution using: xrandr -s 1920x1080 --output DVI-I-1 --panning 2560x1440 (but you have to have Option "nvidiaXineramaInfo" "false").

Thanks!

-------------------------------------

Here's my xorg.conf:

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "off" # if on, you have to press ctrl-alt-backspace twice to kill X.

Option "BlankTime" "7" # simply darken
Option "StandbyTime" "8" # turn off electron gun, recovers quickly
Option "SuspendTime" "9" # turn off electron gun, power supply
Option "OffTime" "10" # turn off everything, minimal state

Option "AllowDeactivateGrabs" "on" # deactivate any grab Ctrl+Alt+Keypad-Divide.
Option "ClosedownGrabs" "on" # close the connection to the grabbing client with Ctrl+Alt+Keypad-Multiply.

# Option "Xinerama" "True" # needed to avoid in-physical-resolution gtk menus (disables RANDR)
EndSection


Section "Device"
Identifier "device_nvidia"
VendorName "NVidia"
BoardName "GeForce Something"
Driver "nvidia"
Screen 0

Option "DPMS"
Option "HWCursor" "1"

Option "UseEDIDDpi" "false" # if false, don't use EDID-supplied DPI value
Option "DPI" "120 x 120" # override DPI (we set it in xinitrc.d)

Option "Coolbits" "5" # 1 - clock control, 2 - experimental SLI, 4 - fan control.

Option "NvAGP" "0" # 0 disable, 1 nvagp, 2 agpgart, 3 agpgart then nvagp
Option "NoLogo" "1"
Option "CursorShadow" "1"
Option "CursorShadowAlpha" "50"
Option "CursorShadowXOffset" "5"
Option "CursorShadowYOffset" "0"

# This fixes virtual screen geometry reporting
Option "nvidiaXineramaInfo" "false"

Option "TripleBuffer" "True" # enable GL triple buffering for vblank
EndSection



Section "Screen"
Device "device_nvidia"
Identifier "screen0"
# Monitor "monitor0"

DefaultDepth 24

SubSection "Display"
Virtual 2560 1440
Viewport 0 0
Depth 24
Modes "1920x1080"
# Modes "1024x768"
EndSubSection

EndSection
Attached Files
File Type: gz nvidia-bug-report.log.gz (73.7 KB, 45 views)
alex_sh is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:16 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.