Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-22-12, 11:32 AM   #1
shmerl
Registered User
 
Join Date: Oct 2011
Posts: 8
Default Brightness problem with Nvidia 304.60 on HP 8710w laptop with Quadro FX 1600M

After upgrading Nvidia driver to 304.60 (on current Debian testing x86_64 with KDE) on my laptop (HP Compaq 8710w which uses Quadro FX 1600M/PCIe/SSE2), the screen became dim, and brightness keys don't work to change it back. (See attached bug report below). For now I'm downgrading the driver back to 304.51 even though it has a memory leak in Xorg in Twinview mode. But the dimness just makes the new driver unusable.

This case seems to be similar somewhat:

https://bbs.archlinux.org/viewtopic.php?pid=1179520/
Attached Files
File Type: gz nvidia-bug-report.log.gz (63.1 KB, 88 views)
shmerl is offline   Reply With Quote
Old 10-23-12, 01:26 AM   #2
rainerklier
Registered User
 
Join Date: Oct 2003
Posts: 45
Unhappy Re: Brightness problem with Nvidia 304.60 on HP 8710w laptop with Quadro FX 1600M

Quote:
Originally Posted by shmerl View Post
After upgrading Nvidia driver to 304.60 (on current Debian testing x86_64 with KDE) on my laptop (HP Compaq 8710w which uses Quadro FX 1600M/PCIe/SSE2), the screen became dim, and brightness keys don't work to change it back. (See attached bug report below). For now I'm downgrading the driver back to 304.51 even though it has a memory leak in Xorg in Twinview mode. But the dimness just makes the new driver unusable.
me too!
i have the same notebook, and it behaves the same...

see http://www.nvnews.net/vbulletin/show...php?t=194740#2
rainerklier is offline   Reply With Quote
Old 10-23-12, 04:12 PM   #3
Ralph
Registered User
 
Join Date: Jul 2007
Posts: 74
Default Re: Brightness problem with Nvidia 304.60 on HP 8710w laptop with Quadro FX 1600M

Same problem on my laptop HP Pavilion with GeForce GT 320M.
I have downgraded to 304.51.
Ralph is offline   Reply With Quote
Old 11-06-12, 12:04 PM   #4
shmerl
Registered User
 
Join Date: Oct 2011
Posts: 8
Default Re: Brightness problem with Nvidia 304.60 on HP 8710w laptop with Quadro FX 1600M

Looks like 304.64 fixes this bug: http://www.geforce.com/drivers/results/51453
shmerl is offline   Reply With Quote
Old 11-07-12, 03:13 AM   #5
rainerklier
Registered User
 
Join Date: Oct 2003
Posts: 45
Talking Re: Brightness problem with Nvidia 304.60 on HP 8710w laptop with Quadro FX 1600M

yes!
you are right!
issue fixed in 304.64!
rainerklier is offline   Reply With Quote
Old 11-07-12, 07:56 PM   #6
Ralph
Registered User
 
Join Date: Jul 2007
Posts: 74
Default Re: Brightness problem with Nvidia 304.60 on HP 8710w laptop with Quadro FX 1600M

Not fixed here.

Example:

nvidia-settings -a 0/Gamma[DFP-0]=0,746
Code:
ERROR: Error assigning 0,746000 to attribute 'Gamma' on linux-22kj.site:0.0
       specified in assignment '0/Gamma[DFP-0]=0,746' (Bad handle)
Ralph is offline   Reply With Quote
Old 11-08-12, 12:25 PM   #7
Kynde
Registered User
 
Join Date: Oct 2008
Posts: 5
Default Re: Brightness problem with Nvidia 304.60 on HP 8710w laptop with Quadro FX 1600M

Fedora 17 here on a HP 8530w using rpmfusion packages. 304.60 broke brightness controls, screen usually black after suspend etc. 304.64 still broken. Setting can be set manaully from /sys.

Rebuilt 304.51 packages and all's well again.

Let me know if you need me to elaborate, provide details or try something out.
Kynde is offline   Reply With Quote
Old 12-07-12, 07:50 AM   #8
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: Brightness problem with Nvidia 304.60 on HP 8710w laptop with Quadro FX 1600M

Quote:
Originally Posted by Kynde View Post
Fedora 17 here on a HP 8530w using rpmfusion packages. 304.60 broke brightness controls, screen usually black after suspend etc. 304.64 still broken. Setting can be set manaully from /sys.

Rebuilt 304.51 packages and all's well again.

Let me know if you need me to elaborate, provide details or try something out.
Exact same situation (hardware and distribution) here. The brightness keys and also brightness settings from KDE power management do not work. Can use /sys/class/backlight to change the brightness manually.
Often after suspend the brightness is set to minimum while /sys/class/backlight reports the brightness to be at maximum, setting the brightness manually still works in this situation.
Also with 310.19 it still does not work properly.
Lysius is offline   Reply With Quote

Old 01-19-13, 08:59 AM   #9
Kynde
Registered User
 
Join Date: Oct 2008
Posts: 5
Default Re: Brightness problem with Nvidia 304.60 on HP 8710w laptop with Quadro FX 1600M

For the record, with the beta 313.09 drivers the brightness works again like it did up to and including 304.51.
Kynde is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.