Go Back   nV News Forums > Graphics Card Forums > NVIDIA Windows Graphics Drivers

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-23-12, 01:44 PM   #1
DSC
Registered User
 
Join Date: Nov 2002
Posts: 888
Default Nvidia GeForce 310.33 beta drivers

http://www.geforce.com/whats-new/art...ivers-released
DSC is offline   Reply With Quote
Old 10-23-12, 04:05 PM   #2
AngelGraves13
Registered User
 
Join Date: Aug 2002
Posts: 2,383
Default Re: Nvidia GeForce 310.33 beta drivers

It erased all my profiles lol

Oh well.
AngelGraves13 is offline   Reply With Quote
Old 10-24-12, 05:49 AM   #3
Muppet
Registered User
 
Muppet's Avatar
 
Join Date: Jun 2004
Location: New Zealand
Posts: 3,130
Default Re: Nvidia GeForce 310.33 beta drivers

Just downloaded. Will try these out soon. From all reports, these look pretty good.
Muppet is offline   Reply With Quote
Old 10-25-12, 01:56 AM   #4
jlippo
Registered User
 
Join Date: Mar 2006
Posts: 532
Default Re: Nvidia GeForce 310.33 beta drivers

Apparently drivers have altered SGSSAA LoD bias behavior.
Now it automatically adjusts the bias when SSAA is increased.

This should increase SSAA quality and reduce the need of tweaking the settings.
jlippo is offline   Reply With Quote
Old 10-25-12, 02:15 AM   #5
MUYA
 
Join Date: Jul 2002
Location: Hong Kong
Posts: 6,795
Send a message via MSN to MUYA
Default Re: Nvidia GeForce 310.33 beta drivers

Hmm i have been having issues with new drivers for my 680 ...especially with the secret world. Will give these a shot
__________________
I5-2500k@4.7GHz - MSI Z77A-GD65 - 4GB X2 A-DATA DDR3 1600 - Corsair H100 - Antec Quatro 850W
Gigabyte Windforce X3 GTX 680 OC - Dell 24" IPS
Intel 320 300 GB SSD - 1 TB Hitachi HDD - 2x 250 GB WD HDD
Corsair K90 - Corsair Venegance 2000 Headset - Razer Naga Epic
Corsair 600T Case
MUYA is offline   Reply With Quote
Old 11-06-12, 09:28 AM   #6
fasedww
Pc Gamer
 
fasedww's Avatar
 
Join Date: Jul 2002
Location: Minneapolis
Posts: 1,578
Default Re: Nvidia GeForce 310.33 beta drivers

I like them. Where the heck has all the people gone that used to post here?.
__________________
Asus X79 rampage extreme 4, i7 3930K, 47X100, 4.70 GHZ, ,16 gigs, corsair, 1600mhz, 3 MSI GTX 780's Tri SLI, gtx, Prolimatech Genesis, 2 140mm fan heastsink, Lian Li PC 80 ArmorSuit case, PCPC 1200 watt, window side panel with 120mm blowhole, SoundBlaster X-Fi Titanium HD , Asus Blueray sata dvdrw,SSD 256GB Plextor Pro,SSD Patriot Pyro 240gig,SSD Agility 4 256 , 1 300 gig raptor, 1 600 gig raptor, segate 1 gig ,Total Airhead amp, Denon AH-D2000 headphones, Dell Ultra3011, Acer HN274H 120 Hz Lcd, ,26,500 3dmark 11, Win 7 HomePrem.

Rig #2 i7 3930k 4.7GHZ. 16 gig corsair Platinum 2400MHZ, Asus P9X79 DELUXE, 2 7970's Watercooled, Koolance blocks, on 1080 nova rad. 9 fan. 655 swiftech. Cpu heatkiller block, coolgate 240mm rad, 2 fan sycthe 108cfm 655 pump,OCZ 256Gb Vertex 4 ssd, C300 256Gb ssd, Patriot pyro 240Gb ssd, 2 wd 640gig Hd, Lian Li 343 modular case. Asus BD drive, Corsair AX1200 watt, X-FI Titanium HD on Fiio , Shure SRH840 Head phones, Dell Ultra3011, Razer Black Widow Ult. BF3 Edition keyboard, Corsair Vengence M60 Mouse, 3dmark 11 16,500, win 7 homePrem.
fasedww is offline   Reply With Quote
Old 11-06-12, 10:26 AM   #7
Quick420
Registered User
 
Quick420's Avatar
 
Join Date: Oct 2005
Location: London,Canada
Posts: 1,445
Default Re: Nvidia GeForce 310.33 beta drivers

I use em here with no problems so far.Good drivers
__________________
:Gaming Rig:
Asus P5N-D SLi E8400 Wolfdale@3.6ghz/TTBig TyphoonCooler 51c Orthos 3hrs
Galaxy GTX560ti-GC 296.10 Forceware 950/1900/2200,1100mv,Gts250/Physx
2x2gb Ddr2 1066mhz 4-4-4-12 1T
3xWD WD5000AAKS 500gb/sata300/ 1xSeagate 320gb Ide(tuuunz)
X-fi Fatality Pro*ASUS VH242H 24"LCD*:::Windoze 7-64bit:::
Sony DvD/Ram-Drive
Logitech G25
3dmark06 17,898 Vantage 12,851



If the light is GREEN the trap is clean
Quick420 is offline   Reply With Quote
Old 11-06-12, 10:19 PM   #8
MUYA
 
Join Date: Jul 2002
Location: Hong Kong
Posts: 6,795
Send a message via MSN to MUYA
Default Re: Nvidia GeForce 310.33 beta drivers

Gaming is no problem for me but I get strange stuttering when trying to play videos, even in game video cinematics in Xcom
__________________
I5-2500k@4.7GHz - MSI Z77A-GD65 - 4GB X2 A-DATA DDR3 1600 - Corsair H100 - Antec Quatro 850W
Gigabyte Windforce X3 GTX 680 OC - Dell 24" IPS
Intel 320 300 GB SSD - 1 TB Hitachi HDD - 2x 250 GB WD HDD
Corsair K90 - Corsair Venegance 2000 Headset - Razer Naga Epic
Corsair 600T Case
MUYA is offline   Reply With Quote

Old 11-07-12, 07:42 PM   #9
batterbrain101
"TAZ LIKE!"
 
batterbrain101's Avatar
 
Join Date: Sep 2002
Location: Spokane, Washington, USA
Posts: 191
Default Re: Nvidia GeForce 310.33 beta drivers

Downloading now, will report back.
__________________
] My village called, their Idiot is missing!

My rig:
Asus Maximus VI Hero
Intel i7 4770K@ 4.2 GHz
16GB G-Skill Trident X DDR3 2400 Ram
Corsair 750HX "Silver Certified" PSU
Corsair H70 Hydro CPU Cooler
2x PNY GTX 770 OC2 4GB in SLI
180 GB Intel 520 SSD
2 TB Barracuda HD, 2 TB WD Caviar Green
Logitech G-510 Keyboard
Windows 7 Professional 64 bit
3 Samsung 24" LED SyncMaster Monitors

batterbrain101 is offline   Reply With Quote
Old 11-09-12, 09:45 PM   #10
john19055
 
john19055's Avatar
 
Join Date: Jul 2002
Location: GREENVILLE,TX
Posts: 3,859
Default Re: Nvidia GeForce 310.33 beta drivers

I seem to had problems with them some of my games were flashig,went back to my other drivers and now it works fine.I may try them again I don't think I had a good uninstall.
__________________
Intel i7-3820+Corsair H-100+Gigabyte X79-UD5+16gigs G.Skill PC1600DDR3+2-ASUS DirectCU II GTX-670 in SLI+Crucial 256g-SSD+1-3Gig Seagate+2- Samsung 1-TB+3-WesternDigtial 640g+LG-12x Blu-Ray Burner+850watt XFX+Antec-P280 case+50" Plasma PM6700+Logitech Mouse+Keyboard+Pioneer VSX-1020+Polk Audio Speakers
john19055 is offline   Reply With Quote
Old 11-11-12, 02:27 AM   #11
batterbrain101
"TAZ LIKE!"
 
batterbrain101's Avatar
 
Join Date: Sep 2002
Location: Spokane, Washington, USA
Posts: 191
Default Re: Nvidia GeForce 310.33 beta drivers

Installed these a few days ago no and they are working fine, not that I had any issues really any way, but they aren't giving me any issues either.

Actually I'm getting a lot stuttering in Skyrim: Elder Scrolls DawnGaurd during in level map updates now versus when I had on the 306.23 WHQL drivers installed. It was a pretty minor thing to begin with but is less noticeable now
__________________
] My village called, their Idiot is missing!

My rig:
Asus Maximus VI Hero
Intel i7 4770K@ 4.2 GHz
16GB G-Skill Trident X DDR3 2400 Ram
Corsair 750HX "Silver Certified" PSU
Corsair H70 Hydro CPU Cooler
2x PNY GTX 770 OC2 4GB in SLI
180 GB Intel 520 SSD
2 TB Barracuda HD, 2 TB WD Caviar Green
Logitech G-510 Keyboard
Windows 7 Professional 64 bit
3 Samsung 24" LED SyncMaster Monitors

batterbrain101 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:14 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.