Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-17-03, 10:16 AM   #1
Plaz McMan
Registered User
 
Join Date: Oct 2003
Location: Gualala, CA
Posts: 13
Default FX 5200 and RH9 problems

--------------------------------
PNY Verto GeForce FX 5200 (AGP)
nForce-2 mobo (Epox)
Athlon 1800+
--------------------------------

I recently installed RH9, and can succesfully boot into Xwindows, using my driver as "nv."
However, I would like to be able to use "nvidia" as my driver, but it does not seem to be working. I installed the nForce drivers and the display drivers, but still, no luck. I modified my XF86Config file as specified in the readme. When I try startx, the screen goes black (but does not turn off), and the machine freezes (no keybord LEDs, and CTRL ALT DEL doesn't work). I think I had it all working once (saw spalsh screen), though I forgot what I did (and, stupidly, forgot to backup my Config file).

My WORKING config file, with "nv". I tried replacing "nv" with "nvidia", but it locks up. Any suggestions? Also, I have no problems with re-installing the whole system, if that would make it easier for a walkthrough.



# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "dvorak"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Gateway Vivitron 20"
HorizSync 29.0 - 82.0
VertRefresh 50.0 - 150.0
Option "dpms"
EndSection

Section "Device"
Identifier "nvidia0"
Driver "nv"
BoardName "Unknown video card"
EndSection

Section "Screen"
Identifier "Screen0"
Device "nvidia0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection



#Thanks,

#Brannon
Plaz McMan is offline   Reply With Quote
Old 10-17-03, 10:21 AM   #2
irreligious80
Registered User
 
Join Date: Oct 2003
Location: Finland
Posts: 8
Default

I have the exactly the same problem. Though my graphics card is a GF3 Ti-500.
irreligious80 is offline   Reply With Quote
Old 10-19-03, 05:15 AM   #3
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

The readme discusses setting different agp driver options, to allow for the possibility that your motherboard does not work well with the 'AGPgart' driver, or the 'NvAGP' driver. Try setting those options, which go in your XF86Config file and take the form:

Driver "nvidia"
Option "NvAGP" "1"

(you choose which agp module to use by selecting the number of the NvAGP option you want, see the readme.)

As another option, try disabling acpi or apm on kernel boot. You do this in your lilo or grub config. Look into kernel options if you want to mess with this, as you should understand the basics of what its doing.

it goes something like:
acpi=off

and is also discussed in the nvidia readme I believe.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 10-19-03, 07:02 AM   #4
Ixthus2003
GeForce 5 FX 5200
 
Join Date: Apr 2003
Posts: 2
Default

I had the same problems. It seems to be a problem with some card BIOSes. Here's some details from the nvidia linux readme:

Q: X takes a long time to start (possibly several minutes). What can
I do?

A: Most of the startx delay problems we have found are caused by incorrect
data in video BIOSes about what display devices are possibly connected
or what i2c port should be used for detection. You can work around
these problems with the XF86Config option "IgnoreDisplayDevices"
(please see the description in (app-d) APPENDIX D: XF86CONFIG OPTIONS).
Ixthus2003 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:17 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.