Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-19-03, 10:20 AM   #1
NSKL
Registered User
 
Join Date: Oct 2003
Posts: 3
Send a message via AIM to NSKL
Default Toshiba laptop, Slack and GeForce4

First off, hello to everyone here, since i'm new...
I've been using Linux (Slackware) for 4 years now, and i've done a number of nvidia drivers installations and i dealt with a number of problems.
However, i recently purchased a Toshiba satellite 1950-801 with a GeForce 4 460 Go, and a nice 16" monitor. Got X up and running, then downloaded nvidia's newest drivers, installed, restarted X, and the big "plasma monster" attacked me. So i played with options in XF86Config for a couple of days, and the best result i got was with igoring EDIDs. In this case i just get a fuzzy, shifted picture, like when you have bad TV reception.
I've read many posts about similar problems, and followed all advice i could gather. I tried disabling AGP, disabling ACPI and APIC (on uniprocessors), passing NVreg_Mobile=2 to nvdriver, downgrading drivers and the kernel! (drivers to 4363 and kernel to 2.4.20 but still no go. I either get the "plasama thing" or if i set Ignore edid i get the fuzzy unusable display. Other options, such as UseEdidFreqs just make it worse by leaving my console in a unusable state as well. I e-mailed Toshiba to send me detailed hsync and vert refresh freqencies for my monitor, but they didnt answer yet...

I have no idea whats left to do. I purchased this laptop exactly for the reason it had a Nvidia card since i had (mostly) good experiences with Nvidia and linux so far..
However this is a disaster. I'm pretty much left with no hair cuz i tried everything i could find or think of.
Is there something else to try? Did anyone solve this bloody problem?
Thank you for any help/advice
-NSKL
NSKL is offline   Reply With Quote
Old 10-19-03, 05:32 PM   #2
pyrest
Registered User
 
Join Date: Oct 2003
Posts: 4
Default

Here you can try this:

1. Ensure you're using the 4363 batch (the last set of ones). The 44xx series cause severance lines as well as distortion. Currently I'm trying to find a way around this. This is mandatory.

2. Make sure you include the IgnoreEDID statement in the Device Section (Video Card) of you XF86Config file. This is mandatory.

3. Set you resolutions to whatever is your native res (i.e. 1280x1024), and only that res.

4. Pass the NVreg_Mobile=2 option under /etc/modules.conf and make sure that it is after the device aliasing for the nvidia card. This is also mandatory.

5. Set your HorizSync to 35-85 and VertRefresh to 40-100. This is semi-mandatory.

6. Enable glx in Section Module and disable dri and GLcore (if applicable).

Steps flagged mandatory need to be done in order to get around the "trippy" look. The "trippy" look is that purple/pink blob that goes across the screen as you start X. If you encounter this just either switch terminals (ctrl-alt-F#) or kill it (ctrl-alt-bksp).

The reason the frequencies are semi-mandatory is because you may not want to start your system up with its native res. In this case you can set the settings lower and they will work fine. A lower res (or higher one for that matter) will cause the system to create a virtual desktop with a viewable area of the specified res with a defined res of the native res (or at least I believe this to be the case most of the time).

If you need to find out a list of possible settings and their associated frequencies do the following:

% startx -- -logverbose 5

This creates a log file in /var/log named XFree86.x.log where x is the server number. This will have a listing of resolutions with their corresponding frequencies as well as other fun stuff.

That should be it. You may want to enable the AGPgart (either the Nvidia one or the Kernel one). Hope that helps. If you need to, consult the README, it's quite comprehensive (however I do understand that many may not understand what it says).

Quick note: Whenever you change drivers it will do a re-write of /etc/modules.conf. It is therefore a necessity to change that file manually everytime you install the drivers again. If you find yourself doing this a lot you may want to write up a script or keep a buffer open in an editor to do quick saves.

You can go through all the options for the Device Section and edit them as you see fit as well. I recommend you avoid trying to set IgnoreDisplayDevices as on my machine it causes my screen to die (i.e. It doesn't come back I have to do a reboot, not a simple frequency out of range). You may want to mess with the FlatPanelProperties, NvAGP, NoBandWidthTest and whatever else you feel like. I personally kill the logo while I'm at it.

On a side note I'm running a Tosh 1955-S803 and haven't had any problems -- chances are we have almost identical hardware.

If you have any more questions post a reply.
pyrest is offline   Reply With Quote
Old 10-20-03, 04:51 AM   #3
NSKL
Registered User
 
Join Date: Oct 2003
Posts: 3
Send a message via AIM to NSKL
Default

Thanks for the reply,
However i have already tried most of these things (will try again tho, as soon as i get home). For now i have found a temporary solution.

I downgraded the kernel to 2.4.20 and the drivers to 41XX and now it works. However playing a 3d game for a while causes the laptop to overheat, and goes into shutdown. I really hope that fan is spinning on the vid card, no way to check except to open the laptop?

Again thanks for the suggestions, will let you know if i get it to work.
-NSKL
NSKL is offline   Reply With Quote
Old 10-20-03, 11:26 AM   #4
NSKL
Registered User
 
Join Date: Oct 2003
Posts: 3
Send a message via AIM to NSKL
Default

Well, well, what do you know, following your instructions, i got X to work with nvidia 4363 drivers and kernel 2.4.22.

However playing a 3d game still gives problems. I tried SOF and Rune and i get a distorted image (bad TV 'scanlines') and when going to change resolutions, both games segfault. I have 4 different modes for the color depth i use specified in XF86Config, so i beleive its a problem with the drivers. This happened with 41xx drivers too...
I'll play with XF86Config options in hope to solve this, but if you, or someone else knows a quick fix that would be great.
Again thanks for all the help
-NSKL
NSKL is offline   Reply With Quote
Old 11-25-03, 08:00 PM   #5
huffman
Registered User
 
huffman's Avatar
 
Join Date: Nov 2003
Location: x
Posts: 12
Default

With a Toshiba 1950-801, I've got the same problems; downgrading to 2.4.21 kernel and 4363 works almost good... the only problem I got is that I can't see the entire screen... even using "Scaling = centered" in "FlatPanelProperties".

Can you post your XF86Config? Just to compare frequencies...
Attached Files
File Type: txt xf86config.txt (5.3 KB, 173 views)
__________________
huffman salutes you!
huffman is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.