Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-20-03, 04:54 AM   #1
semios
Registered User
 
Join Date: Oct 2003
Posts: 2
Default twinview

I'm running Mandrake 9.2, athlon 2600+ and a geforce 5200. I've run through the last three driver releases and basically every possible permutation on the XF86Config-4 file with no luck whatsoever. My 2nd screen will NOT come on in any resolution, refresh rate, etc. I have come up with the (EE) errors not allowing me into X and right now X starts correctly, flashes the 2nd screen as if to turn it on, but it never turns on. It reminds me of old days of the 2nd head flaws on windows98. Right now, the screen indicates "no signal"






latest xf86config

# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
#DontZap # disable <Crtl><Alt><BS> (server abort)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "MouseManPlusPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 60 Hz"
HorizSync 31.5-48.5
VertRefresh 50-70

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce FX (generic)"
Driver "nvidia"
Option "NvAGP" "3"
Option "SecondMonitorHorizSync" "31.5-78.5"
Option "MetaModes" "1024x768, 800x600; 1024x768, 1024x1024"
Option "TwinView" "1"
Option "ConnectedMonitor" "CRT, CRT"
Option "NoBandWidthTest" "1"
Option "SecondMonitorVertRefresh" "60"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 15

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
semios is offline   Reply With Quote
Old 12-17-03, 07:53 AM   #2
semios
Registered User
 
Join Date: Oct 2003
Posts: 2
Default thanks to all for the quick response

I suppose I mistakenly believed these forums were monitored and there was some help for us poor consumers - especially us former windows experts who are fairly new to linux. Instead, it must be that we have to help ourselves and share the knowledge among ourselves. Sorry if I expected too much from moderators and nvidia personel.

The real problem with my twinview dilemna had to deal with the detection of the 2nd monitor (which in NO way worked correctly). My solution was twofold: 1)setting up a virtual desktop which is actually not virtual but real. 2) providing the exact specs of my 2ndary monitor.

Here's the pertinent sections of my xfconfig after I finally managed to fix the problem.

BTW, a little advise for everyone: check your /var/log/XFree86.0.log file. It can be helpful even if you don't understand everything that's going on.


Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 60 Hz"
HorizSync 31.5-48.5
VertRefresh 60
EndSection

Section "Device"
Identifier "device1"
VendorName "Leadtech"
BoardName "NVIDIA GeForce FX 5200"
VideoRam 131000
Driver "nvidia"
Option "NvAGP" "1"
Option "NoLogo" "1"
Option "RenderAccel" "1"
Option "MetaModes" "1024x768, 1024x768;1024x768, 800x600; 1024x768, null"
Option "TwinView" "1"
Option "SecondMonitorVertRefresh" "60"
Option "SecondMonitorHorizSync" "48.4-65.0"
Option "ConnectedMonitor" "CRT, CRT"
Option "TwinViewOrientation" "RightOf"
Option "NoBandWidthTest" "1"
Option "IgnoreEDID" "1"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24
Subsection "Display"
depth 24
Virtual 2048 768
Endsubsection
semios is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Twinview? ghorsepower NVIDIA Linux 2 10-11-02 12:46 PM
XF86Config for a Quadro4 without TwinView? Twirlip NVIDIA Linux 1 10-09-02 10:36 AM
Suse Linux 8.0 - Geforce 4 TwinView TA00 NVIDIA Linux 8 08-30-02 03:24 AM
Twinview with TV-out karlaugust NVIDIA Linux 10 08-28-02 04:20 PM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 03:20 AM

All times are GMT -5. The time now is 08:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.