Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-20-02, 12:32 PM   #1
sudsm
Guest
 
Posts: n/a
Default Error loading kernel module 3123, MDK8.2

Hi all,
My setup is
NVIDIA TNT2 64, Mandrake 8.2 kernel 2.4.18-6mdk.

I am getting the following error when loading the kernel module 3123. Any help is greatly appreciated.

Quote:
nvidia: loading NVIDIA Linux x86 NVdriver Kernel Module 1.0-3123 Tue Aug 27 15:56:48 PDT 2002
devfs_register(nvidiactl): could not append to parent, err: -17
devfs_register(nvidia0): could not append to parent, err: -17
and when I start X, it just hangs without a display.


Thanks
suds.
  Reply With Quote
Old 09-20-02, 01:25 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Error -17 is -EEXIST (check /usr/include/asm/errno.h, included from /usr/include/linux/errno.h, which was included from /usr/include/bits/errno.h, which was included from /usr/include/errno.h, the header file from which all the error numbers get symbols).

Looking at the 2.4.19 kernel source for fs/devfs/base.c, I see that it looks like it returns -EEXIST if the directory entry (a.k.a. file or device) that it's trying to create or register already exists.

If you remove (modprobe -r) NVdriver, manually delete /dev/nvidia*, and then try to modprobe NVdriver, does it work?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 09-21-02, 05:31 AM   #3
sudsm
Guest
 
Posts: n/a
Default

Thanks a lot bwkaz!

I removed the dev files already present and the NVdriver is working fine! Thanks again.

PS: I should have really used my brain and looked in errno.h for the details on 17.
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[BUG] nvidia crashes kernel with 'Xid 13' and attempted to yield the CPU while atomic rockob NVIDIA Linux 36 09-26-12 07:48 AM
upgrade to xorg server 1.13 damaged Geforce 7300 GT KDE NVIDIA Linux 2 09-07-12 08:04 AM
Fatal upgrade: from bad (8800 GTS) to worse 9GTX 560 Ti) ssnyder NVIDIA Linux 1 07-01-12 08:14 PM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM

All times are GMT -5. The time now is 12:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.