Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-20-02, 10:22 PM   #1
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Why cant I run at 2048x1536 with nvidia drivers

Why can i not even run at 2048x1536 with the linux nvidia drivers, what is up?
my video card is geforce 2 ultra, and im running slackware 8.1 using xfree86 4.2.0
heres what i get in the log..

(II) NVIDIA(0): ViewSonic P225F: Using hsync range of 31.50-127.00 kHz
(II) NVIDIA(0): ViewSonic P225F: Using vrefresh range of 50.00-180.00 Hz
(II) NVIDIA(0): Clock range: 12.00 to 350.00 MHz
(II) NVIDIA(0): Not using mode "2560x1920" (no mode of this name)
(II) NVIDIA(0): Not using mode "2048x1536" (no mode of this name)
(**) NVIDIA(0): Validated modes for Display Device 0:
(**) NVIDIA(0): Default mode "1920x1440": 297.0 MHz, 112.5 kHz, 75.0 Hz
(**) NVIDIA(0): Default mode "1600x1200": 229.5 MHz, 106.2 kHz, 85.0 Hz
(**) NVIDIA(0): Default mode "1280x1024": 157.5 MHz, 91.1 kHz, 85.0 Hz
(**) NVIDIA(0): Default mode "1280x960": 148.5 MHz, 85.9 kHz, 85.0 Hz
(**) NVIDIA(0): Default mode "1152x864": 108.0 MHz, 67.5 kHz, 75.0 Hz
(**) NVIDIA(0): Default mode "1024x768": 94.5 MHz, 68.7 kHz, 85.0 Hz
(**) NVIDIA(0): Default mode "800x600": 56.3 MHz, 53.7 kHz, 85.1 Hz
(**) NVIDIA(0): Default mode "640x480": 74.2 MHz, 85.9 kHz, 85.1 Hz (D)
(II) NVIDIA(0): Virtual screen size determined to be 1920 x 1440
(--) NVIDIA(0): Display dimensions: (400, 300) mm
(--) NVIDIA(0): DPI set to (121, 121)

now, why does it say unkown mode for 2048x1536? wtf? it ends up running @ 1920x1440 instead, thats ghetto
Xevious is offline   Reply With Quote
Old 09-21-02, 01:26 PM   #2
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default

so, i guess that no one knows how, sense this post has been up here for a day and no one has replied and its gone on to the second page?
Xevious is offline   Reply With Quote
Old 09-21-02, 02:31 PM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Looks like X doesn't know what that mode is. Or the XFree86 developers figured "almost nobody can even use this mode because monitors don't get that big, so let's not support it" (this would have been a while ago; X 4.2 isn't all that new). But I kinda doubt that last one.

Or your monitor is telling X that that mode isn't supported, however I don't think this is your problem either. The error message sounds like X doesn't recognize the mode as being even a candidate for being valid. If you had told it to go into 1843x1567 mode or some gibberish like that, I have a feeling it would complain the same way.

I have no idea how to fix it, either, short of looking at the XFree86 source and adding support for that display mode. And I have no idea how you'd go about doing that; I don't know how it works internally that well.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 09-21-02, 03:39 PM   #4
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default

I know its not telling X my monitor cant do that resolution, i know for a fact it can, and at 79 Hz, but if it did it would be saying the v or h-sync was out of range, not mode not known, anyway i heard of somone else having this same problem when upgrading to xfree86 4.2 im wondering if this is xfree86 porblem or nvidia driver problem, but i remember back in the day a while back i could do it on my 19 inch monitor using the nv driver on an old version of xfre86 and not with the nvidia driver, but thats because the nv driver cant detect the resolutions my monitor can do and my monitor wasnt suppost to be doing 2048x1536 but still that was an older version and it worked fine, i hope stupid xfree86 guys tookout that mode, thats the stupidist most ignorant thing i could ever hear, i mean comeon, they already had it supported in an older version! its not like they didnt add it, they would have to have taken it out. weak!
Xevious is offline   Reply With Quote
Old 09-21-02, 08:36 PM   #5
utiel
Registered User
 
Join Date: Aug 2002
Location: mallorca
Posts: 65
Default I think there are 2 problems...

XF86Config doesn't have a modeline for that resolution or
Nvidia drivers thinks your monitor is not capable of that resolution.


Nvidia Readme, says
For modeline generators, Search "Modeline" in freshmeat.net or visit
http://www.xfree86.org/pipermail/xpe...er/012070.html


I recommend, you add Option "IgnoreEDID" "true" in XF86Config.
.
.
.
Section "Device"
Identifier "RIVA TNT2"
Driver "nvidia" #IMPORTANT for NVIDIA users
# Change "nv" to "nvidia
# for use Nvidia driver
VendorName "RIVA TNT2"
BoardName "RIVA TNT2"
#Personal Options
#
Option "IgnoreEDID" "true" #Ignore monitor resolution
Option "NoLogo" "true" #Dont show Nvidia logo at startup
Option "NvAGP" "1" #Use Nvidia's AGP
#0:Disable AGP
#1:Nvidia's AGP
#2:User kernel AGP-gart
#3:Try 2, then 1 (Default)
EndSection
utiel is offline   Reply With Quote
Old 09-22-02, 02:23 AM   #6
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default

ok, i added the modeline, and i know its not because it cant detect my monitor cant do it, the resolution it doesnt detect my monitor cant do, which it can, is 2560x1920. anyway i still get an error, but different..

(WW) NVIDIA(0): Not using mode "2048x1536":
(WW) NVIDIA(0): horizontal sync width (2520 - 2080 = 440) greater than 256
(WW) NVIDIA(0): vertical sync width (1614 - 1538 = 76) greater than 16
Xevious is offline   Reply With Quote
Old 09-24-02, 05:24 PM   #7
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default

so i guess none runnign linux/nvidia drivers is running at 2048x1536 then? if so can you paste your XF86Config
Xevious is offline   Reply With Quote
Old 09-30-02, 12:53 AM   #8
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default

so i guess not one person has xfree 86 4.2.0 with nvidia drivers running at 2048x1536, or who can tell me a modline, that really sux
Xevious is offline   Reply With Quote

Old 02-08-05, 07:32 PM   #9
rmx555
Registered User
 
Join Date: Feb 2005
Posts: 1
Default Re: Why cant I run at 2048x1536 with nvidia drivers

$ gtf 2048 1536 79

# 2048x1536 @ 79.00 Hz (GTF) hsync: 126.95 kHz; pclk: 359.53 MHz
Modeline "2048x1536_79.00" 359.53 2048 2216 2440 2832 1536 1537 1540 1607 -HSync +Vsync
rmx555 is offline   Reply With Quote
Old 02-09-05, 05:08 AM   #10
MadEgg
Registered User
 
Join Date: Apr 2003
Posts: 88
Default Re: Why cant I run at 2048x1536 with nvidia drivers

I don't actually he's waiting for a solution after three years, but anyway
__________________
Proud owner of GF 6800 Ultra AGP and GF 6600 AGP
MadEgg is offline   Reply With Quote
Old 09-16-05, 09:48 PM   #11
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: Why cant I run at 2048x1536 with nvidia drivers

Quote:
Originally Posted by MadEgg
I don't actually he's waiting for a solution after three years, but anyway
hey, it is the thought that counts =), I was able to get all sorts of custom modelines going shortly after that, I am now happily running at 2560x1920.
Xevious is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Nvidia GeForce 310.54 Beta Drivers are Now Available News Archived News Items 0 11-12-12 06:20 PM
vdpau issues with openSUSE 12.2 x86_64 and nvidia 304.43 drivers frispete NVIDIA Linux 0 09-29-12 04:41 PM
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM

All times are GMT -5. The time now is 06:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.