Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-14-03, 12:27 PM   #25
dpw2atox
Registered User
 
Join Date: May 2003
Posts: 170
Default

i hope nvidia releases official support for fedora core 1
dpw2atox is offline   Reply With Quote
Old 11-14-03, 03:01 PM   #26
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

"Official support" from nVidia on the Fedora project would be including precompiled kernel interfaces for the release kernels, and while this would be very nice it would require rebuilding them frequently as the kernel will likely be updated. What would be very beneficial is an RPM release that makes use of pre- and post- install scripts to take care of this type of error.

Recompiling the kernel should NOT be necessary for FC1, unless you need to include other kernel features... but not just for the nVidia driver.

ByteWarrior:
Your problem should be fixed by first configuring your kernel source tree, and then re-running the installer and choosing to let the installer compile the interface for you. Don't say no during the install process, even when it says it wants to try to connect to get a new interface, it will fail politely and then compile one, which is what you want.

First configure your source tree, which will require a couple steps. Make sure you have the source for your kernel installed, these commands will help you do that:
Code:
rpm -qa kernel
rpm -qa kernel-source
uname -r
Make sure here that you see in each of the rpm returns the exact same kernel version (should be: 2.4.22-1.2115.nptl ) that you get from the uname command. If so, you're ready to proceed. If not, then you need to install the kernel-source rpm that matches this version (which contains some letters and numbers).
Next configure the source tree. These commands must be done as root:
Code:
cd /usr/src/linux-2.4.22-1.2215.nptl
make mrproper
cp configs/kernel-2.4.22-athlon.config .config
make menuconfig
Exit the make selecting yes to save changes.
You'll need to then use the previously stated environment variables:
Code:
export CC=gcc32
export IGNORE_CC_MISMATCH=1
(no guys, both should not be necessary but why not do it anyway)

Then attempt to install the nVidia driver again. This time make sure to select yes until it asks you if it can compile a module for you.. and say yes!

Note: export CC=gcc32 is useles sif you don't have the package 'gcc32' installed on your machine (you need this to 'correctly' compile kernel modules.. but it might work without it, maybe)
rpm -q gcc32
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 11-14-03, 08:22 PM   #27
ftz
Registered User
 
Join Date: Dec 2002
Posts: 4
Send a message via ICQ to ftz
Thumbs up Driver install help!!!

You guys are AWSOME!!!!!!!!

I couldn't get UT2003 to run after installing nvidia
drivers. Your posts help me fix it.
Now I get 150-200 FPS, witch I wouldn't believe if I didn't see it with my own eyes.

Of course to install the driver.
export CC=gcc32

To make my openGL games work.
rpm -e --nodeps XFree86-Mesa-libGL

Thank you so much!!!!!!!!
ftz is offline   Reply With Quote
Old 11-14-03, 10:25 PM   #28
djlightning
Registered User
 
Join Date: Nov 2003
Posts: 24
Default

Well if anyone has any other ideas on how to get this to work...I am all ears. I have tried about every suggested way to install this drive and I keep comming up with the exact same result......a big black screen!!! Still havnt figured out how to get back to terminal with this happens, I remember RH would kick you back there if X couldnt load but this isnt the case so I cant change my config file back to use "nv".
djlightning is offline   Reply With Quote
Old 11-15-03, 04:40 AM   #29
ByteWarrior
Registered User
 
Join Date: Nov 2003
Location: Belgium
Posts: 21
Default

Quote:
Originally posted by LordMorgul
ByteWarrior:
Your problem should be fixed by first configuring your kernel source tree, and then re-running the installer and choosing to let the installer compile the interface for you. Don't say no during the install process, even when it says it wants to try to connect to get a new interface, it will fail politely and then compile one, which is what you want.

<snip>
I tried your method, but it didn't work All the version numbers match, and during the install from the driver I always pressed ok/yes.

Still, I keep getting this error:
Code:
ERROR:The kernel header file 
'/lib/modules/2.4.22-1.2115.ntpl/build/include/linux/modversion.h' does not exist.  
The most likely reason for this is that the kernel header files in 
'/lib/modules/2.4.22-1.2115.ntpl/build/include' have not been configured.
I'm a complete newbie, so I don't know what this means, but errors can't be good...

What should I do to configure those files in /lib/modules/... ?
__________________
AMD Athlon 2400+ 256 MB RAM
ASUS A7N8X with GeForce4 400 MX AGP 8X
HD 60 GB
RedHat 9 (Shrike) - kernel 2.4.20
My system logs
My qualification: Linux beginner
ByteWarrior is offline   Reply With Quote
Old 11-15-03, 10:55 AM   #30
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

A proper (normal) way for kernel sources to be installed for Fedora is that the directories:

/lib/modules/<kernelversion>/build
and
/usr/src/linux-<kernelversion>

are the same directory, because the /build is a symlink which redirects to the /usr/src/linux-<> directory.

So, the short answer is that the kernel source tree must be configured to match your currently running kernel. This is a major hassle for someone new to the way this works, I know since I was there too

If my previous method of configuring your kernel didn't work, then you may be forced to compile it yourself... since it should have worked. This doesn't necessarily mean you have to USE a kernel you compiled, but you might. Here are the steps I suggest, partially copied from before:

Code:
cd /usr/src/linux-2.4.22-1.2215.nptl
make mrproper
cp configs/kernel-2.4.22-athlon.config .config
vi Makefile  :  and then remove the string "-custom" from the line "EXTRAVERSION=" 
make oldconfig
make
make modules
Do not use 'make modules_install" unless you intend to use your new kernel, because you're going to be rewritting the installed modules from RPM! (probably don't want to do this yet)

(After you've done this.. go immediately back into the Makefile and replace the "-custom" if you're worried about replacing the modules accidentally)

If after the previous you still cannot build your nvidia module, then you'll need to go all out and build / install / run your own kernel, for which you'll need more guidance. See www.tldp.org for a good kernel building HOW-TO, but keep in mind parts of it may be out of date.. follow the steps, not the exact commands necessarily.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 11-15-03, 10:59 AM   #31
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

Quote:
Originally posted by djlightning
...
I remember RH would kick you back there if X couldnt load but this isnt the case so I cant change my config file back to use "nv".
In grub, enter password, then push e on the kernel boot choice you use, push e on the line that has something like (your kernel version may be different)

kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ hdc=ide-scsi hdd=ide-scsi rhgb

you're now editing the line, add a " 1" to the end of the line to make it:
kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ hdc=ide-scsi hdd=ide-scsi rhgb 1

push enter, then b to boot and you will enter run level 1 to edit the config back to "nv" until you can fix the issue.

Use the command "telinit 5" to go back up to graphical mode.

[edit]
You can also use ctrl-alt-backspace to kill / restart the X server.. which will just kill it if you started X with startx, but restarts the server if you're in runlevel 5. [/edit]
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.

Last edited by LordMorgul; 11-15-03 at 06:22 PM.
LordMorgul is offline   Reply With Quote
Old 11-15-03, 04:53 PM   #32
DrD
Registered User
 
Join Date: Nov 2003
Posts: 5
Default

Quote:
Well if anyone has any other ideas on how to get this to work...I am all ears. I have tried about every suggested way to install this drive and I keep comming up with the exact same result......a big black screen!!! Still havnt figured out how to get back to terminal with this happens, I remember RH would kick you back there if X couldnt load but this isnt the case so I cant change my config file back to use "nv".
Ok, good, GOOD! djlightning has already brought up the EXACT same issue I am having. It apears that I have succesfully installed the nvidia drivers, TWICE now, after 2 reinstalls of Fedora, and both times, after I edit XF86Config and remove Load "dri" and replace Driver "nv" with Driver "nvidia", and start X, the screen goes BLACK. Nothing I can do, until I edit the file and put Driver "nv" back. This can't be a one time deal, becasue I've reinstalled Fedora and got the exact same results.
The only clue I have to anything is that when I check the XFree86.0.Log file, I find an itneresting error: "(EE) GLX Failed to add GLX extension Nvidia XFree86 driver not found"
So what on earth is this? The Driver installed and recompiled my kernel interface seemingly fine, and finsihed with no apearent problems. And yes, Load "glx" is also in the XF86Config file, in the modules section.

If anyone can help me, or djlightning, please do so!
DrD is offline   Reply With Quote

Old 11-15-03, 06:18 PM   #33
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

Quote:
Originally posted by DrD

The only clue I have to anything is that when I check the XFree86.0.Log file, I find an itneresting error: "(EE) GLX Failed to add GLX extension Nvidia XFree86 driver not found"
Do you have the driver where it should be? Missing this would indicate a damaged install, and the system seems unable to locate it.
Code:
ls -l /usr/X11R6/lib/modules/extensions/libglx*
Produces:
Code:
lrwxrwxrwx    1 root     root           18 Oct 29 13:20 /usr/X11R6/lib/modules/extensions/libglx.so -> libglx.so.1.0.4496
-rwxr-xr-x    1 root     root       691856 Oct 29 13:20 /usr/X11R6/lib/modules/extensions/libglx.so.1.0.4496
Is the nvidia X module where it should be?
Code:
ls -al /usr/X11R6/lib/modules/drivers/nvidia_drv.o
Have you removed Mesa libGL from your system? Have you used the NvAGP?

And finally, would you like to attach the X log, config, and system information.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 11-15-03, 10:00 PM   #34
DrD
Registered User
 
Join Date: Nov 2003
Posts: 5
Default

I apprecitate the advice and all, but I hardly have a clue what you are talking about, more so near the end of your post:

Quote:
Have you removed Mesa libGL from your system? Have you used the NvAGP?

And finally, would you like to attach the X log, config, and system information.
sigh... what on earth is that?
You can tell I'm rather irritated (caution, rant alert!) I've been through an insane amount of mind-boggeling issues just TRYING to get the drivers installed (getting binutls and the kernel-source RPMS installed was part of it) whihc took me like 6 hours of reasearch and tinkering and THREE installs of fedora, only to finally get the .run driver file installed, and now this! What???

So you mean that not only will these nvidia drivers not install unless you have such and such RPMs already installed and have to edit the XF86Config file outside of X, but you also have to know about bloody Mesa libGL and NvAGP?!??!?!?!?!?

I don't know whos to blame, nvidia, linux itself. But to have to go through all of this crap just to get stinking OpenGL support is a nightmare!!! What on earth? The user shouldn't have anything to do with this bull crap.

Now that my rant is done, I'm not mad at anyone on the forums, just the situation. Explain what I need to do and what you were reffering to. I doubt the drivers are in the wrong location considering That I completly whiped out fedora the 2nd time, installed the drivers again, and got the same results.
DrD is offline   Reply With Quote
Old 11-16-03, 01:44 AM   #35
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

I'm sorry you are having a hard time getting things configured. That said, you have to realize that the power and control offered you with linux by definition gives you / everyone the chance to get things borked with very little effort required. It is neither the fault of nVidia nor Linux that your system doesn't work, it is simply a combination of the inputs... some difficulties on at least 3 parties (all of which need improvement). Realize that your systems issues are not necessarily the norm.

Mesa.
There is a software rendered openGL library present on Fedora when you install it, as long as you selected it to be installed. It should be there by default. You do not want it there if you are installing the nvidia drivers, as they come with their own GL libraries to take care of this. Not everyone wants to utilize the binary drivers offered by nVidia because they are not open source (the reasons for this are many, and unimportant to the discussion, that is just why Mesa is there). You want to remove one rpm file, containing the libraries, do so (as the root user) with:
Code:
rpm -e --nodeps XFree86-Mesa-libGL
NvAGP:
There are two main options for how your hardware AGP bus is handled in Linux for an nVidia card. Suffice it to say, you can 'ask' the system to use one preferred to the other, and most often the nVidia supplied option is most effective on newer hardware. You do this by adding an option to your XF86Config, in the Device section for the card, after the Driver. Mine reads:
Code:
Section "Device"
         Identifier  "TI4400"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "NV25 [GeForce4 Ti 4400]"
       Option      "NvAGP" "1"
        Option      "NoLogo" "1"
        Option      "HWcursor" "1"
        Option      "CursorShadow" "1"
        Option      "CursorShadowAlpha" "50"
        Option      "CursorShadowXOffset" "5"
        Option      "CursorShadowYOffset" "4"
        BusID       "PCI:1:0:0"
EndSection
where the option NvAGP requests the nVidia supplied AGP driver rather than the kernel source supplied AGP driver. The other options there you may disregard, but are nice additions once you can actually see things.
(your BusID may be different, leave it as is, or it may not be there which is fine)

(still no logs, configs, etc) It really does help us on the forum help you to attach:
/var/log/XFree86.0.log
/var/log/nvidia-installer.log
/var/log/dmesg
/etc/X11/XF86Config
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 11-16-03, 05:51 AM   #36
ByteWarrior
Registered User
 
Join Date: Nov 2003
Location: Belgium
Posts: 21
Default

Quote:
Originally posted by LordMorgul
If my previous method of configuring your kernel didn't work, then you may be forced to compile it yourself... since it should have worked. This doesn't necessarily mean you have to USE a kernel you compiled, but you might. Here are the steps I suggest, partially copied from before:

Code:
cd /usr/src/linux-2.4.22-1.2215.nptl
make mrproper
cp configs/kernel-2.4.22-athlon.config .config
vi Makefile  :  and then remove the string "-custom" from the line "EXTRAVERSION=" 
make oldconfig
make
make modules
Do not use 'make modules_install" unless you intend to use your new kernel, because you're going to be rewritting the installed modules from RPM! (probably don't want to do this yet)

(After you've done this.. go immediately back into the Makefile and replace the "-custom" if you're worried about replacing the modules accidentally)
This method worked!! The nVidia installer didn't complain, it compiled the driver without a hitch.

Thanks!
__________________
AMD Athlon 2400+ 256 MB RAM
ASUS A7N8X with GeForce4 400 MX AGP 8X
HD 60 GB
RedHat 9 (Shrike) - kernel 2.4.20
My system logs
My qualification: Linux beginner
ByteWarrior is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Canonical partners with Microsoft to support Ubuntu on Azure News Archived News Items 0 06-08-12 05:20 AM
Remastered Doom 3 BFG Edition Game Coming with Stereo 3D Support News Archived News Items 0 06-01-12 05:30 AM
Intel's Ivy Bridge Core i7 3770K Overheating Issue Detailed News Archived News Items 0 05-16-12 10:40 AM
CPUMark99 - how do you compare fuelrod Benchmarking And Overclocking 66 07-19-11 08:32 AM
Official Detonator 40.xx Feedback Thread pelly NVIDIA Windows Graphics Drivers 299 09-22-02 06:54 AM

All times are GMT -5. The time now is 04:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.