Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-11-03, 08:56 AM   #1
Lulu
Registered User
 
Join Date: Nov 2003
Posts: 4
Default Red Hat 9 on Geforce FX 5200

Hello,

I have a Geforce Fx 5200 video card.
I just installed Red Hat 9.
During instalation I cannot used the graphic mode so I installed in text mode.
At the end of the instalation I set up the graphic enviroment.
I used GeforceFx generic as video card.
After instalation ends and I restarted my computer, I cannot start de Linux, because my monitor turns off and computer freeze.

What can I do ?
Lulu is offline   Reply With Quote
Old 11-11-03, 10:48 PM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

You can either boot from a cdrom, and manually edit your /etc/X11/XF86Config to 'nv' instead of either 'vesa' or 'nvidia', or you can use the boot loader to change the runlevel you boot into, using a command line parameter. If you're using grub, push p (enter password), then e to edit the middle line (the one below). You want to add a 1 to the end of the line, which will boot to single user text mode where you can edit the file with vi or other text editor. Push enter to save the line change (this boot only..) and then push b to boot.

Code:
title Red Hat Linux (2.6.0-test9)
        root (hd1,4)
        kernel /vmlinuz-2.6.0-test9 ro root=LABEL=/ hdd=ide-scsi
        initrd /initrd-2.6.0-test5.img
here you would change the middle line to:
Code:
       kernel /vmlinuz-2.6.0-test9 ro root=LABEL=/ hdd=ide-scsi 1
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 11-13-03, 09:09 AM   #3
Lulu
Registered User
 
Join Date: Nov 2003
Posts: 4
Default

Hello,

I make the change but it didn't start.
I used XFree86 -configure
After that I test the configuration as it was written on the screen.

The result -> screen became black but I could see an X - mouse poiter - which I was able to move around.

When I return to console (with Ctrl+Alt+BackSpace) I see an error message, something abount can't find screen

I check the configuration file and I sow
screen 0
Don't you think must be another number instead of 0 ?

What should I do ?

Please advice

Lulu
Lulu is offline   Reply With Quote
Old 11-13-03, 09:42 AM   #4
Biased turkey
Registered User
 
Join Date: Nov 2003
Location: Montreal, Canada
Posts: 12
Default

Thanks a bunch for the tip about replacing "vesa" with "nv" in the XFree86Config file.
I purchased an FX5200 last monday and couldn't start X too.
That for sure saved my day.
Biased turkey is offline   Reply With Quote
Old 11-13-03, 10:48 AM   #5
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

Quote:
Originally posted by Lulu
Hello,

I make the change but it didn't start.
I used XFree86 -configure
After that I test the configuration as it was written on the screen.
Evidently we didn't understand each other. My suggestion was not to allow you to get X to work, or to allow it to configure. The commandline parameter suggestion is to allow you to get your machine to boot without going to graphical mode first, to avoid hard lockup problems.

If you are able to get into the machine in any fashion, like the ability to run a configuration program, then you don't need to use single user mode. What you need to do is manually edit your config file to use a screen that is configured.

Configuration programs evidently (I've seen this several times) choose the vesa driver incorrectly for 5200 cards, which will cause a blank screen and inability to work on the machine.

Quote:
Originally posted by Lulu

The result -> screen became black but I could see an X - mouse poiter - which I was able to move around.

When I return to console (with Ctrl+Alt+BackSpace) I see an error message, something abount can't find screen

I check the configuration file and I sow
screen 0
Don't you think must be another number instead of 0 ?

What should I do ?

Please advice

Lulu
Your results sound very much like you're using the 'vesa' driver for your card, which won't work. The screen 0 is not a problem, and is normal... depending on what your config file looks like.

To avoid our misunderstanding, please post (by attachment) these files:

/etc/X11/XF86Config
/etc/X11/XF86Config-4
/var/log/XFree86.0.log

(if any file isn't there, just post the others)
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 11-15-03, 01:56 AM   #6
Lulu
Registered User
 
Join Date: Nov 2003
Posts: 4
Default

Hello Lord Mogul,

The missunderstanding was my fault, because I didn't told you the whole story.

After my first post I erase Linux partitions fromm HDD and I re-installedt Red Hat 9.

This time, at the end of the instalation I skiped XServer configuration.
Now I can boot and login as root in text mode.

I searched for file
/etc/X11/XF86Config
but I didn't find it !?!

That's why I used command XFree86 -configure.
On my screen appears:
"
Your XFreeConfig file is /root/XF86Config.new.
To test the server, run 'XFree86 -xf86config /root/XFConfig.new'
"
I tried to test the server but I sow only a black screen and a mouse cursor on it (like I told you).
I pressed Ctrl+Alt+Backspace and I returned to the prompt.

On the screen I sow:
"
Fatal server error:
no screens found
"
From the list of files you asked for on my HDD I found only this one:
/var/log/XFree86.0.log
and also I find
/var/log/XFree86.0.log.old
I also put enclosed
/root/XF86Config.new
maybe you can figure what it's all about.

I must say since I first installed Linux I can't even sleep and I am also very confused about all those damn folders.
Please help me.

regards, Lulu
Attached Files
File Type: zip files.zip (2.4 KB, 192 views)
Lulu is offline   Reply With Quote
Old 11-17-03, 12:04 AM   #7
Lulu
Registered User
 
Join Date: Nov 2003
Posts: 4
Default

Hello everybody,

I resolved my problem.
Here is the solution:
I boot from Knoppix CD, search for XF86Config file, copy the file on my Red Hat partition, reboot.

Now XWindows starts (kind of slow) but starts.
Lulu is offline   Reply With Quote
Old 11-25-03, 02:25 PM   #8
mweisman
Registered User
 
Join Date: Nov 2003
Location: South Florida, USA
Posts: 2
Default THANKS LordMorgul

Another sincere THANK YOU for your advice about changing the line in /etc/X11/XF86Config to "nv".

I had the exact problem described in this thread and tried your solution. It was certainly the quickest method.

Thanks Again.
mweisman
mweisman is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome3 with composite is very slow on Geforce FX 5200 with 173.14.31 driver Artox NVIDIA Linux 0 05-26-12 10:33 AM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
red hat distros gadido NVIDIA Linux 3 09-02-02 05:17 PM
Source RPMS for GCC3.2 - Red Hat 8.0? chrisw01 NVIDIA Linux 4 08-21-02 08:17 AM

All times are GMT -5. The time now is 03:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.