Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-11-03, 10:14 AM   #1
posterboy
Registered User
 
Join Date: Nov 2003
Posts: 2
Angry IA64 + RH AWS 2.1 + Errata Update = NVidia No Work

I have an HP zx6000 (IA64), with an NVidia 980 XGL running RH AWS 2.1. Recently I applied RH's updates which effectively broke my NVidia driver.

The problem exists with the HP supplied driver (4431) and the one downloaded from NVidia (4050) on the original kernel (2.4.18-e.31) or the updated version (2.4.18-e.37). One of the updates was from XFree86 ver 4.0.2 (trying to remember the original version) to 4.1.0. Considering the symptoms I'm guessing that the XFree86 update broke something.

Basically X tries to start and then goes back to the console. In /var/log/XFree86.0.log I see a bunch of messages about unresolved symbols in /usr/X11R6/lib/modules/drivers/nvidia_drv.o. Of course, this file comes as binary only so I'm checking to see if anyone has found a workaround or if NVidia plans on updating for the newer version of XFree86.

Thanks,
PB
posterboy is offline   Reply With Quote
Old 11-13-03, 08:05 AM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

Did you reinstall the driver after the X update? I certainly would at least try this even tho its not 'strictly' mandatory.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 11-13-03, 08:13 AM   #3
posterboy
Registered User
 
Join Date: Nov 2003
Posts: 2
Default

The drivers were reinstalled.

What's interesting is that if I revert back to the original kernel they won't even compile. Make dies with a message about not support kernel versions < 2.4.12 (the original and updated kernels are both 2.4.18).

On the new kernel, the driver compiles, but it complains about the X11 module when X tries to start...Looking at the NVIDIA_GLX tarball, it appears as though the X11 module comes as binary only; basically the install just copies it over and doesn't compile anything.
posterboy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM

All times are GMT -5. The time now is 12:01 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.