Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-11-03, 10:51 PM   #1
ahelder
Registered User
 
Join Date: Nov 2003
Posts: 2
Unhappy 1.0-4496 2d performance worse than "stock" XFree86 "nv" driver

Hi:

I've noticed an extreme 2d performance loss after switching from the XFree86 "nv" driver to the 1.0-4496 "nvidia" driver under Fedora Core 1. I am aware of the CC_COMPILER_MISMATCH and Xfree86-Mesa-libGL issues, and these are resolved.

To get some kind of quantitative comparison, I created a 6 meg plaintext file (called "foo")Then I did this :

1) Install "nv" driver
2) start X
3) open an xterm and maximize it
4) type "time cat foo"
5) Install the "nvidia" driver

repeat 2-4

Here are the results of dumping the 6 meg text file to the screen using "cat":

"nv" driver 1 min and 2.5 sec
"nvidia" driver : 2 min and 47 sec.

I can't imagine the XFree86 "nv" driver being so much faster than NVidia's own! Here are some more specifics about my system:

Chipset: VIA 686B / VT82C693A/694x
Card : GeForce4 MX-440
OS : Fedora Core 1
Drivers : 1.0-4496
Kernel 2.4.22 (of course)
Gnome 2.4

Also :

(1) I am sure that the nvidia drivers are using AGP (both AGPGART and the nvidia AGP driver produce the same effects)

(2) I am sure that I edited the XF86Config file correctly - "dri" and "glcore" are not loaded, for example

(3) I am aware of (and solved) the compiler mismatch and library conflicts with XFree86-Mesa-libGL using "export cc=gcc32"

(4) XFree86.0.log reports nothing unusual (no missing DRI symbols) Thank you very much for any ideas!

-Alex
ahelder is offline   Reply With Quote
Old 11-12-03, 02:14 AM   #2
russofris
Registered User
 
Join Date: Jul 2003
Posts: 125
Default

Enable renderaccel

In the Device section, put

Option "RenderAccel" "on"



Thank you for your time,
Frank Russo





Section "Device"
Identifier "FX 5600"
Driver "nvidia"
#VideoRam 131072
# Insert Clocks lines here if appropriate
Option "NoLogo" "on"
Option "RenderAccel" "on"
Option "CursorShadow" "on"

EndSection
russofris is offline   Reply With Quote
Old 11-12-03, 09:08 AM   #3
dropman
Registered User
 
Join Date: May 2003
Posts: 9
Default

I tried time cat foo on my slackware9.1 linux.
P3 800, 256mb sdram, GF2MX400, latest nvidia drivers, 1024x768 resolution.
I used Konsole instead of xterm
And here is what i get:
nvidia 44sec
nv 44sec
vesa 1m 6sec

strange results

i also tried to turn on RenderAccel but it seems there is no effect for me
dropman is offline   Reply With Quote
Old 11-12-03, 09:10 AM   #4
ahelder
Registered User
 
Join Date: Nov 2003
Posts: 2
Default

Thanks for the RenderAccel suggestion - I forgot to mention that I did try this, with absolutly no effect whatsoever.

-Alex
ahelder is offline   Reply With Quote
Old 11-12-03, 09:40 AM   #5
mariuz
Albino penguin
 
mariuz's Avatar
 
Join Date: Dec 2002
Location: Transylvania
Posts: 114
Default

Quote:
Originally posted by ahelder
Thanks for the RenderAccel suggestion - I forgot to mention that I did try this, with absolutly no effect whatsoever.

-Alex
Yep 2d performance is the same with RenderAccel on
__________________
http://www.firebirdsql.org
mariuz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM
RH7.3 and nForce - can't find the module dmw400 NVIDIA Linux 4 08-05-02 12:14 PM

All times are GMT -5. The time now is 06:10 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.