Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-23-02, 08:15 AM   #1
medon
Guest
 
Posts: n/a
Default SearchAndRescue

Hi,
I have Riva TNT M64 and recent kernel modules. When I try to play game SearchAndRescue, I just receive a message:
Unable to find useable X Visual.
Or with debug option set it writes:
GW Debug: glXChooseVisual(): RGBA double buffer X Visual not available.
GW Debug: glXChooseVisual(): RGBA single buffer X Visual not available.
GW Debug: glXChooseVisual(): RGB double buffer X Visual not available.
GW Debug: glXChooseVisual(): RGB single buffer X Visual not available.

The developer has written to me:
"As long as you have 16, 24, or 32 bits with a TrueColor
visual and a card that has an alpha channel, SAR should
find the appropriate X Visual."

I have a 16 bits color depth. Where is the problem?
  Reply With Quote
Old 09-23-02, 09:16 AM   #2
utiel
Registered User
 
Join Date: Aug 2002
Location: mallorca
Posts: 65
Default check XF86Config

Do you Have Load "dbe" and Load "glx" in Section "Module"??
ex.
Section "Module"
Load "dbe"
Load "extmod"
Load "freetype"
Load "type1"
Load "glx"# Add this line
# And
# Remove or coment under lines
#Load "dri"
#Load "GLcore"
EndSection

And, Do you have any MesaGL library in /usr/lib or /usr/X11R6/lib?
They can conflict with NV GL library

Good luck

Last edited by utiel; 09-23-02 at 09:49 AM.
utiel is offline   Reply With Quote
Old 09-23-02, 09:33 AM   #3
medon
Guest
 
Posts: n/a
Default

Yes, I have everything in XF86Config. I have xlibmesa3 instaled in both /usr/lib, /usr/X11R6/lib, but NV GLX has rewritten them when it was installing. Quake2 is working well.
  Reply With Quote
Old 09-23-02, 09:55 AM   #4
utiel
Registered User
 
Join Date: Aug 2002
Location: mallorca
Posts: 65
Default

Quote:
Originally posted by medon
Yes, I have everything in XF86Config. I have xlibmesa3 instaled in both /usr/lib, /usr/X11R6/lib, but NV GLX has rewritten them when it was installing. Quake2 is working well.
Nvidia install /usr/lib/libGL.*
But if there is any libGL.* (not libGLU*) in /usr/X11R6/lib, they can conflict.

If QuakeII,III works well.. I don't know...
Perhaps TNT(1) is limited.

My TNT2-M64 doen't have S3TC(texture compression in OpenGL)

Have you tried if game works with Xfree (nv) and MesaGL?
utiel is offline   Reply With Quote
Old 09-23-02, 10:00 AM   #5
medon
Guest
 
Posts: n/a
Default

I have RIVA TNT2 Model 64 as well. No I have not tried it with nv driver.
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:10 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.