Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-29-03, 07:09 PM   #1
machuidel
Registered User
 
Join Date: Nov 2003
Posts: 8
Unhappy [GF FX 5700Ultra] Lock-ups when running 3D applications in X (ex. glxgears)

Hi,

I have a problem with my Geforce FX 5700 Ultra I bought today. XFree starts up showing the NVidia logo, everything in 2D works, but when I run "glxgears" it hangs after running fine for about 5/7 seconds. Even though it looks like a total lock-up I'm still able to move and close the "glxgears" window with my mouse or switch consoles with my keyboard, but it is responding very slow (10 to 60 sec. delay). Other 3D applications hang as well (Tuxracer, WineX). The output of "glxgears" as follows:

16534 frames in 5.0 seconds = 3306.800 FPS
326 frames in 9.0 seconds = 36.222 FPS
X connection to :0.0 broken (explicit kill or server
shutdown).

I have the following setup:
Card: Geforce FX 5700 Ultra
Driver: Linux x86 1.0-4496
Video BIOS: 04.36.20.18.01
CPU: 2x Pentium III 500 MHz (SMP)
MB: Asus P2B-DS Dual Slot1, Intel440BX, 100MHz, 4SDRAM, 4PCI, 2ISA, AGP2X, SCSI, ATX
Mem: 128MB

I tried the following combinations and setups without luck:
- XFree 4.2.1.1 with Linux 2.4.22 (Once with DRI compiled in and once without)
- XFree 4.2.1.1 with Linux 2.4.19 (Without DRI compiled in)
- XFree 4.3 with Linux 2.4.22 (Once with DRI compiled in and once without)
- XFree 4.3 with Linux 2.4.19 (Without DRI compiled in)
- XFree 4.3 with Linux 2.4.18 (Without DRI compiled in)
- Turned off the use of AGP with the NvAgp option set to "0"
- Turned on the use of the Nvidia AGP driver with the NvAgp option set to "1" (without module "agpgart" loaded)
- Turned on the use of the AGPGArt driver with the NvAgp option set to "2"
- Turned on the use of the Nvidia AGP driver with pssible fallback to AGPGart with NvAgp set to "3"
- Commented out all the options in the Device section except the Indentifier, VendorName, Driver and BusID
- Checked BusID with "lspci", and was correct
- Runned kernel with the "noapic" and "pci=noacpi" options, and checked if it was really turned of afterwards
- Set AGP to 2x
- Set AGP to 1x
- With APM turned off (in kernel)
- Made sure DRI module wasn't loaded
- Installed external cooling for the NVIDIA card
- Tweaked MTTR settings, did all combinations with and without
- Used Uniprocessor instead of Dual

Any idea what's wrong? I'm really out of ideas

Thank you,

Mike

[edit]
A stupid mistake pointed out by raiford. I changed all occurences of 2700 to 5700.
[/edit]
Attached Files
File Type: log xfree86.0.log (26.5 KB, 103 views)

Last edited by machuidel; 12-01-03 at 06:30 PM.
machuidel is offline   Reply With Quote
Old 11-29-03, 07:12 PM   #2
machuidel
Registered User
 
Join Date: Nov 2003
Posts: 8
Default

Here my XF86Config as attachement and my /proc/interrupts as follows:

Code:
           CPU0       CPU1
  0:      97384      97218    IO-APIC-edge  timer
  1:       8372       8306    IO-APIC-edge  keyboard
  2:          0          0          XT-PIC  cascade
  5:          0          0   IO-APIC-level  EMU10K1, usb-uhci
  8:          4          0    IO-APIC-edge  rtc
 10:        630        633   IO-APIC-level  eth0
 11:      68772      68182   IO-APIC-level  nvidia
 12:      13523      13654    IO-APIC-edge  PS/2 Mouse
 14:       9575       9201    IO-APIC-edge  ide0
 15:          1          1    IO-APIC-edge  ide1
NMI:          0          0
LOC:     194531     194518
ERR:          0
MIS:          0
machuidel is offline   Reply With Quote
Old 11-29-03, 07:14 PM   #3
machuidel
Registered User
 
Join Date: Nov 2003
Posts: 8
Wink

Sorry, again
Attached Files
File Type: txt xf86config.txt (4.6 KB, 113 views)
machuidel is offline   Reply With Quote
Old 11-30-03, 07:19 AM   #4
machuidel
Registered User
 
Join Date: Nov 2003
Posts: 8
Post

My machine is about 5 years old and I still have a PSU of 230w inside (probably too low). I haven't tested a PSU with higher watts yet.

Could that be the problem?

[edit]
By now I have done some testing with different power supplies. Conclusion with 400W PSU (Qtec Dual fan) and 450W PSU (Aopen):
Still the same results as before with the 230W PSU.
[/edit]

Last edited by machuidel; 12-01-03 at 05:53 PM.
machuidel is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:23 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.