Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-24-03, 07:09 PM   #1
devjam
Registered User
 
Join Date: Nov 2003
Posts: 4
Question nvnet doesnt work after update ...

hi,

With some help of a friend i installed the following
driver:
NVIDIA_nforce-1.0-0261.suse90.i586.rpm

After we got it work, i called the SUSE-Linux-Online-Update
and installed all patches that were possible.
There has been a patch for NVIDIA, a Kernel-Patch for AMD-CPUs
and some other patches. So after this patches and reboot i am
not more possible to connect to internet.

I am newbee on Linux!

if i type "ifconfig" on shell i get this:

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:60 errors:0 dropped:0 overruns:0 frame:0
TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:3912 (3.8 Kb) TX bytes:3912 (3.8 Kb)

if i'm looking on the details of networkadapter in SUSEplugger
i see that the name of the adapter is correct.
status is: availability = yes
configured = no
driver info:

Driver Info #0:
Driver Status: nvnet is not active
Driver Activation Cmd: "modprobe nvnet"

if i type "modprobe nvnet" into a shell i get this:

Using /lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol __netdev_watchdog_up_Ra7000325
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol eth_type_trans_Rd36c0dd3
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol skb_over_panic_R9ee181c3
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol softnet_data_R6d8f9943
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol netif_rx_Rfadb88b1
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol alloc_skb_Rdee41f6c
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresolved symbol __kfree_skb_Raebda71a
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.


please help me, i don't know what to do or what i am doing wrong.
i tried to reinstall the driver but it seems not working

thanx a lot
devjam is offline   Reply With Quote
Old 11-25-03, 05:14 AM   #2
devjam
Registered User
 
Join Date: Nov 2003
Posts: 4
Default

is realy no one out there, who can help me?


PLEASE
devjam is offline   Reply With Quote
Old 11-26-03, 05:13 PM   #3
sirius
Registered User
 
Join Date: Nov 2003
Posts: 5
Smile

Don't worry, I have the same problem, am working on a solution and once I have it working, will tell you.

Basically you ignored a warning message when seleting the updates, that users using the pre-compiled binary version for the SuSE 9.0 version (using by default the kernel 2.4.21-99-athlon i.e. revision 99) will have to recompile the nvnet and nvaudio driver after the upgrade to the fixed -144 revision of the 2.4.21 kernel.

What's to do now is:

a) get the kernel sources and the nvidia driver as tarball (*.tar)
b) transfer them, i.e. via usb stick or CD as they are large
c) install the sources and upack the tarball
d) recompile the kernel-modules as described on the nvidia pages
e) try using the module with modprobe nvnet

reboot. done. good luck

related links:
http://portal.suse.com/sdb/en/2002/01/ftpkernel.html
- Updating your Kernel with RPM Packages
http://download.nvidia.com/XFree86/n..._1.0-0261.html
- nForce Linux Driver Release Notes
http://www.nvidia.com/object/linux_nforce_1.0-0261.html
- Linux nForce Driver
http://www.suse.de/de/private/download/ftp/inland.html
- SuSE Mirrors
need kernel-source-2.4.21-144.src.rpm + the one for athlon
sirius is offline   Reply With Quote
Old 11-26-03, 06:05 PM   #4
devjam
Registered User
 
Join Date: Nov 2003
Posts: 4
Default

Thanx a lot! I'll try it tomorrow and tell you if i have had luck!
devjam is offline   Reply With Quote
Old 11-29-03, 05:25 PM   #5
sirius
Registered User
 
Join Date: Nov 2003
Posts: 5
Default still problems ...

The current problem I have is to get the k_athlon-2.4.21-144.src.rpm kernel source installed. after rpm -Uhv finishes, i still can't find the new sources ... then I guessed that the above package is only an update to the kernel-source-2.4.21-144.src.rpm for the athlon. but installing them in sequence also does not work .... no src, no compile, no nvnet :-(((

Anybody successfull yet?

sirius is offline   Reply With Quote
Old 11-29-03, 07:54 PM   #6
buster
Registered User
 
Join Date: Nov 2003
Posts: 5
Default Got it working!!!!!

I’ve been having the same problem and finally got it to work. I’m new to all of this and I’m not sure that everything that I did was necessary, but in the end it worked. Here’s exactly what I did.

SuSE 9.0
AMD Athlon XP +2800
NVIDIA nForce2 Ethernet Controller
Connected to a Linksys Wireless Access Point Router (DHCP)

Downloads:

Athlon kernel source 2.4.21
k_athlon-2.4.21-144.i586.rpm
http://www.suse.de/en/private/downlo...t_mirrors.html
(Select a site (i386) and follow /suse/i386/9.0/suse/i586/ from your entry point)
Download to /usr/src/packages/RPMS/athlon

Linux nForce drivers:
NVIDIA_nforce-1.0-026.src.rpm
http://www.nvidia.com/object/linux_nforce_1.0-0261.html
Download to /usr/src/packages/SRPMS

Installation:

1) Update the kernel: I used YaST2 to do this for me by left clicking on the k_athlon-2.4.21-144.i586.rpm file and then clicking on the “Install packages with YaST” button. Presumably the directions in http://portal.suse.com/sdb/en/2002/01/ftpkernel.html will also work, except that SuSE 9.0 uses GRUB, so the lilo command at the end doesn’t seem to apply. I wasn’t sure how to configure the boot loader for GRUB, so that’s why I decided to let YaST2 do the work. Don’t forget to reboot.

(After the kernel upgrade you should see a 2.4.21-144-athlon directory in lib/modules)

2) Build the driver from source: I followed the directions in the READ.ME from NVIDIA
http://download.nvidia.com/XFree86/n..._1.0-0261.html starting at “Alternative SuSE Installation”. After updating the kernel the d series packages were already installed, but it would be a good idea to check to make sure (From the desktop launch YaST2 then follow Yast2 Software>Install and Remove Software and then change “Filter:” menu from Search to Package Groups. The required packages should be checked.)

2a) Set up the development environment following the directions in the NVIDIA READ.ME. Make sure to start in the usr/src/packages/SRPMS directory. After the popd command you should return to this directory as root.

2b) Install the source RPM (remain as root):

rpmbuild --rebuild NVIDIA_nforce-1.0-026.src.rpm

(I did not see a line that said :
Wrote: /usr/src/{RPM root dir}/RPMS/i386/nforce{package na****-1.0-1.rpm
Instead look for NVIDIA_nforce-1.0-0261.i586.rpm in /usr/src/packages/RPMS/i586)

2c) Install the binary RPM:

cd ./RPMS/i586

rpm –i NVIDIA_nforce-1.0-0261.i586.rpm

(At this point there should be a nvnet.o file in /lib/modules/2.4.21-144-athlon/kernel/drivers/net)

2d) load the module

modprobe nvnet

3) Follow directions at the bottom of the NVIDIA READ.ME for changing the Systems BIOS configuration. (ie changed PNP OS Installed to NO). This requires you to reboot.
(Note: This may not be necessary, since after the installation I changed the System BIOS back to the original configuration and am still able to get a network connection.)

4) Configure the Network card:
From the desktop launch YaST2 and follow Network Devices > Network Card to the “Network cards configuration” window. Click on the Configure button launching the “Manual network card configuration” window. Under “Module name” enter

nvnet

then press the Next button and complete the rest of the configuration. I’m behind a router with a DHCP connection and didn't have to change any of the fields after this point.

From there I was able to get a connection. Hope this works for you.

Later
buster is offline   Reply With Quote
Old 11-29-03, 08:19 PM   #7
buster
Registered User
 
Join Date: Nov 2003
Posts: 5
Default Errata

typo (in case you don't know how to switch directories (like me)):

in step 2c)

cd ./RPMS/i586

should be

cd ../RPMS/i586

Also, after step 2d) if you decide not to reconfigure the Systems BIOS you should reboot after loading the module.
buster is offline   Reply With Quote
Old 11-30-03, 06:09 AM   #8
technics
Registered User
 
Join Date: Nov 2003
Posts: 1
Default

hi
i got the nvnet driver to work without problems, after installing the kernel-source, works just fine, but the nvaudio module doesnt (i am using the binary nforce driver).
i keep getting the "unresolved symbols" error everytime i boot/load the module, but it still works in kde, xmms, etc. but other apps (mplayer eg.) dont work properly anymore
i really need nvaudio, because it supports spdif out, or is there a way to get that standard driver to work with spdif!?

any help would be appreciated..
technics
technics is offline   Reply With Quote

Old 11-30-03, 07:00 PM   #9
sirius
Registered User
 
Join Date: Nov 2003
Posts: 5
Default To Buster: can you post the new rpm?

Buster:

Can you please post the new rpm?
I tried to do the same, but again, on my machine the compile failed with some error messages on the nvnet.c while building the nvnet.o.

This would be very helpfull for all the people who have upgraded to the new kernel build -144 and need the nvnet and nvaudio drivers.

Thanks a lot!

Sirius
sirius is offline   Reply With Quote
Old 11-30-03, 10:51 PM   #10
buster
Registered User
 
Join Date: Nov 2003
Posts: 5
Default forgot an important first step

sirius

I don't think the binary will do you much good. Sorry to say, but I forgot to mention that I performed a necessary first step, and that was to install the binary

kernel-source-2.4.21-144.i586.rpm

Feeling guilty I tried to install and load the nvnet module straight from different NVIDIA binaries without using the NVIDIA source rpm, and was unable to load nvnet into the kernel. (In fact, without the kernel-source it wouldn't even compile from its source rpm.) From this I can only conclude that one needs to follow the NVIDIA READ.ME and set up the development environment ie

% cd /usr/src/packages/SRPMS
% su
Password: *******
# pushd /usr/src/linux
# make cloneconfig
# make dep
# popd

and then start installation with the source rpm (as I did in my previous posting). Hopefully with updaing the kernel source as your very first step and then following the directions from my previous post, you'll be able to get things running. It was the only (and I mean only)way I got it to work.

Good luck and sorry about the mistake
buster is offline   Reply With Quote
Old 12-01-03, 06:06 AM   #11
sirius
Registered User
 
Join Date: Nov 2003
Posts: 5
Default

Buster, thanks a lot, but I did this as a first step, but to no avail.

I actually endet up with a lot of tar.bz2 files containing the .21 kernel and the pathches for the suse revision -144. I tried it about 10 times, in different variations and finally even unpacked the tarball's, applied the patches, moved the source to /usr/src/linux.2.4.21-144/ , symlink to ./linux but still the compile fails ..... complaining to need to use some other header files ... did that too as described, now the message is gone to but the compile errors stay, claiming some mistake in the nvnet.c ......

I'm realy starting to get fed up with this now .

As I understand it, as long as you have the same patchlevel, one actually CAN use the binaries from a different machine.
As far as your tests are concerened, you tried to use the precompiled ones from the nvidia website, which require the patch level -99. however, your have the kernel with patchlevel -144. Therefore I would like to test, if your NVIDIA_nforce-1.0-0261.i586.rpm found in your /usr/src/packages/RPMS/i586 might work on my machine.

I think what is wrong with my machine is something trivial but hard to find and I'm close to completely setting up the machine anew. So at the moment, I would be very gratefull if you could post your -144 rpm ....

thanks (It's the last thing I want to try)

Cheers and Thanks
sirius is offline   Reply With Quote
Old 12-01-03, 12:43 PM   #12
buster
Registered User
 
Join Date: Nov 2003
Posts: 5
Default will post soon

sirius,

I talked to our sys admin and he'll let me post the rpm on our site, so you'll be able to download it. Unfortuantely, it's at home. Once it's posted I'll post the address here.

Later
buster is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiseat X with two cards: used to work, now segfaulting Artefact2 NVIDIA Linux 10 06-26-12 06:22 PM
Tribes: Ascend Staying Alive update adds sticky grenades, disco Brute News Archived News Items 0 05-22-12 08:10 AM
295.40 Does not Work Had to downgrade to 295.33 Archmbc NVIDIA Linux 4 05-03-12 03:38 PM

All times are GMT -5. The time now is 01:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.