Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-03-03, 04:49 PM   #1
Norman
Gigabyte GeForce 6600 GT
 
Join Date: Oct 2003
Posts: 18
Default VESA framebuffer modes are not available if TV is plugged

Normally I use mode 791 ( 1024x768 16 bit ) of the linux VESA framebuffer driver ( linux 2.4.22 ). But when I plug in the TV at boot time, grub comes up with the message "You passed an undefined mode number". However, I know that this mode is supported by the TV-out of my card ( Geforce4 MX 440 ) because I use nView with that mode under Windows. So I would like to ask if someone knows a solution on how to use the VESA framebuffer modes even if a TV is plugged. Could it be that the VESA BIOS extension of the graphics card is disabled when TV-out is enabled ? Does the linux riva driver support a GeForce4 and may it work while TV-out is enabled ?

Last edited by Norman; 10-03-03 at 05:22 PM.
Norman is offline   Reply With Quote
Old 10-04-03, 11:51 AM   #2
vnpenguin
GeForce4
 
Join Date: Mar 2003
Location: Belgium
Posts: 28
Send a message via Yahoo to vnpenguin
Default

Hi,
I never use TV-out in my card. With "GeForce4 MX 440" and nVidia driver 4496 I can use framebuffer (vga=791) without any problem. Since I changed to "GeForce4 MX 440 AGP8x" the framebuffer no longer work any more. I think there is problem with AGP support ...
I have posted my question longtimes, but no response at all
vnpenguin is offline   Reply With Quote
Old 12-08-03, 11:01 AM   #3
ribx
Registered User
 
Join Date: Nov 2003
Location: germany, baden
Posts: 32
Unhappy i know what you mean...

my kyroII also worked fine with the vesa frame buffer, but the GF4mx440 agp8x (aka nv18) doesnt support any higher resolutions.. i worked very hard on this problem, because i realy love workin in the text console.. i think the problem on my card is that the tv-out is always enabled. this causes problems with the bios, because every bootloader reads out the resolutions which are supported by the card from the bios at boottime.

btw pls try the command:
lilo -T video

i get this back:

VGA/VESA adapter

640x350x16 mode 0x0010
640x480x16 mode 0x0012

320x200x256 mode 0x0013
640x480x256 mode 0x0101
800x600x256 mode 0x0103

Enable Screen Refresh bug is present.

strange is that i cannot find anything about this bug in google! i never had such a problem which wasnt found in google!

the problem is that there are no fb support from nvidia. they do not give any source codes to the developpers of linux .. so they cannot create an fb for nvidia (in my opinion: this sux a bit :P )
ribx is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
320.17 can't detect video modes on Lenovo laptop tadawson NVIDIA Linux 13 07-14-12 01:40 AM
Missing Video Modes Enverex NVIDIA Linux 0 06-22-12 06:30 AM
fonts were nicer with VESA driver, any hints? wim NVIDIA Linux 1 08-27-02 12:03 PM

All times are GMT -5. The time now is 09:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.