Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-03-03, 03:09 PM   #1
mdq
Registered User
 
Join Date: Dec 2003
Posts: 2
Default 2.6, Debian Sid and libc 2.3.2.ds1-10. GLX error (about TLS...).

Hello,

I upgraded from 2.4 to 2.6, and compiled nvidia drivers patched with www.minion.de code (following the procedure from that web). Then, I also copied the various TLS binaries to their locations. But xfree doesn't load the GLX extension:

-------/var/log/XFree86.0.log-----
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
dlopen: /usr/lib/libGLcore.so.1: undefined symbol: __gl_tls_var0
(EE) Failed to load /usr/X11R6/lib/modules/extensions/libglx.so

(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (loader failed, 135874371)
------------------------------------

Other modules load correctly, and xfree is usable (no quake, of course :-P ).

In case of using the no-TLS version, the X screen remains black and the consoles freeze with at half bright tone (though the system is responsive).

---------/etc/X11/XF86Config-4-----
Option "NvAGP" "0"
---------------------------------------

System:
* Debian Unstable/Sid
* libc6 2.3.2.ds1-10 (I have searched through varous web sites and mailing lists and it seems to be a problem related to the last versions of libc -though libc mantainers passed "the ball" to the nvidia package mantainers. Tsk, tsk, closed source is not a good thing...-).
* xfree86-common 4.2.1-14
* xserver-xfree86 4.2.1-14
* Linux 2.6.0-test11

Hardware:
motherboard DFI AD77 Infinity
Athlon XP 1700+

~/downl/video$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400 AGP] Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
00:0b.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
00:0f.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
00:10.0 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235 AC97 Audio Controller (rev 50)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440SE AGP 8x] (rev a2)
mdq is offline   Reply With Quote
Old 12-03-03, 10:51 PM   #2
ghostwalker
Registered User
 
Join Date: Sep 2003
Location: Tacoma, WA
Posts: 76
Default

Hey get the following www.minion.de and do

NVIDIA-Linux-x86-1.0-4496-pkg#.tar.gz --extract-only

I had to actually go into the NVIDIA-?? directory and issue a make install
and that copied all of the necessary lib's.

Last edited by ghostwalker; 12-03-03 at 10:56 PM.
ghostwalker is offline   Reply With Quote
Old 12-04-03, 09:40 PM   #3
mdq
Registered User
 
Join Date: Dec 2003
Posts: 2
Default

Forget about it. I just reinstalled it and now it runs fine.

Procedure:
-apply # patch
-apply diff patch
-make install

Q3 (I have only tried this one so far) had also the same problem with libc6, so I had to execute quake3 +set vm_game 2 +set vm_cgame 2 +set vm_ui 2.
mdq is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.