Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-16-02, 04:00 PM   #1
sndev
Registered User
 
Join Date: Oct 2002
Posts: 9
Default tv and monitor picture problem

hello all
i will take picture on monitor and my tv when start X
i have GF 4 mx 440

any help?

my xf86config ..


Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "type1"
Load "speedo"
Load "extmod"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc101"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "ButtonNumber" "5"
Option "Device" "/dev/mouse"
Option "InputFashion" "Mouse"
Option "Name" "Autodetection"
Option "Protocol" "imps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
DisplaySize 310 230
HorizSync 22-69
Identifier "Monitor[0]"
ModelName "107S (17 ZOLL/CM1300)"
VendorName "Philips"
VertRefresh 50-120
UseModes "Modes[0]"
EndSection

# TV
Section "Monitor"
Identifier "Monitor[1]"
ModelName "PAL TV"
VendorName "SONY"
VertRefresh 60
HorizSync 30-50
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 71.39 1024 1088 1264 1384 768 768 778 802
Modeline "1024x768" 81.59 1024 1088 1264 1384 768 768 778 802
Modeline "1024x768" 91.63 1024 1088 1264 1384 768 768 778 802
Modeline "1280x1024" 102.24 1280 1296 1552 1736 1024 1024 1033 1070
Modeline "1280x1024" 114.82 1280 1296 1552 1736 1024 1024 1034 1070
Modeline "832x624" 40.44 832 848 968 1112 624 624 629 652
Modeline "832x624" 47.17 832 848 968 1112 624 624 634 652
Modeline "832x624" 53.91 832 848 968 1112 624 624 634 652
Modeline "832x624" 60.65 832 848 968 1112 624 624 634 652
Modeline "832x624" 67.39 832 848 968 1152 624 624 634 652
Modeline "832x624" 74.52 832 848 968 1152 624 624 634 652
Modeline "800x600" 37.44 800 816 928 1072 600 600 605 626
Modeline "800x600" 43.68 800 816 928 1072 600 600 610 626
Modeline "800x600" 49.92 800 816 928 1072 600 600 610 626
Modeline "800x600" 56.16 800 816 928 1072 600 600 610 626
Modeline "800x600" 62.40 800 816 928 1112 600 600 610 626
Modeline "800x600" 68.64 800 816 928 1112 600 600 610 626
Modeline "800x600" 71.76 800 816 928 1112 600 600 610 626
Modeline "640x480" 23.96 640 656 720 864 480 480 484 501
Modeline "640x480" 27.96 640 656 720 864 480 480 490 501
Modeline "640x480" 31.95 640 656 720 864 480 480 490 501
Modeline "640x480" 35.94 640 656 720 864 480 480 490 501
Modeline "640x480" 39.94 640 656 720 864 480 480 490 501
Modeline "640x480" 43.93 640 656 720 864 480 480 490 501
Modeline "640x480" 47.92 640 656 720 864 480 480 490 501
Modeline "720x400" 22.46 720 736 824 1008 400 400 403 417
Modeline "720x400" 26.21 720 736 824 1008 400 400 410 417
Modeline "720x400" 29.95 720 736 824 1064 400 400 410 417
Modeline "720x400" 33.70 720 736 824 1064 400 400 410 417
Modeline "720x400" 37.44 720 736 824 1064 400 400 410 417
Modeline "720x400" 41.18 720 736 824 1064 400 400 410 417
Modeline "720x400" 44.93 720 736 824 1064 400 400 410 417
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x1024" "1024x768" "1024x768" "832x624" "800x600" "800x600" "640x480" "640x480" "640x480" "720x400"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x1024" "1024x768" "1024x768" "832x624" "800x600" "800x600" "640x480" "640x480" "640x480" "720x400"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1280x1024" "1024x768" "1024x768" "832x624" "800x600" "800x600" "640x480" "640x480" "640x480" "720x400"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x1024" "1024x768" "1024x768" "832x624" "800x600" "800x600" "640x480" "640x480" "640x480" "720x400"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
Option "TwinView" "on"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "MetaModes" "1024x768"
EndSection

# RITHMISEIS TV
Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "640x480"
EndSubSection
Device "Device[1]"
Identifier "TV"
Monitor "Monitor[1]"
EndSection

# OTHONI
Section "Device"
BoardName "GeForce4 MX 440"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
EndSection

# TV OUT
Section "Device"
BoardName "GeForce4 MX 440"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[1]"
Screen 0
VendorName "NVidia"
Option "TVOutFormat" "COMPOSITE"
Option "TVStandard" "PAL-B"
Option "ConnectedMonitor" "TV"
EndSection




Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection
sndev is offline   Reply With Quote
Old 10-16-02, 04:45 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Um... what's the problem now? It wasn't especially clear from your post...

If your problem is with TwinView (which you have enabled), then the one issue I see is your MetaModes option. This should (from the nVidia README) be a semicolon-separated list of comma-separated meta-modes. Like this, assuming you want 1024x768 on the first screen and 640x480 on the second screen as a first choice, and 800x600 on the first screen with 640x480 on the second screen, as a fallback:

Option "MetaModes" "1024x768,640x480; 800x600,640x480"
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 10-19-02, 10:28 AM   #3
sndev
Registered User
 
Join Date: Oct 2002
Posts: 9
Default

My problem is that: i want to use my tv and my monitor at the same time when "X" are loaded.My monitor is recognised as primary devise and my tv as secondary device. This moment i get signal ("view") only in my monitor but not in my tv and i do not know how am i going to use bot, monitor and tv, at the same time. I tried using some changes in the xf86config but i failed so if you could help me somehow i whould be grateful. Thanx for your time
sndev is offline   Reply With Quote
Old 10-24-02, 12:48 AM   #4
TA00
Registered User
 
Join Date: Aug 2002
Posts: 29
Default

Hello !

I have the same problem with this card and a SuSE 8.0 and now 8.1. I've set "MetaModes" correctly and I've try to force using both (Monitor and TV) with "ConnectedMonitors" "CRT, TV" but if I use "TV" with this option - X don't start "screen(s) found but none have a useable configuration" - if I don't use this string Xfree.0.log displays "only one device found; disabling twinview".
I don't know how to ge it work. No replay from nvidia support.

If you found out what's the problem please send a message.
TA00 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.