Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-07-03, 05:17 AM   #1
Electrode
cogito ergo doleo
 
Join Date: Aug 2003
Posts: 23
Send a message via ICQ to Electrode
Default GeForce FX 5600 Ultra, dual CRT, Xinerama: Second screen garbled

They say a picture is worth a thousand words:



The nvidia logo, when it first appears, looks perfect. The corruption shows up when it disappears. Note that the mouse cursor looks just fine. Twinview works, this problem only shows up when using Xinerama.

Mobo: Tyan Thunder K8W
CPU: Dual AMD Opteron 240
RAM: 1 GB
Video: Gainward GeForce FX 5600 Ultra
Other cards: Creative Sound Blaster Audigy, pcHDTV HD-2000 TV card

Distro: LFS
Kernel: 2.4.23
X: 4.3.99.12
Nvidia driver: 4620 (also tried 4496)

And to answer the first question (if Twinview works, why not use it?), I will soon be adding another video card to run my third monitor, and Twinview won't work with that.
Electrode is offline   Reply With Quote
Old 12-11-03, 01:49 PM   #2
Electrode
cogito ergo doleo
 
Join Date: Aug 2003
Posts: 23
Send a message via ICQ to Electrode
Default

↑
Electrode is offline   Reply With Quote
Old 12-14-03, 12:32 AM   #3
Electrode
cogito ergo doleo
 
Join Date: Aug 2003
Posts: 23
Send a message via ICQ to Electrode
Default

anyone?
Electrode is offline   Reply With Quote
Old 12-14-03, 02:34 PM   #4
Phorem
Registered User
 
Join Date: Dec 2003
Location: Toronto
Posts: 34
Default

1. Post your XF86Config

2. Post "dmesg"

3. Does your AGP work on the first monitor? I notice you got the K8T800 chipset that was a pain in the butt to get going for me.

Just a quick note, if the logo comes up and then you get a bunch a garbage on the second monitor, it's usually the resolution or Refresh rate.
__________________
Gentoo Linux-64, AMD64 Athlon 3200, Asus K8V Deluxe, 1 gig(3200 400mhz) ram, GeForce FX5200 128, HP 400i DVD+R+RW, HP ScanJet 2200c, Epson Stylus C84, JVC DRV3000U (firewire - usb), Kodak CX6330
Phorem is offline   Reply With Quote
Old 12-14-03, 04:09 PM   #5
Electrode
cogito ergo doleo
 
Join Date: Aug 2003
Posts: 23
Send a message via ICQ to Electrode
Default

1. XF86Config is attached. The commented out parts are the Xinerama-related stuff.

2. Here's the only part of my dmesg that has anything to do with the video card:

Code:
Dec 13 19:30:09 belphegor kernel: 0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module  1.0-4620  Mon Sep 29 08:49:59 PDT 2003
Dec 13 19:30:11 belphegor kernel: AGP: Found AGPv3 capable device at 4:0:0
Dec 13 19:30:11 belphegor kernel: AGP: Found AGPv3 capable device at 5:0:0
Dec 13 19:30:11 belphegor kernel: AGP: Enough AGPv3 devices found, setting up...
Dec 13 19:30:11 belphegor kernel: AGP: Setting up AGPv3 capable device at 4:0:0
Dec 13 19:30:11 belphegor kernel: AGP: Setting up AGPv3 capable device at 5:0:0
3. The chipset is the AMD 8111+8151, NOT the VIA K8T800. AGP works fine.

4. I'll try different settings for the second monitor. Right now I'm just using some settings that I'm pretty sure are wrong and relying on EDID to correct them.
Electrode is offline   Reply With Quote
Old 12-14-03, 04:10 PM   #6
Electrode
cogito ergo doleo
 
Join Date: Aug 2003
Posts: 23
Send a message via ICQ to Electrode
Default

forgot attachment
Attached Files
File Type: txt xf86config.txt (3.6 KB, 137 views)
Electrode is offline   Reply With Quote
Old 12-14-03, 05:40 PM   #7
Phorem
Registered User
 
Join Date: Dec 2003
Location: Toronto
Posts: 34
Default

From what i see in your XF86Config, you would have to have both monitors set to 800x600 as that is the max for the second monitor. They HAVE to be the SAME for twinview to work.
__________________
Gentoo Linux-64, AMD64 Athlon 3200, Asus K8V Deluxe, 1 gig(3200 400mhz) ram, GeForce FX5200 128, HP 400i DVD+R+RW, HP ScanJet 2200c, Epson Stylus C84, JVC DRV3000U (firewire - usb), Kodak CX6330
Phorem is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
Dual Display with main CRT, and secondary TV-out BlackDogg NVIDIA Linux 3 08-10-02 09:52 AM

All times are GMT -5. The time now is 07:45 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.