Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-15-03, 12:04 PM   #1
zero05
Registered User
 
Join Date: Apr 2003
Posts: 3
Unhappy asus a7n8x sound does not work

Hi,

i installed the newest nforce2 drivers on my debian sid box (kernel 2.4.20).
After compiling i tried to install the nvaudio module and the following error occured:

rage:~# modprobe nvaudio
/lib/modules/2.4.20/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_probe_codec_R84601c2b
/lib/modules/2.4.20/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_adc_rate_R5307368c
/lib/modules/2.4.20/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_dac_rate_R42924aaa
/lib/modules/2.4.20/kernel/drivers/sound/nvaudio.o: insmod /lib/modules/2.4.20/kernel/drivers/sound/nvaudio.o failed
/lib/modules/2.4.20/kernel/drivers/sound/nvaudio.o: insmod nvaudio failed

any ideas?

BTW: the network driver works fine
zero05 is offline   Reply With Quote
Old 04-15-03, 12:46 PM   #2
douglass
Registered User
 
Join Date: Apr 2003
Location: SouthEast
Posts: 13
Default

You need the ac97_codec module loaded.
Try either:
insmod ac97_codec
or
modprobe -a nvaudio (-a loads all dependancies).

I think that debian comes with an app called modconf that will put the appropriate modules both in your initscripts and your initrd image.
I would guess this comes from ac97_codec being required with i810_audio in recent kernels.

Hope it helps.
-Chris
douglass is offline   Reply With Quote
Old 04-16-03, 02:36 AM   #3
zero05
Registered User
 
Join Date: Apr 2003
Posts: 3
Smile

aah thats it thanks

Sirko
zero05 is offline   Reply With Quote
Old 12-23-03, 04:59 PM   #4
toscana
Registered User
 
Join Date: Dec 2003
Posts: 2
Default

I have compiled a debian 2.4.23 kernel. If you compile your own kernel, it's very easy to install the sound driver for the asus A7N8X deluxe.
To compile your own kernel, there is enough information....

When you're doing make menuconfig, choose
Intel ICH (i8xx), SiS 7012, NVidia nForce Audio or AMD 768/811x
in Sound -> Sound Card Support

For the network card driver, just run the make and make install, it works...afterwards you can run modconf to insert the nvnet module


Greetz
__________________
-----Toscana-----
toscana is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Review of the 23-inch Asus VG23AH Passive 3D IPS Display News Archived News Items 0 06-21-12 07:40 PM
ASUS GeForce GTX 670 DirectCU II Top Unveiled Features 1137MHz Boost Clock (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 06:30 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
Asus Bios bug nforceuser NVIDIA Linux 3 10-06-02 04:15 AM
nForce sound locking up system shroom NVIDIA Linux 4 09-16-02 01:50 AM

All times are GMT -5. The time now is 01:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.