Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-09-03, 01:06 PM   #1
msc
Registered User
 
Join Date: Dec 2003
Posts: 11
Post Glx, Tls, 4499, Amd64

My system: Dual Opteron, Redhat 2.9ELsmp, GeForce FX5600, 4499 driver.
Like several others here, if I try to load glx, X dies. I get a signal 11. I've attached my XF86Config, as well as the two log files (with and without glx).

I've also tried using the SuSE fix on the NVIDIA download page. Same result.

One difference between what I am doing and at least one other person here who has been successful, is that my /lib/libc.so.6 supports TLS (Thread-Local Storage), and theirs did not. According to the README from nvidia, there should be additional tls libraries installed in /usr/lib/tls.

However, there are no tls libraries included in the nvidia 4499 tarballs, even though the Makefile for the glx libraries refers to them.

TLS may have nothing to do with the problem, but, like the installer, it is something that the README says is included, but isn't.

Can anyone who has this working check to see if their libc.so.6 supports TLS. To do so, simply enter /lib/libc.so.6 and see if it says "Thread-local storage support included."

Thanks for any help.
msc is offline   Reply With Quote
Old 12-09-03, 01:07 PM   #2
msc
Registered User
 
Join Date: Dec 2003
Posts: 11
Default

XF86 Config file
Attached Files
File Type: txt xf86config.txt (3.8 KB, 116 views)
msc is offline   Reply With Quote
Old 12-09-03, 01:07 PM   #3
msc
Registered User
 
Join Date: Dec 2003
Posts: 11
Default

log file with signal 11
Attached Files
File Type: log xfree86.0.txt.log (40.6 KB, 136 views)
msc is offline   Reply With Quote
Old 12-09-03, 01:08 PM   #4
msc
Registered User
 
Join Date: Dec 2003
Posts: 11
Default

log file when glx is not loaded
Attached Files
File Type: txt xfree86.0.log.noglx.txt (40.6 KB, 118 views)
msc is offline   Reply With Quote
Old 12-09-03, 02:24 PM   #5
SnapIT
Registered User
 
Join Date: Jun 2003
Posts: 154
Default

could you post your dmesg?

As i see it the problem is related to the kernel module rather than X..
SnapIT is offline   Reply With Quote
Old 12-09-03, 02:57 PM   #6
msc
Registered User
 
Join Date: Dec 2003
Posts: 11
Default

My dmesg....
Attached Files
File Type: txt dmesg.txt (15.4 KB, 155 views)
msc is offline   Reply With Quote
Old 12-09-03, 04:17 PM   #7
Phorem
Registered User
 
Join Date: Dec 2003
Location: Toronto
Posts: 34
Default

Before when i couldn't get my agp to work (check my thread http://www.nvnews.net/vbulletin/show...threadid=22036) i had to use NvAGP "1" and that would allow me to boot into X using just PCI and not agp. I noticed in your XF86Config you were using "2". Using "1" might let you get into the X server where it'll be a little easier to work on your agp issue.

Here is my output from /lib/libc.so.6.........

switch@darkstar:~$ /lib/libc.so.6
GNU C Library stable release version 2.3.2, by Roland McGrath et al.
Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.
Compiled by GNU CC version 3.2.3.
Compiled on a Linux 2.4.20 system on 2003-05-18.
Available extensions:
GNU libio by Per Bothner
crypt add-on version 2.1 by Michael Glad and others
linuxthreads-0.10 by Xavier Leroy
BIND-8.2.3-T5B
libthread_db work sponsored by Alpha Processor Inc
NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk
Report bugs using the `glibcbug' script to <bugs@gnu.org>.
switch@darkstar:~$


My system works fine in 32bit or 64 (in pci and agp now on 2.4.23) without the support you mentioned. I am also using beta 4620 drivers as well.
__________________
Gentoo Linux-64, AMD64 Athlon 3200, Asus K8V Deluxe, 1 gig(3200 400mhz) ram, GeForce FX5200 128, HP 400i DVD+R+RW, HP ScanJet 2200c, Epson Stylus C84, JVC DRV3000U (firewire - usb), Kodak CX6330
Phorem is offline   Reply With Quote
Old 12-09-03, 11:51 PM   #8
otan
Registered User
 
Join Date: Dec 2003
Posts: 20
Default

What Hardware do you use ?
otan
otan is offline   Reply With Quote

Old 12-10-03, 08:10 AM   #9
msc
Registered User
 
Join Date: Dec 2003
Posts: 11
Default

Phorem,

I'm not sure it is an AGP issue. If I try setting NvAGP to anything other than 0 or 2, X locks up my machine and even using ssh to come in from another machine to kill X doesn't get me back. I have to reboot. This happen regardless of whether I try to load glx or not.

Otan,
What other hardware info do you need? My motherboard is a Tyan K8W.
msc is offline   Reply With Quote
Old 12-10-03, 08:42 AM   #10
SnapIT
Registered User
 
Join Date: Jun 2003
Posts: 154
Default

Quote:
Originally posted by msc
Phorem,

I'm not sure it is an AGP issue. If I try setting NvAGP to anything other than 0 or 2, X locks up my machine and even using ssh to come in from another machine to kill X doesn't get me back. I have to reboot. This happen regardless of whether I try to load glx or not.

Otan,
What other hardware info do you need? My motherboard is a Tyan K8W.
The problem is that the chipset does not report the settings correctly and the Nvidia driver is very anal about correct settings...

In other words, your chipset is not supported...

If i were you i would use the minion patch and the 2.6 kernel, or manually install everything...

Another solution would be to manually install it, the driver most probably will work, it just doesn't know that it will...

It would be interesting to know the results if you decide to try installing it manually, if you do, please e-mail me at snap.it@telia.com
SnapIT is offline   Reply With Quote
Old 12-10-03, 03:25 PM   #11
otan
Registered User
 
Join Date: Dec 2003
Posts: 20
Default

I have the same problem as you have with the same hardware. In my case
my System is running fine until you install the nvidia drivers.
One problem i have: It is crashing when the nvidia drivers
print the bios of my GraphicsCard a PNY FX1000 . It crashes with
a signal 11.
I have some information for the reason, but no solution, yet.
I am checking if the info is true, before i release it.
You will hear more soon...
p.s> One is able to solve a problem, if one knows what causes it.
Maybe it is Hardware or it is Software related.

otan

Last edited by otan; 12-10-03 at 03:45 PM.
otan is offline   Reply With Quote
Old 12-10-03, 04:07 PM   #12
Phorem
Registered User
 
Join Date: Dec 2003
Location: Toronto
Posts: 34
Default

Ok, i don't know if the K8T800 is supported, but i know it WORKS fine if you use kernel 2.4.23 and configure the agp like mine - config attached.
I'm not going to type all of this stuff again, but like i said above, goto this link in these threads http://www.nvnews.net/vbulletin/show...hreadid=22036.

This worked for me. I have agp enabled, and i am using the AMD64 Athlon 3200 with the Asus K8V Deluxe which uses the same chipset as everyone else in this thread (well at least Otan). Again, i'm using the 4620 beta drivers that i got from a link posted on this forum and i installed them just like any other of Nvidia's *.run files.

All i am saying, is that it worked for me and i'm going to do my best to get it to work for everyone else out there that has the same chipset and wants to use their computer and not wonder (like me for a couple of weeks) if they wasted their hard earned coin.
Attached Files
File Type: txt config-2.4.23.txt (19.7 KB, 107 views)
__________________
Gentoo Linux-64, AMD64 Athlon 3200, Asus K8V Deluxe, 1 gig(3200 400mhz) ram, GeForce FX5200 128, HP 400i DVD+R+RW, HP ScanJet 2200c, Epson Stylus C84, JVC DRV3000U (firewire - usb), Kodak CX6330
Phorem is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
GLX bug? (1.0-3123) marc NVIDIA Linux 2 09-21-02 04:58 PM
Remote Accelerated GLX and Raster Display Oddity dzzero NVIDIA Linux 2 09-18-02 01:59 PM

All times are GMT -5. The time now is 09:32 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.