Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-28-03, 10:31 AM   #1
--- Zest ---
Registered User
 
Join Date: Dec 2003
Location: Netherlands
Posts: 7
Unhappy Suse 9.0 crashes on boot (it's driver-ing me nuts)

Hi,

I'm a newbie at Linux and I've installed Suse Linux 9.0 on my system and everything worked fine at first. Then I tried to install the nVidia Linux driver twice after reading a LOT of documentation about this (with sometimes totally different instructions.

TRY 1
I used these instructions from Suse:
-------------------------------------------------
I. SuSE Linux 9.0
-----------------

1) Kernel sources must be installed and configured. Usually this means
installing the 'kernel-source' package with YaST2. Update it - if not
already done - via YaST2 Online Update (YOU).

2) Use the nvidia installer for 1.0-5328.

sh NVIDIA-Linux-x86-1.0-5328-pkg1.run

3) Configure XFree86 with

sax2 -m 0=nvidia (0 is a digit, not a letter!)

NOTE: There is no need to try to enable 3D support. It's already
enabled, when the nvidia driver is running. Ignore the
misleading error message, that 3D support can't be enabled.
This problem will be fixed with SuSE > 9.0 and is related to the
latest nvidia driver release.
-------------------------------------------------

So I found out how to boot to the VGA console instead of X (init 3). Then I proceeded with steps 2) and 3). Note that I forgot to check if I had the kernel sources installed!
Anywayz. At step 3) the screen just went black and every now and then the harddisk LED would light up for a short time. After waiting 15 mniutes I just reset my system which to my amazement booted .. phew..
I could not run OpenGL apps though. So I found in other documentation how to configure the display adapter for XFree, so I followed these instructions from nVidia and rebooted:

----------------------------------------------------------------
(sec-03) EDITING YOUR XF86CONFIG FILE
__________________________________

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist. There are also numerous options that can be added to
the XF86Config file to fine-tune the NVIDIA XFree86 driver. Please see
Appendix D for a complete list of these options.

Once you have configured your XF86Config file, you are ready to restart
X and begin using the accelerated OpenGL libraries. After you restart X,
you should be able to run any OpenGL application and it will automatically use the new NVIDIA libraries.
----------------------------------------------------------------

After that I saw the nvidia logo upon booting the system and I could start tuxcart for example, but the opgenGL apps ran terribly slow! Less than 1 fps.

So I went on with
TRY 2
Since I now found out that I had forgotten to check if the kernel sources were installed I tried the instructions from Suse again, this time I installed the kernel sources first . Then I changed the /etc/inittab file to boot to to the VGA console (init 3). The I followed steps 2) and 3) from the Suse instructions.
At step 3) the screen just went black again and every now and then the harddisk LED would light up for a short time. After waiting 15 minutes I just reset my system which started to the vga console. However, upon entering the 'startx' command the screen just flashes and goes black.
So now I'm really stuck since I can only get to the console and not back to the X system anymore...

I don't know how to get a copy from the log files to post here because I can't access those files from Windows, which I'm writing this with. I did open them from the console though and noted this error, because I think this is the most important clue:

-----------------------------------------
Failed to initialize NVIDIA kernel module
*** Aborting ***
Screen(s) found, but none have a usable configuration

Fatal server error:
no screens found
-----------------------------------------

Please help me, I'm going nuts here....
Further info:

System:
Epox 8K3A mainboard
Athlon XP 1800+
256 MB RAM
ASUS GeForce 4 Ti4200

Driver:
NVIDIA-Linux-x86-1.0-5328-pkg1.run
--- Zest --- is offline   Reply With Quote
Old 12-28-03, 01:35 PM   #2
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

Try HERE or use the 4620 drivers for Suse9, i've found them to be much better.

try1 is the currect why
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 12-28-03, 05:27 PM   #3
--- Zest ---
Registered User
 
Join Date: Dec 2003
Location: Netherlands
Posts: 7
Default

I can't bvelieve it : it works (the driver from sh.nu)

!!!! THANX x 1000 !!!!

After 8 hours of frustration this solution works!
Since I haven't done anything different from my try1, may I conclude that the problem was due to a (major) bug in the nvidia driver?
--- Zest --- is offline   Reply With Quote
Old 12-31-03, 04:46 AM   #4
martinj
Registered User
 
Join Date: Dec 2003
Posts: 10
Default

hi,
I've got the same problem but i don't know what you did exactly. Can you write me a short reply what i must do? Thanks

bye
martinj is offline   Reply With Quote
Old 01-02-04, 10:34 AM   #5
--- Zest ---
Registered User
 
Join Date: Dec 2003
Location: Netherlands
Posts: 7
Default

Here's what to do for Kernel versions 2.4.xxx
(For versions 2.6.xxx you need the other driver from http://www.sh.nu/download/nvidia)

1) install the Kernel sources. Usually this means
installing the 'kernel-source' package with YaST2. Update it - if not
already done - via YaST2 Online Update (YOU).

2) Download the ALTERNATIVE nvidia installer for 1.0-5328.

http://www.sh.nu/download/nvidia/lin...-5328-pkg0.run

from http://www.sh.nu/download/nvidia/linux-2.4/

3) Boot linux to the VGA console. You can do this in 2 ways:

a) edit the etc/inittab file and change the line
id:5:initdefault:
to
id:3:initdefault:
Note that this is a definite change until you edit the file back to it's original state.

The easy way is to start the console and type 'init 3'

4) install the driver:

Change to the dir with the driver and run:

sh NVIDIA-Linux-x86-1.0-5328-pkg0.run

The .run file is a self-extracting archive. When the .run file is executed,
it extracts the contents of the archive, and runs the contained 'nvidia-installer'
utility, which will walk you through installation of the NVIDIA driver.

3) Configure XFree86 with

sax2 -m 0=nvidia (0 is a digit, not a letter!)

NOTE: There is no need to try to enable 3D support. It's already enabled,
when the nvidia driver is running. Ignore the misleading error message,
that 3D support can't be enabled. This problem will be fixed with
SuSE > 9.0 and is related to the latest nvidia driver release.

5) Edit your XF86config file:

This is located here: /etc/X11/XF86Config

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist.

Once you have configured your XF86Config file, you are ready to restart
X and begin using the accelerated OpenGL libraries. After you restart X,
you should be able to run any OpenGL application and it will automatically use the new NVIDIA libraries.

4) boot back into x, by typing

init 5


This should work if I haven't forgotten anything :-)
Good Luck!
--- Zest --- is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 08:30 PM
Mandrake 9.0 driver installation Andy Mecham NVIDIA Linux 3 10-02-02 04:12 PM
Mandrake 9.0 upgrade - x crashes gozilla NVIDIA Linux 2 09-27-02 10:04 AM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 12:31 PM
how to boot SuSe 8.0 to console? chrisr NVIDIA Linux 8 08-19-02 09:08 PM

All times are GMT -5. The time now is 07:20 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.