Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-17-04, 11:22 AM   #1
BradReed
Registered User
 
Join Date: Nov 2004
Location: Cairo, Egypt
Posts: 18
Default nvidia module no longer loads under linux-2.6.10-rc3-mm1

It appears 2.6.10-rc3-mm1 once again kills the nvidia module. When loading the module, it complains:

nvidia: Unknown symbol class_simple_create
nvidia: Unknown symbol class_simple_device_add
nvidia: Unknown symbol class_simple_destroy
nvidia: Unknown symbol class_simple_device_remove
nvidia: Unknown symbol class_simple_create

And I see the 2.6.10-rc3-mm1 patch includes:

root@galactus:/home/breed/Tarballs/Patches[1012]# fgrep -- -EXPORT_SYMBOL\(class 2.6.10-rc3-mm1
-EXPORT_SYMBOL(class_simple_create);
-EXPORT_SYMBOL(class_simple_destroy);
-EXPORT_SYMBOL(class_simple_device_add);
-EXPORT_SYMBOL(class_simple_set_hotplug);
-EXPORT_SYMBOL(class_simple_device_remove);

Just thought people might be interested.
BradReed is offline   Reply With Quote
Old 12-17-04, 12:53 PM   #2
valdis
Registered User
 
Join Date: Apr 2003
Posts: 48
Default Re: nvidia module no longer loads under linux-2.6.10-rc3-mm1

You can just change those EXPORT_SYMBOL to EXPORT_SYMBOL_GPL and rebuild your kernel. They used to be _GPL, they were patched to be EXPORT_SYMBOL, the patch was agreed to be bad - the only problem is that one of the kernel maintainers needs to re-clone their BitKeeper repository in a slightly different manner for the fixing patch to get pushed to Andrew Morton and appear in the -mm stream. So hopefully it should be fixed for good in -rc3-mm2 if it happens, or 2.6.10-mm1, if that's the next -mm version.

Patch attached....
Attached Files
File Type: txt fix-gpl-export.txt (1.4 KB, 833 views)
valdis is offline   Reply With Quote
Old 12-17-04, 04:00 PM   #3
BradReed
Registered User
 
Join Date: Nov 2004
Location: Cairo, Egypt
Posts: 18
Smile Re: nvidia module no longer loads under linux-2.6.10-rc3-mm1

Quote:
Originally Posted by valdis
You can just change those EXPORT_SYMBOL to EXPORT_SYMBOL_GPL and rebuild your kernel. They used to be _GPL, they were patched to be EXPORT_SYMBOL, the patch was agreed to be bad - the only problem is that one of the kernel maintainers needs to re-clone their BitKeeper repository in a slightly different manner for the fixing patch to get pushed to Andrew Morton and appear in the -mm stream. So hopefully it should be fixed for good in -rc3-mm2 if it happens, or 2.6.10-mm1, if that's the next -mm version.

Patch attached....
Thanks for the patch, It will come in handy. I had already manually made those changes though as I wanted to tryout the realtime-preempt patches and have nvidia too.

So far, I like the realtime-preempt.
BradReed is offline   Reply With Quote
Old 12-29-04, 01:09 PM   #4
mistermachine
Registered User
 
Join Date: Nov 2004
Posts: 40
Default Re: nvidia module no longer loads under linux-2.6.10-rc3-mm1

Quote:
Thanks for the patch, It will come in handy. I had already manually made those changes though as I wanted to tryout the realtime-preempt patches and have nvidia too.

So far, I like the realtime-preempt.
i am using a planet-ccrma version of this kernel (for audio production), and am unable to build any of the nvidia drivers (well, i think it builds the module, but says it is "unable to load module nvidia.ko" or something).

is the only way to address this issue by rebuilding the kernel, or are there patched nvidia drivers that might deal with it?

shayne
mistermachine is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 02:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.