Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-02-04, 05:26 PM   #1
Alan666
Registered User
 
Join Date: Aug 2002
Location: Portland, OR
Posts: 14
Default `/usr/lib/libGL.la' is not a valid libtool archive

When trying to get a some OpenGL programs to build, I get the error:

`/usr/lib/libGL.la' is not a valid libtool archive

and the compile errors out.

Any ideas what is going wrong here? This is the first time I have seen this error.

I am using NVIDIA-Linux-x86-1.0-5328-pkg1.run and Fedora 1.

Thanks!
Alan666 is offline   Reply With Quote
Old 01-02-04, 07:10 PM   #2
SuLinUX
 
SuLinUX's Avatar
 
Join Date: Sep 2003
Location: UK
Posts: 847
Default

In /usr/lib there is a file called "libGL.la" , in the file where it says,

Generated by nvidia-installer: 1.0.3

replace with

Generated by nvidia-installer: 1.0.3(for use by libtool)

That will sort it but you need to be root to change it.
__________________
AthlonXP 2600+ / nForce2 Asus A7N8X-X / PNY GeForce FX5900 Ultra / 1024Mb Samsung Ram /nForce Sound / Hansol 920D Plus 19" monitor / Lite-On 32x12x40 / 2x Maxtor HD 40Gb/80Gb / nVidia 7174 driver / Gnome 2.10.1 / Kernel 2.6.11.9 / Slackware 10.0
SuLinUX is offline   Reply With Quote
Old 01-02-04, 09:36 PM   #3
Alan666
Registered User
 
Join Date: Aug 2002
Location: Portland, OR
Posts: 14
Default

That fixed it!

Thanks!

Alan666 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.