Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-02-04, 09:55 PM   #1
ltal
Registered User
 
Join Date: Jan 2004
Posts: 1
Unhappy blackscreen/freeze on X

Athlon XP1700+
Biostar M7MIA motherboard
HPT370 onboard IDE controller (installed on this)
Geforce 4 Ti4200 AGP 128MB
SBLive Value
Dell 1901FP monitor
Gentoo linux kernel 2.6.0

I've tried many different versions of the nvidia-kernel and nvidia-glx drivers.
No errors come out of X, although I have some strange behavior in my messages log. I get no splash screen, no nothing, X simply refuses to load and the system hard locks (while using the nvidia driver).

I know there have been problems with 5328 so I rolled back to 4496.

When I try to use the 'nv' driver I get a complaint about being unable to setup the write-combining region. X sort of loads, I get no splash screen or hatched background but twm comes up very large (looks like 640x480) and I have no mouse cursor, but windows take focus and I can get the twm menu, although clicking 'exit' only removes the window headers and I have to ctrl-alt-bksp to get out of X and there are two copies of the message saying X was forcibly killed.

Help? It's been a week and I still have no X, it's really starting to hurt. Thanks in advance. -Justin

Cut from messages, first the login and crash, then the reboot to show dmesg:

/var/log/messages
XFree86.0.log

Kernel config
(I have added support for my AMD 761 chipset and removed ACPI as well, not reflected in this file)
XF86Config
ltal is offline   Reply With Quote
Old 01-03-04, 11:25 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default

Just a small thing to point out but:

Your nVidia X driver is being loaded without you having a Load "nvidia" in the Modules section of your XF86Config.
whig is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.