Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-07-04, 05:23 AM   #1
zyroth
Registered User
 
Join Date: Jan 2004
Posts: 1
Default Driver problem with kernel 2.6.0

Trying to install the NVIDIA-Linux-x86-1.0-5328-pkg1.run driver with my 2.6.0 kernel but it wont work at all.

This is the error message im recieving:

ERROR: The kernel header file
'/lib/modules/2.6.0/build/include/linux/modversions.h' does not
exist. The most likely reason for this is that the kernel header
files in '/lib/modules/2.6.0/build/include' have not been
configured.

Im running the kernel totally static cause i didnt get the init-modules-tools to work appropriate. Also im using Xfree version 4.3.0
Redhat 9

All minimun software requirements are met except
Kernel modutils 2.1.121 # insmod -V.
module-init-tools version 0.9.15-pre4
__________________
zyr
zyroth is offline   Reply With Quote
Old 01-07-04, 06:52 AM   #2
moali
Registered User
 
Join Date: Oct 2002
Location: Austria
Posts: 31
Default

You still need the patch from

http://www.minion.de

The drivers released from nvidia do not support 2.6

moali
moali is offline   Reply With Quote
Old 01-07-04, 08:00 AM   #3
ribx
Registered User
 
Join Date: Nov 2003
Location: germany, baden
Posts: 32
Default modules ..

the nvidia is always compiled as a module. if you have no support for loading modules in the kernel, you will not be able to install nvidia drivers.

ps: if your run this computer as a desktop mashine and not a server, try debian or gentoo
ribx is offline   Reply With Quote
Old 01-07-04, 08:12 AM   #4
moali
Registered User
 
Join Date: Oct 2002
Location: Austria
Posts: 31
Default Re: Driver problem with kernel 2.6.0

Quote:

Im running the kernel totally static cause i didnt get the init-modules-tools to work appropriate.
OK. I read over this.

But installing them should be no problem.

Get the latest release e.g. from
ftp://ftp.kernel.org/pub/linux/kerne...rusty/modules/
and follow the instructions given in the readme (incl. doing make moveold at the beginning).

Then modprobe should work as a kind of wrapper: If you use kernel 2.4 it calls modprobe.old and therefore you cannot see any difference. Same for insmod, etc.

The new module-init-tools are only used if you boot 2.6

moali
moali is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 12:19 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.