Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-15-04, 05:08 PM   #1
fatchoumakou
Registered User
 
Join Date: Jan 2004
Posts: 5
Angry :( X doesn't start with driver 5328

Hello,
I installed version 5328 of nvidia drivers and updated my XF86Config-4 file.
Infortunately, it doesn't work, X server crashes on startup. My configuration is:
GeForce FX5200
cpu AMD ATHLON XP 2600
motherboard ASUS A7V8X-X
I use mandrake linux 9.2 with 2.4.19-16mdk kernel.

Look at the attach file it contains output of the command "startx -- -verbose 5 -logverbose 5" +
XF86Config-4 + XFree86.0.log

Any suggestions ?

Thank you in advance
Attached Files
File Type: log attach.log (52.6 KB, 235 views)
fatchoumakou is offline   Reply With Quote
Old 01-16-04, 05:52 AM   #2
fatchoumakou
Registered User
 
Join Date: Jan 2004
Posts: 5
Default

have you got any Idea ?
Maybe, things to add to config file ??
fatchoumakou is offline   Reply With Quote
Old 01-16-04, 03:10 PM   #3
Moled
cheese
 
Join Date: Aug 2003
Posts: 137
Default

check dmesg for a kernel panic
Moled is offline   Reply With Quote
Old 01-16-04, 03:44 PM   #4
blueworm
[DEADAGAIN]blueworm
 
blueworm's Avatar
 
Join Date: Mar 2003
Posts: 416
Default

I have a sneaky suspicion that mandrake has agpgart compiled into kernel.
Try adding.... to your Device section in XF86Config-4
Code:
Option "NvAGP" "2"
blueworm is offline   Reply With Quote
Old 01-16-04, 04:14 PM   #5
fatchoumakou
Registered User
 
Join Date: Jan 2004
Posts: 5
Default

Thank you blueworm, that was the good option to add, it works perfectly :-)
fatchoumakou is offline   Reply With Quote
Old 01-17-04, 01:32 PM   #6
fatchoumakou
Registered User
 
Join Date: Jan 2004
Posts: 5
Default

It seems there is another problem with agppart module. When i switch to a terminal
without X by pressing ctrl-alt-f1, the screen blinks white and black and i can't
see anything. It's the same thing when i shutdown my pc with services screen.

Here is a part of the output of the dmesg command :

0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-5328 Wed Dec 17 13:54:51 PST 2003
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: Detected Via Apollo Pro KT400 chipset
agpgart: unable to determine aperture size.
0: NVRM: AGPGART: unable to retrieve symbol table

in log file I've got :

(WW) NVIDIA(0): Failed to verify AGP usage

Can you see where is the problem from ?
fatchoumakou is offline   Reply With Quote
Old 01-17-04, 03:15 PM   #7
darkhelmet03
Registered User
 
Join Date: Jul 2003
Posts: 62
Default I would say

install a newer kernel, either 2.4.24 or 2.6.1, AGPGART is vastly improved there

VIA chipsets are known to be problematic and newer kernel versions i
I recollect had many VIA specific fixes. 2.4.19 is relatively old and KT400 is new...

if u don't wantto mess with ur kernel try enabling only NvAGP and disable AGPGART
darkhelmet03 is offline   Reply With Quote
Old 01-18-04, 07:20 AM   #8
fatchoumakou
Registered User
 
Join Date: Jan 2004
Posts: 5
Default

Are there other solutions than upgrading my kernel ?
Because if i change my kernel, i think many other problems will
appear ...
How do i enable NvAGP and disable AGPGART ?
fatchoumakou is offline   Reply With Quote

Old 01-18-04, 07:26 AM   #9
blueworm
[DEADAGAIN]blueworm
 
blueworm's Avatar
 
Join Date: Mar 2003
Posts: 416
Default

Unfortunately if AGPGART is compilled into the kernel NvAGP cannot be enabled.
You would have to re-compile your kernel and remove AGPGART support as mentioned earlier.
Linux is the kernel, the sooner you learn to be comfortable re-compilling the kernel the better...
blueworm is offline   Reply With Quote
Old 01-21-04, 09:42 PM   #10
melikamp
Registered User
 
Join Date: Jan 2004
Posts: 3
Default

I had this problem when I tried to update my 2.4.22 slackware kernel with 5328 driver. No matter how I configured my kernel, I always had

(WW) NVIDIA(0): Failed to verify AGP usage

in the logs, and whilst the X mostly worked, I had to startx twice (1st one always crashed), and the 3D acceleration lagged like hell. I tried building the driver against 2.6.1 kernel, but configuration failed.

I solved it by stepping back to 4496 and 2.4.22 kernel, which works fine for now. X started and UT and Quake are running fine :P

Mel
melikamp is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 12:23 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
NVIDIA 3123 driver on SuSE 8.0 Ok , but slow to start X Gabolander NVIDIA Linux 3 09-27-02 07:41 AM
failing to initialize NV driver PsyShook NVIDIA Linux 10 09-19-02 12:41 PM

All times are GMT -5. The time now is 03:49 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.