Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-13-04, 12:06 AM   #1
ManixT
Registered User
 
Join Date: Jun 2003
Posts: 6
Default [1.0-5328] X nvidia module init problem.

I have applied the patch from the minion.de site for the 1.0-5328 driver branch so I could compile the driver with support for my 2.6.0 kernel. I also upgraded the module-init-tools to 3.0-pre5 due to some problems with the older version and installing the module. The installation went perfect and the module was installed:

#: lsmod
Module Size Used by
nvidia 2071752 -

The 3.0-pre5 version of modprobe was silent when "modprobe nvidia" was run, but version 0.9.14 reports:

FATAL: Module nvidia already in kernel.

I have also verified that /lib/module/2.6.0/kernel/drivers/video/nvidia.ko exists (and I symlinked to /lib/module/2.6.0/video/nvidia.ko just incase).

The problem is that XFree86 4.3.0 fails to find the nvidia module (XFree86config file is perfectly setup with the device driver being "nvidia" and glx enabled). The glx driver loads with no problem but when the nvidia module is being loaded XFree86 reports the following error:

(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)

I can supply additional information as nessicary and I greatly appreciate any possible help or information (like how XFree finds modules) on the subject.
ManixT is offline   Reply With Quote
Old 01-13-04, 01:49 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

The error message is referring to /usr/X11R6/lib/modules/drivers/nvidia_drv.o, the NVIDIA XFree86 driver module; it seems that your installation is incomplete. You can use one of the prebuilt Linux 2.6 compatible installers http://www.sh.nu/download/nvidia/linux-2.6 to perform a complete installation.
zander is offline   Reply With Quote
Old 01-13-04, 12:17 PM   #3
ManixT
Registered User
 
Join Date: Jun 2003
Posts: 6
Default

I built the package you specified with the exact same results as before. Perhaps there's something wrong with the method I use? Since the easliest versions it's never given me any grief, anyway the method i use:
I extract the package with the --extract-only flag, cd into the usr/src/nv dir, make SYSINCLUDE=/usr/local/src/linux-2.6.0/include and that's it. Anyone have any other ideas?
ManixT is offline   Reply With Quote
Old 01-13-04, 12:46 PM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

You need to perform a complete installation using the aforementioned installer, just installing the kernel module is insufficient unless all other driver components are already in place, which clearly isn't the case on your system.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
GForce drivers installed...but dont work tomfullery NVIDIA Linux 6 09-22-02 08:23 AM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 10:16 PM

All times are GMT -5. The time now is 08:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.