Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-18-04, 07:04 AM   #1
cojniz
Registered User
 
Join Date: Jan 2004
Location: Sweden
Posts: 2
Default nVIDIA driver & Mandrake 9.2

I recently installed Mandrake 9.2 RC1 for AMD64 and it's all running fine so I was about to install the nvidia driver for my GF4 MX.
I downloaded and installed the kernelsource and also downloaded nvidia glx and nvidia kernel. nvidia glx compiles fine but I can't figure out how to compile the nvidia kernel. It gives an error telling me what to do but I have no idea on how to perform those actions.
Anyone care to tell me what to do?

/usr/include/linux/version.h:2:2: #error "================================================= ======"
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/version.h:35:2: #error "================================================= ======"
cojniz is offline   Reply With Quote
Old 01-18-04, 10:58 AM   #2
Richard_JN
Registered User
 
Join Date: Jan 2004
Posts: 6
Default

I can't tell you how to use the mandrakeclub nvidia rpms, but all I had to do was this:

Install the relevant kernel. Get the kernel source.
Install NVIDIA's driver (from www.nvidia.com)

follow the instructions in the readme - mainly:
go to a text console
login as root
init 3 (stop the GUI)
sh NVIDIA-Linux-x86-1.0-5328-pkg1.run
fillow instructions
reconfigure /etc/X11/XF86Config-4
init 5 (start the GUI)

Nb:

Each time you change kernel, you'll need to re-run this.
It may be worth printing the readme before you start.
Save your old XF86Config-4 (and your new one - if you run the mandrake X config tool again, you'll overwrite it.
I did this on a P4 - it should be fine on an AMD - but I have no actual knowledge.
Remember, when you add a kernel using urpmi, it will end up as an option in /etc/lilo.conf, but you'll have to run lilo to get it to appear in the boot menu. If you want it to be default, edit /etc/lilo.conf


Richard
Richard_JN is offline   Reply With Quote
Old 01-18-04, 11:09 AM   #3
cojniz
Registered User
 
Join Date: Jan 2004
Location: Sweden
Posts: 2
Default

the reason I use these tarballs is that it's the only driver for AMD64 platform. So using the .run file isn't an option.
cojniz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 10:03 AM
NVIDIA Driver Installation flores.facundo NVIDIA Linux 2 06-24-12 08:37 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 02:10 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.