Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-14-04, 01:00 PM   #1
gnumdk
Registered User
 
Join Date: Jul 2003
Posts: 32
Unhappy Please make frame buffer and Gforce 4 working again!

I've got a Gforce 4:

Model: GeForce4 MX 440
IRQ: 10
Video BIOS: 04.17.00.45.00
Card Type: AGP

I use NVagp and not agpgart.
I use Vesa frame buffer.

With drivers <= 4363, framebuffer works.
With drivers > 4363, framebuffer works but after X is started, if i go to console, i've got strange char on screen...

So i always use 4363 drivers version

I have tested with drivers > 4363 and GeForce FX 5200 and it works, same with a TNT2.

I know two people who have a Geforce 4 and they have the same problem :-/
gnumdk is offline   Reply With Quote
Old 01-17-04, 04:31 AM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

Corruption (the strange chars) on the framebuffer, or even on text consoles, after X has started seems common with the mx440 cards. Searching the forum for posts regarding this shows several threads that discuss it. No real fix, but you could:
-compile the kernel without agpgart at all, no module to ensure it doesn't load first
-use Zander's patched nvidia drivers, check www.minion.de
-disable acpi and apm
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 01-17-04, 06:08 PM   #3
rengels
Registered User
 
Join Date: Jan 2004
Location: Germany
Posts: 10
Default yes, funny

Hi,
yes. funny that Nvidia has such problems with the console.

A fix that I used is to switch of the TV output via Option "IgnoreDevice" "TV"
This always works, but of course you can't view videos on the TV after this (even if you start another x-server)

The new 5... driver seems to fix it though, but I have a lot of other funny issues with it.
rengels is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:46 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.