Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-22-03, 01:21 PM   #1
w32.nimda
Registered User
 
Join Date: Oct 2003
Location: in front of my computer
Posts: 4
Default suse linux 9.0 & nvidia driver 5328

Hello!
i have got one question about the new 5328 driver...
when i install ist, it says to run sax to configure 3d acceleration. when i try to start the 3d acceleration, sax says:
Quote:
To activate the 3D subsystem for this card you need to
use the commercial driver from nVidia. Please download
the nVidia installer from the nVidia web server (http://
www.nvidia.com) first. After you have installed the
driver you can enable 3D with Sax2.
please can someone explain? I already installed the driver twice and more times!
__________________
My config:
AMD AthlonXP 1800+
ECS K7S5A
IBM ICVL060 60GB
GeForce4 MX440 (4x AGP)
SuSE Linux 9.0 Professional

I hate Microsoft
w32.nimda is offline   Reply With Quote
Old 12-22-03, 08:46 PM   #2
thunderace
Registered User
 
Join Date: Jan 2003
Location: AZ, USA
Posts: 7
Default

1) Kernel sources must be installed and configured.

2) switch to runlevel 3 ("init 3")

3) Do not go to sax2 configuration, just type sax2 -m 0=nvidia (0 is a digit, not a letter!)

4) Sax still will ask you to configure your monitor, etc. just cancel out of that and startx.
NOTE: you might want to reboot before starting X-windows. I had to because my system gave me a font error.

5) When you see Nvidia splash screen while starting X means nvidia drivers enabled and you have 3D support.

6) Bottom line you don't have to enable 3D in sax2
__________________
SYSTEM
Mobo: Shuttle AK266-A
CPU: AMD XP 1800 @ 1750Mhz
HDD: WD Caviar 40Gig
HDD2: IBM 50Gig
Video: GeForce4 Ti4200
DVD: Sony 16X
CDR/W: Creative 40x16x8
Case: Antec 1080B 350watts
Ram: 512Mb PC 2100
OS: Suse 8.1
thunderace is offline   Reply With Quote
Old 12-23-03, 02:09 AM   #3
niki_iv
Registered User
 
Join Date: Dec 2003
Posts: 1
Default It is not that simple. Driver is crashing

Using athlon optimized kernel, driver is 'crashing' and sending crash info in /var/log/messages. It's 3D part is not working. Sorry, I am at work now using Windows, but later I will post full debug message.
I tried with preloaded driver module for Suse 9.0 and I compiled new one - same error.
niki_iv is offline   Reply With Quote
Old 01-19-04, 05:02 AM   #4
jedah
Vampire Saviour
 
jedah's Avatar
 
Join Date: Jan 2004
Posts: 31
Default

I have installed 53.28 and although Xserver starts with the NVIDIA logo,3D applications run extremely slow.I have an GeForce FX 5700 Ultra and I use SUSE9.0.I've tried Red Hat 9.0 and the Xserver won't start at all.I must admit that I haven't tried "sax2 -m 0=nvidia",but if someone sees the logo does not mean that 3D acceleration works
jedah is offline   Reply With Quote
Old 01-19-04, 09:40 AM   #5
Timothy_Shawn
Registered User
 
Join Date: Apr 2003
Posts: 17
Default

Same here, the Nvidia Splash Screen shows up but the 3D Support doesnt work.

Have a look in /etc/var/log/XFree86.0.log is there a line which says unknown Chipset?
Timothy_Shawn is offline   Reply With Quote
Old 01-19-04, 05:34 PM   #6
kmare
Registered User
 
Join Date: Jul 2003
Location: greece
Posts: 180
Send a message via ICQ to kmare
Default

Plz send your /etc/X11/XF86Config and /var/log/XFree86.0.log

Here I have suse9 and it is working great... (with self compiled kernel 2.6)
no crashes here... and I got about 7600 fps with glxgears

maybe you are using the nv driver (XFree86) and not the nvidia (NVIDIA) one...
kmare is offline   Reply With Quote
Old 01-19-04, 11:02 PM   #7
Timothy_Shawn
Registered User
 
Join Date: Apr 2003
Posts: 17
Default

Please have a look at this thread

LINK
Timothy_Shawn is offline   Reply With Quote
Old 01-21-04, 02:36 AM   #8
jedah
Vampire Saviour
 
jedah's Avatar
 
Join Date: Jan 2004
Posts: 31
Default

I've downloaded a patched version of the drivers from
http://www.sh.nu/download/nvidia/linux-2.4/
and everything is ok now.I highly recommend that 5700 Ultra users should download this file.Racer really rocks now!!Thanks for the support guys
jedah is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
GTX 460M, Xorg 1.12, nvidia driver 295.49, linux 3.3.5-1-ARCH and NVRM Xid 44 elsifaka NVIDIA Linux 0 05-14-12 08:48 AM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 12:52 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 12:31 PM

All times are GMT -5. The time now is 05:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.