Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-14-04, 10:21 AM   #1
chopper2577
Registered User
 
Join Date: Dec 2003
Posts: 2
Default Problem with NVIDIA-Linux-x86-1.0-5328

i try to install this package, but when i initialize the xwindows, i have this error message in my XFree86.0.log.

(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!


Linux distribution: Fedora Core 1
Video Card: NVIDIA GForce 4 MX420 64MB

******** XF86Config**************************************** **********

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
FontPath "/usr/X11R6/lib/X11/fonts/truetype/"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "la"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "MX70"
DisplaySize 320 240
HorizSync 30.0 - 70.0
VertRefresh 47.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
Attached Files
File Type: log xfree86.0.log (18.0 KB, 142 views)
chopper2577 is offline   Reply With Quote
Old 01-17-04, 05:41 AM   #2
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

If you set the Driver to "nv" and otherwise leave this config AS IS, does it work correctly?

If you boot to mode 3, edit /etc/inittab to change this, then try to insert the nvidia kernel module, do you get any errors then? Try this after a fresh reboot.
modprobe nvidia

After this, telinit 5 to go back to graphical mode. If it fails try to get the output of the dmesg command, and post it here.
__________________
"..the triumph of evil is for good men to do nothing." (Edmond Burke)
nVIDIA video driver RPMs for Fedora :: see yum repo at livna.org.
LordMorgul is offline   Reply With Quote
Old 01-18-04, 10:37 PM   #3
asdi
Registered User
 
Join Date: Jan 2004
Posts: 1
Thumbs up

I had the same error on red Hat 8.0.

modprobe nvidia displayed:
0: nvidia: Can't find an IRQ for your NVIDIA card!

Per the instructions I changed 2 BIOS settings:
Plug & Play OS: No
IRQ to VGA: Yes

And it works now.
Good Luck from a fellow newbie.
asdi is offline   Reply With Quote
Old 01-21-04, 07:58 PM   #4
chopper2577
Registered User
 
Join Date: Dec 2003
Posts: 2
Talking

Thanks, now i can use the nvidia driver. it's work when i change, in my BIOS, like asdi said. Now i can saw the nvidia screen when fedora start.

chopper2577 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can NVIDIA better engage with Linux artem NVIDIA Linux 8 06-26-12 10:05 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 01:52 PM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 02:57 AM
download problem with linux NVIDIA driver packages Timo NVIDIA Linux 7 07-31-02 10:22 AM

All times are GMT -5. The time now is 05:13 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.