Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-30-02, 10:59 PM   #1
JoeJaz100
Guest
 
Posts: n/a
Default XF86COnifg-4 configuring and server crashes

I recently purchased a new Athalon XP 2200+ system with a GeForce 4 TI 4600 and have installed RedHat 7.3 on it. Red Hat runs fine in vesa mode, but I can't cofigure the XF86Config-4 file correctly... at least I think that is the problem. I used an rpm version of NVIDIA_kernel-1.0-3123.i686.rpm and NVIDIA_GLX-1.0-3123.i386.rpm. I followed the Nvidia helpfile as best as I could, but I still have no luck. I am thinking that I am missing a command in the /etc/modules.conf file to load the nvidia driver, but I don't know for sure. When I make the changes in my XF86Config-4 file (ie commenting out the "GLore" and "dri" modules, inserting the "glx" module, and inserting the "nvidia" driver line in the Graphics Device Section as indicated by the documentation), and start X, the server crashes and says that my screens are causing a problem. I have gotten a GeForce2 Go work on a Dell Laptop, so I know that it shouldn't be too bad to install the drivers for my new system. However, none of the documentation that I can find has resolved my problem so far. I really don't want to have to run X in framebuffer mode when I have the power of a GeForce 4 at my disposal. If anyone has any suggestions, I would be very greatful. Attached is a copy of my XF86Config-4 file with my /etc/modules.conf file appended to the end. Thanks
Attached Files
File Type: txt xf.txt (4.1 KB, 168 views)
  Reply With Quote
Old 10-01-02, 01:38 AM   #2
NVLinux
Registered User
 
Join Date: Oct 2002
Posts: 8
Default

CHeCK your RPM packages..make sure they are for your CPUs...
NVLinux is offline   Reply With Quote
Old 10-01-02, 09:49 AM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

First off, try the simple stuff. modprobe NVdriver as root, and if it prints out any errors, what are they? If they're "symbol not found" or similar, then you've probably installed the wrong NVIDIA_kernel RPM. Download the nv_chooser script off the driver download page and run it; it should tell you which RPM to use. If you don't get errors, continue on to:

What does [ -c /dev/.devfsd ] ; echo $? print? If it prints a 0, you're using devfs; if it prints a 1, you aren't.

If you are using devfs, then change the alias char-major-195 NVdriver line in /etc/modules.conf to alias /dev/nvidia* NVdriver. And get rid of the NVdriver line at the end, that's not even the right syntax for this file.

If you aren't using devfs, then check to see that the /dev/nvidia* devices exist -- ls /dev/nvidia*. If they don't, then you'll have to create them. And if youre not using devfs, the "NVdriver" line is still the wrong syntax for this file; get rid of it.

If you make changes to modules.conf, run depmod -a (as root) to update cache files and stuff, then try loading X (with the nVidia drivers being used).
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with configuring monitors and keeping them disabled with 302.17 Erosmith NVIDIA Linux 2 06-20-12 12:10 AM

All times are GMT -5. The time now is 11:49 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.